Go to advanced search

by thunderfoot
Fri Aug 10, 2018 9:33 pm
Forum: Advanced users
Topic: Put LAN9514 into SUSPEND0 Mode?
Replies: 0
Views: 161

Put LAN9514 into SUSPEND0 Mode?

Hi, I am investigating ways of trying to reduce power consumption from the LAN9514 chip. I have seen some discussion on methods to enable/disable the bus completely, such as here: https://www.raspberrypi.org/forums/viewtopic.php?t=62411 However, I am wondering if there is a way to put the LAN9514 in...
by thunderfoot
Fri Mar 09, 2018 7:17 pm
Forum: Compute Module
Topic: Design info for adding Ethernet to CM
Replies: 23
Views: 8801

Re: Design info for adding Ethernet to CM

One thing related to this I'm not entirely clear on, and would appreciate clarification: If I configure the LAN_RUN pin in my dt-blob like so (replacing XX with the desired GPIO pin number): [email protected]_RUN { type = "internal"; number = <XX>; }; And hook this up appropriately to a LAN9512/4, will...
by thunderfoot
Mon Feb 19, 2018 8:46 am
Forum: Compute Module
Topic: Okay to place components under Compute Module?
Replies: 2
Views: 810

Re: Okay to place components under Compute Module?

Thanks mic_s, that's a good point for a power hungry component such as LAN9512/4.
by thunderfoot
Fri Feb 16, 2018 6:31 pm
Forum: Compute Module
Topic: Okay to place components under Compute Module?
Replies: 2
Views: 810

Okay to place components under Compute Module?

Hi, I have a project in the works that incorporates the CM3, so far it has been a great choice. I was wondering what the best practice is regarding the placement of components on a custom carrier PCB "underneath" the CM3? I see for example on the official CMIO board there are a few resistors there, ...
by thunderfoot
Mon Sep 25, 2017 8:38 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

The only thing that is still a little odd, is that it seems to boot with a lower resolution on my carrier board than when the same CM3 is booted using the CMIO board. Any explanation for the difference there?

Thanks!
by thunderfoot
Mon Sep 25, 2017 8:33 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

Ahhhh.... I disabled the login shell over serial, and it booted like a charm!! This one threw me for a loop when it shouldn't have. The ESD5384 is the first BGA component I've assembled by hand, so I was suspicious of the HDMI interface right off the bat. And with the "flickering" symptoms I went do...
by thunderfoot
Mon Sep 25, 2017 8:17 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

PhilE, when I open /boot/cmdline.txt I see two occurrences: console=serial0,115200 console=tty1 Do I need to disable something here? In my earlier (non-RPi) prototypes, my application firmware used flow control to enable/disable the RX as needed to prevent transmissions echoing right back in. To be ...
by thunderfoot
Mon Sep 25, 2017 7:39 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

I have now isolated the issue, but am still searching for a solution. The problem with the "flickering" on boot is being triggered because I have a peripheral that uses a single-wire (half-duplex) UART interface connected to UART0 (GPIO 14 & 15). Since it is a single-wire interface, I have the TX an...
by thunderfoot
Thu Sep 21, 2017 4:57 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

I should also add that before changing the kernel7.img name, I tried changing the screen resolution options using raspi-config (down to 640x480). When rebooting I could see the new resolutions were applied, but it didn't appear to have any change on the flickering behavior.
by thunderfoot
Thu Sep 21, 2017 4:54 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

PhilE, I think you may be on to something! I changed kernel7.img to kernel_no.img using the CMIO board, plugged the CM3 back into my custom carrier, and I get the rainbow screen (with no flickering)! I am wondering if perhaps I have gone a bit out of order in bringing up my new board... I haven't ye...
by thunderfoot
Thu Sep 21, 2017 4:59 am
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

Another interesting clue... on a suggestion from a more experienced EE, I wanted to try heating and cooling the BCM2837 in case this would resolve some timing corner-case failure. I had to order some cooling spray, but I do have a hot air rework station. From a safe distance, I began warming the IC....
by thunderfoot
Thu Sep 21, 2017 12:55 am
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

One other small update... After digging up a higher quality HDMI cable, I was able to get my small MustHD monitor to recognize the CM3 via my carrier board. However, the flashing during (long) boot behavior is still there and the same as with my larger ASUS monitor.
by thunderfoot
Wed Sep 20, 2017 6:47 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

I sent Gordon an email with the HDMI schematic. I tried removing the Q4 equivalent on my board, but it doesn't seem to have changed the behavior. I don't have the AP2331 installed, but I do still have a 5V line connected to pin 18, and used as a pullup (via the ESD5384) on the I2C lines. I somehow m...
by thunderfoot
Tue Sep 19, 2017 10:35 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

Thanks for the input, guys. In performing more debugging today I've had some significant updates to report that will hopefully help narrow down what is happening. I noticed in a forum post https://www.raspberrypi.org/forums/viewtopic.php?p=597206 that one person said it took ~7mins for their CM to b...
by thunderfoot
Tue Sep 19, 2017 4:56 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Re: Flickering HDMI on custom CM3 board

Someone else pointed out to me how in the video of my issue, the screen is flickering between the expected boot display, and an underscore in the top left corner of the screen. If it was purely an HDMI issue, one would expect it to flicker between the expected display and a blank screen. I've tried ...
by thunderfoot
Mon Sep 18, 2017 8:35 pm
Forum: Compute Module
Topic: Flickering HDMI on custom CM3 board
Replies: 22
Views: 4518

Flickering HDMI on custom CM3 board

Hi all, I've just assembled prototypes of my first custom PCB designed to work with the Compute Module 3, but I am having an issue with the HDMI. It is flickering heavily, to the point that it is not usable. Please see a short video of the issue here: https://drive.google.com/file/d/0B5TLOoVbEU1cUTh...

Go to advanced search