Go to advanced search

by salvaliebana
Wed Mar 06, 2019 10:20 pm
Forum: Other projects
Topic: My "portable" etcher port for Rpi 3b+
Replies: 9
Views: 509

Re: My "portable" etcher port for Rpi 3b+

There was no contribution on that comment. He said that just to pull dowm my effort. I dont get it. I bring a solution ... a GUI solution and you all are criticized me because of minor thing than doesnt have sence. I will get an odroid . I am done with rpi
by salvaliebana
Wed Mar 06, 2019 6:26 pm
Forum: Other projects
Topic: My "portable" etcher port for Rpi 3b+
Replies: 9
Views: 509

Re: My "portable" etcher port for Rpi 3b+

Yes, and be honest... It sucks. Thats why I preffer using etcher on my pi.
by salvaliebana
Wed Mar 06, 2019 5:25 pm
Forum: Other projects
Topic: My "portable" etcher port for Rpi 3b+
Replies: 9
Views: 509

My "portable" etcher port for Rpi 3b+

Hi. I want to give a retribution to this forum. This help me a lot burnin images from my pi to my other pies.

https://youtu.be/tKbH6CEgtU0


https://drive.google.com/file/d/1tbt4aQ ... sp=sharing

Hope you enjoy it.
by salvaliebana
Tue Mar 05, 2019 10:46 am
Forum: Troubleshooting
Topic: GDB Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Replies: 3
Views: 473

Re: GDB Backtrace stopped: previous frame identical to this frame (corrupt stack?)

should I compile binutils-gdb from source to avoid conflicts?
by salvaliebana
Tue Mar 05, 2019 10:05 am
Forum: Troubleshooting
Topic: GDB Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Replies: 3
Views: 473

Re: GDB Backtrace stopped: previous frame identical to this frame (corrupt stack?)

its in C++ https://github.com/OpenMW/openmw The dev told me than maybe it was ffmpeg that isnt compiled with debug, I compile it again with debug and it didnt fix the problem why ffmpeg? swscaler calls the crash handler. its an ffmpeg swscaler sigbus. one thing, ive compiled openmw with gcc 8.1 and ...
by salvaliebana
Tue Mar 05, 2019 9:53 am
Forum: Troubleshooting
Topic: GDB Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Replies: 3
Views: 473

GDB Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Hi!! I need to debug an SIGBUS error to report the results to the devs but i cant backtrace my game. Thread 8 "openmw" received signal SIGBUS, Bus error. [Switching to Thread 0x6feff1e0 (LWP 5788)] 0x7513b63c in ?? () from /usr/local/lib/libswscale.so.5 (gdb) bt #0 0x7513b63c in ?? () from /usr/loca...
by salvaliebana
Sun Mar 03, 2019 9:36 pm
Forum: Gaming
Topic: DOOM 3 on the RPI3 , another aproach
Replies: 0
Views: 324

DOOM 3 on the RPI3 , another aproach

Hi, ive tested this game many times under mesa. The games run at decent fps at lower resolutions. the problem are the arbs shaders than doesnt work properly on anholt driver. but i get different results on different mesa's. target repo: dhewm3 why not dante? because it works fast as hell on the pi. ...
by salvaliebana
Sun Mar 03, 2019 6:52 pm
Forum: Troubleshooting
Topic: export a lib on program execution
Replies: 5
Views: 232

Re: export a lib on program execution

My idea its to drag the original mesa 13 libs on raspbian and set that as secondary gl libs, because mesa 19 has great features, but has a lot of "regressions" . another idea its just test different mesa builds just for testing porpoise.
by salvaliebana
Sun Mar 03, 2019 6:48 pm
Forum: Troubleshooting
Topic: export a lib on program execution
Replies: 5
Views: 232

Re: export a lib on program execution

Ok, I found this instructions on Anholt wiki: If you're interested in hacking on the Mesa driver, you'll want to build your own copy of Mesa. And since Mesa is a system component and you won't want to break your desktop if you make a mistake, you will want to do it without replacing your system Mesa...
by salvaliebana
Thu Feb 28, 2019 1:40 pm
Forum: Troubleshooting
Topic: reverting from usb boot mode configuration
Replies: 3
Views: 133

Re: reverting from usb boot mode configuration

Yes. I clone my sd card. Thats ok right now with yournexplanation. I will try to solve the issue with my hhd. The fstab rule doesnt work for now. It keeps tryijg to mount it on /boot. The hdd was part of the usb boot experiment...
by salvaliebana
Thu Feb 28, 2019 1:23 pm
Forum: Troubleshooting
Topic: reverting from usb boot mode configuration
Replies: 3
Views: 133

Re: reverting from usb boot mode configuration

Yes. I clone my sd card. Thats ok right now with yournexplanation. I will try to solve the issue with my hhd. The fstab rule doesnt work for now. It keeps tryijg to mount it on /boot. The hdd was part of the usb boot experiment...
by salvaliebana
Thu Feb 28, 2019 1:55 am
Forum: Troubleshooting
Topic: reverting from usb boot mode configuration
Replies: 3
Views: 133

reverting from usb boot mode configuration

After a couple of mounths trying to resolve this issue from here https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=221271 . i cant find the way to finally resolve this issue. There its another mounting setup hidding somewhere else but its not fstab. it happen when I use my HHD (than I use to b...
by salvaliebana
Wed Feb 27, 2019 5:33 am
Forum: Advanced users
Topic: The dtoverlay=vc4-kms-v3d overlay and memory allocation
Replies: 6
Views: 744

Re: The dtoverlay=vc4-kms-v3d overlay and memory allocation

I found than cma its at256 by default. I will try your cmd line. But maybe the overlay will ignore that by default because the max cma option inside the overlay dtb its 256. I will try to edit the dtb if thats the case. Thanks!
by salvaliebana
Tue Feb 26, 2019 1:04 am
Forum: Troubleshooting
Topic: export a lib on program execution
Replies: 5
Views: 232

Re: export a lib on program execution

I will try those solutions, thanks!!
by salvaliebana
Mon Feb 25, 2019 3:41 am
Forum: Troubleshooting
Topic: export a lib on program execution
Replies: 5
Views: 232

export a lib on program execution

Hi everyone! I update my mesa and gles support its not working as expected. a lot of opengl projects where great but other not. i want to use my old library of gles on a different location for some apps. i create a sh for my game in this way: #!/bin/sh export LD_LIBRARY_PATH=/opt/vc/lib/libbrcmGLESv...
by salvaliebana
Sun Feb 24, 2019 5:54 pm
Forum: Advanced users
Topic: The dtoverlay=vc4-kms-v3d overlay and memory allocation
Replies: 6
Views: 744

Re: The dtoverlay=vc4-kms-v3d overlay and memory allocation

I did precaching on legacy driver (under retropie) of huge amounts on hd textures and never has this issue. that because the gpu/cpu memory splits actually works... but with the overlay its different in some way. gpu_mem doesnt affect it (by obvious reasons) and even get the things worst. dont know ...
by salvaliebana
Sun Feb 24, 2019 5:45 pm
Forum: Advanced users
Topic: The dtoverlay=vc4-kms-v3d overlay and memory allocation
Replies: 6
Views: 744

Re: The dtoverlay=vc4-kms-v3d overlay and memory allocation

I am running out of memory on some games, they hang on precaching. I need more ram for my vc4 overlay. dont know how it works as an overlay on memory allocation, I just need more ram to it nad these are some tips than some advance users gave me. by default its set to 64, i tried 256 but i am running...
by salvaliebana
Sat Feb 23, 2019 9:43 pm
Forum: Advanced users
Topic: The dtoverlay=vc4-kms-v3d overlay and memory allocation
Replies: 6
Views: 744

The dtoverlay=vc4-kms-v3d overlay and memory allocation

Hi everyone!! The problem its than I need to add more memory to the dtoverlay vc4-kms-v3d overlay and I tried by three ways. 1) with "dtoverlay=vc4-kms-v3d,cma-256" on config.txt 2) with "[email protected]" on cmdline.txt 3)both none of these "solutions" give me any help on this topic. I use gpu_mem=64 ...
by salvaliebana
Mon Dec 10, 2018 5:48 pm
Forum: Gaming
Topic: Run Windows recompiled ARM binaries on raspbian with WINE [does not work]
Replies: 20
Views: 6072

Re: Run Windows recompiled ARM binaries on raspbian with WINE [does not work]

SORRY, I made a lot of progress on this. i made my own build of raspbian to run wine natively and even rufus works. check my youtube channel please.
by salvaliebana
Sun Sep 16, 2018 10:18 pm
Forum: Troubleshooting
Topic: error on auto-mounting ntfs drive
Replies: 25
Views: 1834

Re: error on auto-mounting ntfs drive

I checked my hhd on a clean raspbian image and it works as expected. just plug in and it shows up...soo.. there is something more i can try to save my older image?? some test you need. I think there its a bug created by the "booting from usb" experiment. i shame than I removed my raspbian backup bef...
by salvaliebana
Thu Aug 30, 2018 4:16 am
Forum: Troubleshooting
Topic: error on auto-mounting ntfs drive
Replies: 25
Views: 1834

Re: error on auto-mounting ntfs drive

Yes, you are right. but I am making some projects on my pi right now... I cant try any risky solution right now. My other sd card isnt on great shape, just horrible copy/write speeds. So, I will try my HHD on a new sd with the latest raspbian on the next mount and I will comment my result. Thanks du...
by salvaliebana
Wed Aug 29, 2018 9:52 pm
Forum: Troubleshooting
Topic: error on auto-mounting ntfs drive
Replies: 25
Views: 1834

Re: error on auto-mounting ntfs drive

I will keep mounting it manually or traying to create a rule on fstab. its unsolved...but i wont continue this..

thanks anyway!
by salvaliebana
Wed Aug 29, 2018 9:48 pm
Forum: Troubleshooting
Topic: error on auto-mounting ntfs drive
Replies: 25
Views: 1834

Re: error on auto-mounting ntfs drive

Sorry, there was an error on copy paste. my hhd its mmcblk0. And my concerns where right, changing fstab like this just crush my raspbian. so, i get another sd and remove the changes...

/dev/mmcblk0p1 /boot vfat defaults 0 2

/dev/mmcblk0p2 / ext4 defaults 0 1

Go to advanced search