Go to advanced search

by dirdled
Sat Apr 04, 2020 4:46 am
Forum: Weather station
Topic: Help with DS18B20 wiring.
Replies: 14
Views: 243

Re: Help with DS18B20 wiring.

Ok, now I've tried a number of other pins I'm not sure what I did wrong the first time I tried setting up an alternate 1-Wire pin, but all of them that I've tried work fine, except the default...That's great I have a work-around that I can use, but now I want know what is wrong with the default pin ...
by dirdled
Fri Apr 03, 2020 5:10 pm
Forum: Weather station
Topic: Help with DS18B20 wiring.
Replies: 14
Views: 243

Re: Help with DS18B20 wiring.

Move data to PIN18(GPIO24) Then type Code: Select all sudo dtoverlay w1-gpio gpiopin=24 pullup=0 Wait and see if you see anything being found in the one wire place. (I know you have done it before) That worked fine...and I tried it just moving the data wire from pins 4 to pin 24. So for some reason...
by dirdled
Thu Apr 02, 2020 10:04 pm
Forum: Weather station
Topic: Help with DS18B20 wiring.
Replies: 14
Views: 243

Re: Help with DS18B20 wiring.

Here's the rundown of additional things I've checked tested the DS18B20 - It was fine tried a different DS18B20 - same result re-checked(and re-did) all the wiring - looked OK Verified that the power getting to the DS18B20 - 3.29 V Verified that the power was correct - ground to ground pin, etc Veri...
by dirdled
Wed Apr 01, 2020 10:36 pm
Forum: Weather station
Topic: Help with DS18B20 wiring.
Replies: 14
Views: 243

Re: Help with DS18B20 wiring.

Hi everyone, Has anyone had any luck getting a ds18b20 to work on a pi4? I've been trying to do the same thing and I can't find the device in /sys/bus/w1/devices. I've set this up on multiple other Raspberry Pis without a problem, but this is the first Raspberry Pi 4 that I've tried. I've tried a co...
by dirdled
Thu Aug 24, 2017 1:45 am
Forum: Troubleshooting
Topic: Problem with SPI after updating to Stretch - RESOLVED
Replies: 7
Views: 4003

Re: Problem with SPI after updating to Stretch - RESOLVED

Hmm, I looked at your data sheet and it comes right out and says High-SpeedSPIInterface(MCP23S17): - 10MHz(maximum) for mine it's a little more cryptic for the MCP3008. If I'm looking at the right place it looks like it says the Clock Frequency is either 3.6 or 1.35 Mhz based on the Vdd Is there a b...
by dirdled
Thu Aug 24, 2017 1:30 am
Forum: Troubleshooting
Topic: Problem with SPI after updating to Stretch - RESOLVED
Replies: 7
Views: 4003

Re: Problem with SPI after updating to Stretch

Very cool...All bow to the big brain on Bulletmark...That seems to have fixed it, I added one line spi.max_speed_hz = 5000 Immediately following the spi.open command and it seems to be working now...I'll report back if I find out differently. Just curious but how do I know what a good value would be...
by dirdled
Thu Aug 24, 2017 12:47 am
Forum: Troubleshooting
Topic: Problem with SPI after updating to Stretch - RESOLVED
Replies: 7
Views: 4003

Re: Problem with SPI after updating to Stretch

I hope this answers what you're asking
The kernel version is Kernel version: Linux 4.9.43-v7+ armv7l
and the SPI Lib Im using is

I'm not sure how to find a version of spidev
by dirdled
Wed Aug 23, 2017 8:31 pm
Forum: Troubleshooting
Topic: Problem with SPI after updating to Stretch - RESOLVED
Replies: 7
Views: 4003

Problem with SPI after updating to Stretch - RESOLVED

Hi, I've updated my trusty Raspberry pi 2 to stretch, and now I can't get one of my staple scripts to work. It's a python script that accesses an mcp3008 to monitor light and temperatures. the SPI interface says it's on, and the script runs without any errors, but the calls to the mcp3008 are all re...

Go to advanced search