Go to advanced search

by nfstoney
Thu Oct 18, 2018 6:55 am
Forum: General discussion
Topic: Load new URL, edit URL in chromium-browser with command line
Replies: 4
Views: 822

Re: Load new URL, edit URL in chromium-browser with command line

I solved this problem.
The Website is loaded in a iframe on an own website where is a js running. The js gets the new url from a xdotool or similar.
by nfstoney
Sat Oct 13, 2018 8:39 pm
Forum: General discussion
Topic: Touch-Events
Replies: 0
Views: 147

Touch-Events

Hello I would like to write a C-programm for raspbian. The programm should simulate touch-events (touchstart, touchmove, touchend). I have already a program that simulates mouse-events. There is no touch-controller or mouse connected to the raspi. I have two options: - Can the system (raspbian) conv...
by nfstoney
Fri Oct 12, 2018 7:52 am
Forum: Beginners
Topic: USB-Cam Streamview on Website
Replies: 0
Views: 115

USB-Cam Streamview on Website

Hello I have an USB-Cam connected on my Raspberry (Raspbian Stretch). With the VLC I can get video-stream from the device /dev/video0. On the basis of this behavior I know that the cam basically do the job. My target is to implement the stream-data from the cam in a webpage. For this I write this ja...
by nfstoney
Thu May 03, 2018 6:47 am
Forum: General discussion
Topic: Load new URL, edit URL in chromium-browser with command line
Replies: 4
Views: 822

Re: Load new URL, edit URL in chromium-browser with command line

The xdotool is useless in this case. All what xdotool can do is the same that I can do with mouse and keyboard. I can't change url in chromium appmode with mouse and keyboard. In the app-mode of chromium-browser there is no possibility(F6) to give the focus to the omnibox(url-inputfield) because the...
by nfstoney
Wed May 02, 2018 3:14 pm
Forum: Deutsch
Topic: GPIO from shell script
Replies: 3
Views: 510

Re: GPIO from shell script

Hallo

Wie sind die Ports Definiert wenn du
raspi-gpio get (sudo apt-get install raspi-gpio, falls noch nicht installiert)
aufrufst.

Was passiert mit den GPIO wenn du diese mit raspi-gpio manipulierst?
Erscheinen dann auch Fehlermeldungen?

Gruss nfstoney
by nfstoney
Wed May 02, 2018 2:45 pm
Forum: General discussion
Topic: Load new URL, edit URL in chromium-browser with command line
Replies: 4
Views: 822

Load new URL, edit URL in chromium-browser with command line

Hello I start chromium in app mode with a web-address in command line: chromium-browser --app=http://www.ride.ch At runtime I would like to edit the url of this chromium-browser in command line. I don't want to close the chromium-browser and starti it new with the new url. I want to avoid long start...
by nfstoney
Fri Dec 15, 2017 3:33 pm
Forum: Compute Module
Topic: uSDCard can't mount after Boot Raspi over USB
Replies: 8
Views: 1241

Re: uSDCard can't mount after Boot Raspi over USB

You did it!

Add the startup_state = "active" to the pin 129 and remove the activitiy led section from the kernel device tree let the SDCard be mount after bootup from USB.

Many thanks for your help.
by nfstoney
Fri Dec 15, 2017 1:06 pm
Forum: Compute Module
Topic: uSDCard can't mount after Boot Raspi over USB
Replies: 8
Views: 1241

Re: uSDCard can't mount after Boot Raspi over USB

Firstly do not touch GPIO47 on a CM3L. Refer to the schematics. Whilst on the CM1 GPIO47 is used for EMMC_EN_N_1V8 (as shown in Figure 1 of the datasheet), on CM3/CM3L a GPIO off an expander is used (as shown in Figure 2). GPIO47 is used for other purposes and messing with it will cause issues. You...
by nfstoney
Thu Dec 14, 2017 5:14 pm
Forum: Compute Module
Topic: uSDCard can't mount after Boot Raspi over USB
Replies: 8
Views: 1241

Re: uSDCard can't mount after Boot Raspi over USB

Many thanks for your answer,

after adding "dtparam=act_led_trigger=none" to config.txt
The GPIO47 is driven high.

Your link don't give more information to solve the problem.

I need some commands to control the gpio47 (set high/set low) while the system is running.
by nfstoney
Thu Dec 14, 2017 4:14 pm
Forum: Compute Module
Topic: uSDCard can't mount after Boot Raspi over USB
Replies: 8
Views: 1241

uSDCard can't mount after Boot Raspi over USB

Hello, I boot up my CM3L-Module in the IO Board over an image on USB. After booting the uSDCard don't mount and I can't use as mass storage. In the manual for CM3L there is a hint to this issue: Note that once booted over USB, BCM2837 needs to re-enable the SD/eMMC device (by releasing EMMC DISABLE ...
by nfstoney
Fri Oct 13, 2017 7:06 am
Forum: Beginners
Topic: raspidmx
Replies: 3
Views: 541

Re: raspidmx

I copied manually the missing lib from the raspidmx lib-folder to the raspi lib folder /lib/

Now, it works.
by nfstoney
Fri Oct 13, 2017 6:51 am
Forum: Beginners
Topic: raspidmx
Replies: 3
Views: 541

Re: raspidmx

File permissions checked. --> 777
by nfstoney
Thu Oct 12, 2017 4:00 pm
Forum: Beginners
Topic: raspidmx
Replies: 3
Views: 541

raspidmx

Hello I play around with the program examples. https://github.com/AndrewFromMelbourne/raspidmx I installed according Andrew: - first install the libpng12-dev - make in the top level directory To start the program (for example rgb_triangle) - run lxterminal - go to directory cd /raspidmx-master/rgb_t...
by nfstoney
Wed Oct 11, 2017 1:25 pm
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1507
Views: 609848

Re: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)

How did you solve it?
by nfstoney
Wed Oct 11, 2017 12:25 pm
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1507
Views: 609848

Re: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)

I give you a screenshot from an other system where it is running according my descriptions.
Example.JPG
Example.JPG (249.75 KiB) Viewed 4065 times
The transparent menu is a website over the whole screen.
by nfstoney
Wed Oct 11, 2017 11:47 am
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1507
Views: 609848

Re: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)

I don't would like to give the video a transparency. I would like to give the browsercontent or the whole browser a transparency because this content is over the video. My problem to your first hint is that the white background of the browser which is over the video should be replaced to a full tran...
by nfstoney
Wed Oct 11, 2017 8:40 am
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1507
Views: 609848

Re: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)

Hello, I have a question about a example of use. To check if it's possible to solve my issue with kweb. The kweb is very powerfull tool and can use for lots of use cases. Too much cases for a fast overview. I would like to play a audio/video-stream in omxplayer fullsize (hw accelerated) and overlay ...
by nfstoney
Fri Oct 06, 2017 12:19 pm
Forum: Raspbian
Topic: chromium-browser source code
Replies: 14
Views: 2963

Re: chromium-browser source code

Should be here. Updated to latest Stretch version today. https://github.com/raspberrypi-ui/chromium_patches On the linked website there I find "Patches to apply to vanilla Chromium browser source to enable hardware acceleration" But, where can I find vanilla Chromium Browser Source Code for Raspber...
by nfstoney
Thu Sep 28, 2017 8:49 am
Forum: Beginners
Topic: Accelerated VLC on another display
Replies: 4
Views: 554

Re: Accelerated VLC on another display

Raspbian is shown on official Touchscreen. I wan't to show the vlc video on the HDMI-Screen.

with the omxplayer I use the following command:
omxplayer -o local rtp://239.186.68.2:10000 --display 5 --layer 0

I think there should be an similar command for vlc.
by nfstoney
Tue Sep 26, 2017 3:08 pm
Forum: Beginners
Topic: Accelerated VLC on another display
Replies: 4
Views: 554

Accelerated VLC on another display

Hello

Is there a possibility to run VLC via command line and send the video to another display and layer according the omxplayer

Code: Select all

omxplayer -o local rtp://239.186.68.2:10000 --display 5 --layer 0
by nfstoney
Tue Sep 26, 2017 8:54 am
Forum: Advanced users
Topic: Browsercontent show on a GPU accelerated layer
Replies: 4
Views: 1224

Re: Browsercontent show on a GPU accelerated layer

Hello After starting problems I can show the browser (with alpha channel) over an omxplayer on a Raspi 3 hardware (only for testing this try) with an HDMI- and DSI-Display. Is it possible to start raspbian on a display which isn't connected (HDMI or DSI)? The Desktop would be show on this non-connec...
by nfstoney
Fri Sep 22, 2017 12:35 pm
Forum: Advanced users
Topic: Browsercontent show on a GPU accelerated layer
Replies: 4
Views: 1224

Re: Browsercontent show on a GPU accelerated layer

Many thanks for your hint with raspi2raspi.

I have another setup than you expected.
My standard display is 4 (DPI).
How can I run chromium-browser on a other display (0)?

Or did I something misunderstand?
by nfstoney
Fri Sep 22, 2017 8:31 am
Forum: Advanced users
Topic: Browsercontent show on a GPU accelerated layer
Replies: 4
Views: 1224

Browsercontent show on a GPU accelerated layer

Hello I want to show browsercontent on a GPU accelerated layer. The layer number should be free selectable. The target is to run a video with omxplayer and overlay a browsercontent (layer number higher than omxplayer) over the video with alpha-channel. So the video is still visible through the brows...
by nfstoney
Fri Sep 08, 2017 9:14 am
Forum: Device Tree
Topic: GPIO set high/low with dtoverlays
Replies: 1
Views: 1344

GPIO set high/low with dtoverlays

Hi, I would like to set some GPIOs in a dtoverlay with the following code: /dts-v1/; /plugin/; / { compatible = "brcm,bcm2708"; [email protected] { target = <&gpio>; __overlay__ { on_pins: on_pins { brcm,pins = <28 29 34 35>; brcm,function = <1 1 1 1>; brcm,pull = <0 0 0 0>; }; }; }; }; The problem I have,...
by nfstoney
Thu Sep 07, 2017 1:58 pm
Forum: Device Tree
Topic: GPIO set high/low with dtoverlays
Replies: 0
Views: 863

GPIO set high/low with dtoverlays

Hi, I would like to set some GPIOs in a dtoverlay with the following code: /dts-v1/; /plugin/; / { compatible = "brcm,bcm2708"; [email protected] { target = <&gpio>; __overlay__ { on_pins: on_pins { brcm,pins = <28 29 34 35>; brcm,function = <1 1 1 1>; brcm,pull = <0 0 0 0>; }; }; }; }; The problem I have,...

Go to advanced search