Go to advanced search

by wilbe
Thu Jul 06, 2017 7:00 am
Forum: Troubleshooting
Topic: /dev/ttyUSB0 Serial Port Not working
Replies: 7
Views: 20887

Re: /dev/ttyUSB0 Serial Port Not working

After contacting Xojo, my code was at fault in my app, somehow the port was not being opened when the app starts up. In order to test if the port works just type cat /dev/ttyUSBn in the console. "n" being the USB number associated with the device. If it returns the strings then you are good to go. :...
by wilbe
Fri Jun 30, 2017 11:57 am
Forum: Troubleshooting
Topic: /dev/ttyUSB0 Serial Port Not working
Replies: 7
Views: 20887

Re: /dev/ttyUSB0 Serial Port Not working

Dave, I reloaded Raspbian and tried my app again but with no success. The USB device is connected to ttyUSB0 Jun 21 10:55:36 raspberrypi kernel: [ 2336.653750] usb 1-1.5: USB disconnect, device number 7 Jun 21 10:55:36 raspberrypi kernel: [ 2336.654378] cp210x ttyUSB0: cp210x converter now disconnec...
by wilbe
Fri Jun 30, 2017 7:28 am
Forum: Troubleshooting
Topic: /dev/ttyUSB0 Serial Port Not working
Replies: 7
Views: 20887

Re: /dev/ttyUSB0 Serial Port Not working

Dave, unfortunately I didn't get a return. I listed the USB devices so that you can see it does detect the CP210 USB converter. [email protected]:~ $ sudo systemctl status [email protected]* [email protected]:~ $ lsusb Bus 001 Device 004: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAV...
by wilbe
Thu Jun 29, 2017 1:20 pm
Forum: Troubleshooting
Topic: /dev/ttyUSB0 Serial Port Not working
Replies: 7
Views: 20887

Re: /dev/ttyUSB0 Serial Port Not working

I have a similar problem. I want to use two different serial devices on my raspberry, one connected to the GPIO pins and communicates via /dev/ttyS0 without any issues and the other to a USB as a serial device. Currently everything work via the GPIO pins as the GPS sends the strings through to my Xo...

Go to advanced search