Go to advanced search

by anfractuosity
Sun Jun 30, 2019 10:26 am
Forum: Raspbian
Topic: Buster bug report thread
Replies: 236
Views: 38637

Re: Buster bug report thread

I recently installed Buster on a Pi zero, the footage from a Pi noir camera now seems to have dramatically changed to: https://www.anfractuosity.com/wp-content/uploads/2019/06/mpv-shot0001-1024x576.jpg From this in Stretch: https://www.anfractuosity.com/wp-content/uploads/2019/06/mpv-shot0001-1-1024...
by anfractuosity
Thu Dec 06, 2018 1:31 pm
Forum: Graphics, sound and multimedia
Topic: Pi-ano (banana/pear piano without additional hardware, except pear!)
Replies: 0
Views: 360

Pi-ano (banana/pear piano without additional hardware, except pear!)

I've just hacked up a little program which at the moment works with a single pear, to generate a tone when you touch it, going to work on adding more pears soon!

https://github.com/anfractuosity/pi-ano

Cheers!

(Any suggestions appreciated!)
by anfractuosity
Fri Jul 27, 2018 3:16 pm
Forum: Networking and servers
Topic: Raspberry PI (multihop!!) meshed network
Replies: 3
Views: 1205

Re: Raspberry PI (multihop!!) meshed network

Hey ,

I've been playing a bit with a meshed networking using the Pis with built in wifi
and using 'Babel' for routing.

I need to do some benchmarks though!

Were you able to get WPA working out of interest?

Edit: Just noticed the date of the original post

Cheers
Chris
by anfractuosity
Thu Jul 26, 2018 7:41 am
Forum: Networking and servers
Topic: Pi3B+ 80Mhz 802.11ac channel
Replies: 0
Views: 288

Pi3B+ 80Mhz 802.11ac channel

Hi, I'm just doing sudo iwlist wlan0 channel But I can't see any of the 80MHz channels mentioned on: https://www.revolutionwifi.net/revolutionwifi/2013/03/80211ac-channel-planning.html I'm just a bit confused why that is the case, is it due to the country by card is set to (UK). I notice the chip ca...
by anfractuosity
Thu Jul 12, 2018 9:59 pm
Forum: Networking and servers
Topic: How to do time sync between 2 raspberry pi?
Replies: 4
Views: 685

Re: How to do time sync between 2 raspberry pi?

I setup ntp recently too, make sure to disable the timesyncd daemon I think if you use the ntpd one.

I used timesyncd on the clients and ntpd for the server.
by anfractuosity
Wed Jul 11, 2018 7:59 pm
Forum: Networking and servers
Topic: Pi 3 B+ using ad-hoc wifi with WPA?
Replies: 4
Views: 1666

Re: Pi 3 B+ using ad-hoc wifi with WPA?

That seems to use AP mode I'm afraid, rather than let you use ad-hoc mode.
by anfractuosity
Mon Jul 09, 2018 8:31 pm
Forum: Networking and servers
Topic: Python urllib2.urlopen not Performant
Replies: 2
Views: 476

Re: Python urllib2.urlopen not Performant

You can specify a timeout with urllib it seems - https://docs.python.org/3/library/urlli ... ib.request
by anfractuosity
Fri Jul 06, 2018 4:10 pm
Forum: Networking and servers
Topic: Pi 3 B+ using ad-hoc wifi with WPA?
Replies: 4
Views: 1666

Re: Pi 3 B+ using ad-hoc wifi with WPA?

Thanks, I believe those options are necessary though to create the ad-hoc network, especially the mode=1 one and it's also necessary to specify a frequency too, so they're all on the same channel for me.
by anfractuosity
Wed Jul 04, 2018 6:46 am
Forum: Networking and servers
Topic: Pi 3 B+ using ad-hoc wifi with WPA?
Replies: 4
Views: 1666

Pi 3 B+ using ad-hoc wifi with WPA?

I can create an ad-hoc network with WEP fine, doing the following: auto wlan0 iface wlan0 inet static address 192.168.1.10 netmask 255.255.255.0 wireless-channel 11 wireless-essid mesh wireless-mode ad-hoc wireless-key <wep key> However, when trying to use WPA with wpa_supplicant I simply can't seem...
by anfractuosity
Fri Jun 30, 2017 6:47 pm
Forum: Other projects
Topic: Weatherproof wildlife camera setup
Replies: 2
Views: 1004

Re: Weatherproof wildlife camera setup

Shortening the cable to 1m and glueing the sunny connector seems to have helped :) As I was able to stream over night. Edit: I have had the vcos_abort occur with a 1m cable now alas. vcos_abort: Halting Edit: I've just started capturing again now, and noticed some image corruption in video, I'm goin...
by anfractuosity
Fri Jun 30, 2017 6:32 pm
Forum: Graphics, sound and multimedia
Topic: Tweeting Photobooth with Thermal Printer
Replies: 13
Views: 2836

Re: Tweeting Photobooth with Thermal Printer

It'd be nice to see a comparison of the two prints.

Did you feed it the right resolution image and apply the dither like scruss mentioned?
by anfractuosity
Thu Jun 29, 2017 6:10 pm
Forum: Troubleshooting
Topic: Pi Camera & Videocore crash
Replies: 10
Views: 1480

Re: Pi Camera & Videocore crash

I created a hacky script to restart my stream if necessary, fingers crossed it works overnight! I run the following as root: (as you need root to read from vcdbg afaik) #!/bin/bash function stream { sudo -u pi raspivid -v -o - -t 0 -fps 30 -b 1000000 | ffmpeg -re -ar 44100 -ac 2 -acodec pcm_s16le -f...
by anfractuosity
Thu Jun 29, 2017 3:00 pm
Forum: Troubleshooting
Topic: Pi Camera & Videocore crash
Replies: 10
Views: 1480

Re: Pi Camera & Videocore crash

I _think_ i've worked out what the problem is, as I can reproduce it: Upon a clean boot and starting the stream, everything looks fine: 074499.695: camsubs: Looking for camera 0: i2c_port = 0, led gpio = 134, power enable gpio = 133 074501.333: camsubs: Camera found OK 074506.752: gpioman: gpioman_g...
by anfractuosity
Thu Jun 29, 2017 11:57 am
Forum: Troubleshooting
Topic: Pi Camera & Videocore crash
Replies: 10
Views: 1480

Re: Pi Camera & Videocore crash

I'm wondering if anyone could possibly point me in the right direction, I'm now using a 1m cable and have glued the sunny connector on now. So I don't think the issue I'm getting now while streaming relates to a hardware issue, but I can't be 100% certain. I'm doing: raspivid -o - -t 0 -fps 30 -b 10...
by anfractuosity
Mon Jun 26, 2017 12:50 pm
Forum: Troubleshooting
Topic: Pi Camera & Videocore crash
Replies: 10
Views: 1480

Re: Pi Camera & Videocore crash

Cheers, I'm going to glue the sunny connector down, as I'm fairly sure that's at least one of the issues I have.

I'll double check all other connections too.

Thanks a lot for the advice.

Also I'm going to use a 1m cable too instead, maybe that might help too.
by anfractuosity
Sat Jun 24, 2017 7:53 am
Forum: Other projects
Topic: Weatherproof wildlife camera setup
Replies: 2
Views: 1004

Re: Weatherproof wildlife camera setup

I had the videocore crash overnight, while running streaming. I think this may now possibly be due to the long cable or moisture somehow getting into the cable? I posted some info on the troubleshooting page: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=186766 You can see some weird image...
by anfractuosity
Sat Jun 24, 2017 7:48 am
Forum: Troubleshooting
Topic: Pi Camera & Videocore crash
Replies: 10
Views: 1480

Re: Pi Camera & Videocore crash

I'm wondering if now it's a result of a hardware issue, which I didn't think it was before. When I looked at the last part of the stream, which you can see at: https://www.anfractuosity.com/files/weird_spots.mp4 You'll noticed there are black spots. I'm using a 2 metre camera cable, which does seem ...
by anfractuosity
Sat Jun 24, 2017 7:20 am
Forum: Troubleshooting
Topic: Pi Camera & Videocore crash
Replies: 10
Views: 1480

Re: Pi Camera & Videocore crash

My config.txt had in it already:

gpu_mem=256
start_x=1


Should it be more than 256?
by anfractuosity
Sat Jun 24, 2017 7:10 am
Forum: Troubleshooting
Topic: Pi Camera & Videocore crash
Replies: 10
Views: 1480

Pi Camera & Videocore crash

I ran the Pi overnight with: raspivid -o - -t 0 -fps 30 -b 1000000 | ffmpeg -re -ar 44100 -ac 2 -acodec pcm_s16le -f s16le -ac 2 -i /dev/zero -f h264 -r 30 -i - -vcodec copy -acodec aac -ab 128k -g 50 -strict experimental -f flv rtmp://a.rtmp.youtube.com/live2/<code> But the Pi Videocore seemed to h...
by anfractuosity
Fri Jun 23, 2017 9:21 pm
Forum: Graphics, sound and multimedia
Topic: Painting christmas tree lights
Replies: 0
Views: 350

Painting christmas tree lights

These are a couple of silly projects I did a year and more ago: This one lets me 'paint' the colour of lights on a christmas tree: https://www.anfractuosity.com/projects/painting-a-christmas-tree/ This one let me display _very_ low resolution video on the tree: https://www.anfractuosity.com/projects...
by anfractuosity
Fri Jun 23, 2017 8:52 pm
Forum: Other projects
Topic: Weatherproof wildlife camera setup
Replies: 2
Views: 1004

Weatherproof wildlife camera setup

I just created this little write up of a little weatherproof camera setup I created to film wildlife in our garden and
stream to youtube:

https://www.anfractuosity.com/projects/wildlife-camera/

Any ideas for improvements would be greatly received!
by anfractuosity
Thu Jun 22, 2017 2:45 pm
Forum: Troubleshooting
Topic: [solved] Streaming Raspivid - container issues
Replies: 1
Views: 771

Re: Streaming Raspivid - container issues

I installed the hardware acceleration for avconv too, and am now doing: raspivid -t 0 -fps 25 -w 640 -h 480 -o - | avconv -r 25 -i - -an -c:v h264_omx -vcodec copy -f matroska tcp://wildlifepi.lan:10000?listen The cpu usage is very low, like < 20% But I get lots of messages like the following from m...
by anfractuosity
Wed Jun 21, 2017 10:39 am
Forum: Troubleshooting
Topic: [solved] Streaming Raspivid - container issues
Replies: 1
Views: 771

[solved] Streaming Raspivid - container issues

If I don't use a container and just do: raspivid -t 0 -fps 30 -w 1920 -h 1080 -o - | nc -l -p 10000 nc wildlifepi.lan 10000 | mpv --no-correct-pts --fps 30 - It works brilliantly. At the full resolution at 30fps. However, if I try to do something like: raspivid -t 0 -fps 30 -w 1920 -h 1080 -o - | av...
by anfractuosity
Wed Jun 21, 2017 9:19 am
Forum: Troubleshooting
Topic: [solved] MP4Box raspivid output 'BitStream Not Compliant'
Replies: 3
Views: 1188

Re: MP4Box raspivid output 'BitStream Not Compliant'

Sure it was just generated with: raspivid -t 0 -fps 30 -w 1920 -h 1080 -o test.avi I guess the file itself isn't actually an avi? Doing 'file' I see: "file test.avi" test.avi: JVT NAL sequence, H.264 video @ L 40 I'm an idiot, renaming the file to test.h264 makes the conversion work when I do: MP4Bo...
by anfractuosity
Wed Jun 21, 2017 7:29 am
Forum: Troubleshooting
Topic: [solved] MP4Box raspivid output 'BitStream Not Compliant'
Replies: 3
Views: 1188

[solved] MP4Box raspivid output 'BitStream Not Compliant'

With the latest Raspbian and the Pi Noir V2 using output from raspivid, with MP4Box I get " Unsupported avi file Error importing a.avi: BitStream Not Compliant " When doing: MP4Box -tmp tmp -add a.avi out.mp4 Just wondering if anyone has any ideas? I've used MP4Box a while ago with an older raspbian...

Go to advanced search