Go to advanced search

by tig124
Wed Mar 21, 2018 10:27 pm
Forum: General discussion
Topic: HELP! - Why does my program not compile?!
Replies: 6
Views: 658

Re: HELP! - Why does my program not compile?!

Ahhhhh! SD Card failure! Thanks - its odd as I delete the file, recompile it and the same outcome happens - going to try a new SD card!

Will let all know how I get on

Thanks
Tom
by tig124
Tue Mar 20, 2018 11:26 pm
Forum: General discussion
Topic: HELP! - Why does my program not compile?!
Replies: 6
Views: 658

Re: HELP! - Why does my program not compile?!

HI, I get no error!... The new email address id exists as its my own email address!, So I changed the email address to the new one, however when the code is run via cron, the code sends data to the old email address!!
by tig124
Tue Mar 20, 2018 11:09 pm
Forum: General discussion
Topic: HELP! - Why does my program not compile?!
Replies: 6
Views: 658

HELP! - Why does my program not compile?!

HI, so I am using gcc myprog.c -o myprog -Wall -std=gnu99 to compile code, I am sure it has worked before tonigth, however its clearly not working tonight, as I have done code changes and its still running an old version of the code... I checked this as well by changing the line to be gcc myprog.c -...
by tig124
Wed Oct 25, 2017 11:30 pm
Forum: General discussion
Topic: mpack email "from" field
Replies: 4
Views: 2221

Re: mpack email "from" field

Got it working! - Now when running this within a C file, it comes up with errors saying its not declared!
by tig124
Wed Oct 25, 2017 11:25 pm
Forum: General discussion
Topic: mpack email "from" field
Replies: 4
Views: 2221

Re: mpack email "from" field

HI, How do I send a file from within another directory, i.e. not from the root? So for example from root I have a folder called freezermon, within this I have a file called Freezer.log that I was to send by email. I have tested sending a file from the root using Mpack, and this works fine, but not f...
by tig124
Wed Oct 25, 2017 11:17 pm
Forum: The MagPi
Topic: WineSaver Issue61, cannot find logupdate.sh
Replies: 3
Views: 1884

Re: WineSaver Issue61, cannot find logupdate.sh

Oddly enough I failed to look in the directory - and have found it.! - Thanks
by tig124
Wed Oct 25, 2017 10:15 pm
Forum: The MagPi
Topic: WineSaver Issue61, cannot find logupdate.sh
Replies: 3
Views: 1884

WineSaver Issue61, cannot find logupdate.sh

Simples really - am trying to find the logupdate.sh file in GitHUB but doing a search comes back with nothing!? - trying to perform a get from within Linux doesnt bring back anything!!

Any help appreciated
by tig124
Fri Jun 23, 2017 10:53 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Can't get SPI devices
Replies: 21
Views: 21196

Re: Can't get SPI devices

Hi Yes, I have a HDMI screen attached and the touch screen is working. Will look at which CS line the touchscreen is using and then make sure I am using the other CS line for the MAX chip - However Yes agree I should still see SPIDev.. Any reason for that not being there?
by tig124
Thu Jun 22, 2017 10:52 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Can't get SPI devices
Replies: 21
Views: 21196

Re: Can't get SPI devices

Hi Sorry Here is the Config.txt contents # For more options and information see # http://rpf.io/configtxtreadme # Some settings may impact device functionality. See link above for details # uncomment if you get no picture on HDMI for a default "safe" mode #hdmi_safe=1 # uncomment this if your displa...
by tig124
Thu Jun 22, 2017 10:23 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Can't get SPI devices
Replies: 21
Views: 21196

Re: Can't get SPI devices

kernal is raspberry pi 4.4.50-v7+ #970 smp 20 Feb PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)" NAME="Raspbian GNU/Linux" VERSION_ID="8" VERSION="8 (jessie)" ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" SUPPORT_URL="http://www.raspbian.org/RaspbianForums" BUG_REPORT_URL="http://www.r...
by tig124
Thu Jun 22, 2017 9:18 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Can't get SPI devices
Replies: 21
Views: 21196

Re: Can't get SPI devices

HI thanks - I have done this, now both from terminal as you suggested, but also via the GUI (I originally did this via the GUI), but its still not working When i do ls -l /dev/spidev* I get a response saying no such device, so if I do a simple ls -l /dev/ then scroll back through the files to see if...
by tig124
Thu Jun 22, 2017 8:23 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Can't get SPI devices
Replies: 21
Views: 21196

Re: Can't get SPI devices

HI, Seems this is an old issue - I am new, and I am having the same problems spidev is there, but does not work when running a test. if I look in the blacklist, I see nothing, as in it is completely empty - is this my problem? to me that would say nothing is blacklisted therefore ok!!? I am running ...
by tig124
Mon Jun 19, 2017 9:19 pm
Forum: Troubleshooting
Topic: Cannot change directories from Terminal
Replies: 4
Views: 1708

Re: Cannot change directories from Terminal

Hi I am having the same issues but I am at the root of the pi, I do CD <folder>, but get the message returned as previously stated. i can change to another directory no problems. So I have done a LS -la to look at all the contents, and the directory I can change to is the following drwxrwxrwx lcd-sh...

Go to advanced search