Go to advanced search

by natinusala
Sun Jul 09, 2017 2:16 pm
Forum: OpenVG
Topic: Unable to find a config with an alpha mask
Replies: 6
Views: 11445

Re: Unable to find a config with an alpha mask

So far with what I've tested, drawing full resolution VGImages quite slows down the app, I wonder if it's the same for GL textures. I'll have to test it anyway, thanks for the help !
by natinusala
Sun Jul 09, 2017 11:35 am
Forum: OpenVG
Topic: Unable to find a config with an alpha mask
Replies: 6
Views: 11445

Re: Unable to find a config with an alpha mask

Well that's what I thought. Thanks !

Will it impact the performances a lot ?
by natinusala
Sat Jul 08, 2017 11:21 pm
Forum: OpenVG
Topic: Unable to find a config with an alpha mask
Replies: 6
Views: 11445

Re: Unable to find a config with an alpha mask

This is because it's a shared config for both VG and GL : I'm using two contexts to draw on the same surface (I swap with eglMakeCurrent). Should I use a pbuffer to draw my VG stuff to a GL texture instead ? This way I can keep two surfaces with the configuration for each context (depth for GL and a...
by natinusala
Sun Jun 04, 2017 1:13 pm
Forum: OpenVG
Topic: Unable to find a config with an alpha mask
Replies: 6
Views: 11445

Unable to find a config with an alpha mask

Hello everyone, I'm trying to find a config with an alpha mask (to use shapes as a mask when drawing images). This is my current config : const EGLint attribute_list[] = { EGL_RED_SIZE, 8, EGL_GREEN_SIZE, 8, EGL_BLUE_SIZE, 8, EGL_ALPHA_SIZE, 8, EGL_DEPTH_SIZE, 16, EGL_SURFACE_TYPE, EGL_WINDOW_BIT, E...

Go to advanced search