Go to advanced search

by xmarkx
Fri Feb 02, 2018 7:31 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

It isn't difficult at all. How are you sending characters to the Arduino from the RPi? Are you using the Arduino IDE or your own Python code? I have two days trying to figure it out. I am using python code to send data to the arduino. I am send something like <43, 65, 125, 72> and from the arduino ...
by xmarkx
Fri Feb 02, 2018 7:19 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

Guys I think I understood whats going on. It is weird. Sending data from arduino to rpi is easy. However sending data from arduino to rpi then from the rpi to arduno and visa versa is complicated. I think that the arduino must initialize the communication else it does not work. I will test more exam...
by xmarkx
Fri Feb 02, 2018 6:41 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

This is the sketch of my arduino: void setup() { Serial.begin(9600); } void loop() { if(Serial.available()) { char ch = Serial.read(); digitalWrite(LED_BUILTIN, HIGH); delay(500); digitalWrite(LED_BUILTIN, LOW); delay(500); digitalWrite(LED_BUILTIN, HIGH); delay(500); digitalWrite(LED_BUILTIN, LOW);...
by xmarkx
Fri Feb 02, 2018 6:18 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

Since i am using Serial.println() with my arduino it should be receiving a new line. No?
by xmarkx
Fri Feb 02, 2018 5:48 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

I think that this is not the problem. Let me explain. First of all I just added a LED on my arduino that blinks when something is received. When I send any sequence from my rpi it does not blink. So I think that the problem is that the arduino is not receiving the data properly. Also, it seems that ...
by xmarkx
Fri Feb 02, 2018 4:48 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

The Arduino will receive and send over Serial. Try something like this to test. This just echoes what it receives back to the sending program. void setup() { Serial.begin(9600); } void loop() { if(Serial.available()) { char ch = Serial.read(); Serial.write(ch); } } I have uploaded your sketch to my...
by xmarkx
Fri Feb 02, 2018 4:28 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

pi@raspberrypi:~/Project/QuadcopterVisualServoing/RPi_CV $ ls /dev* autofs hidraw2 mmcblk0p1 ram4 tty10 tty29 tty47 tty8 vcs7 block hidraw3 mmcblk0p2 ram5 tty11 tty3 tty48 tty9 vcsa btrfs-control hwrng mqueue ram6 tty12 tty30 tty49 ttyACM0 vcsa1 bus initctl net ram7 tty13 tty31 tty5 ttyAMA0 vcsa2 c...
by xmarkx
Fri Feb 02, 2018 3:55 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

SurferTim wrote:
Fri Feb 02, 2018 3:51 pm
The Arduino should show up as /dev/ttyACM0. You can open it like a serial port. I use both Python and C to access my Mega 2560 through the USB connection.
I know this, i can see that with ls /dev*. I just can not receive in my arduino what the python code sends.
by xmarkx
Fri Feb 02, 2018 3:54 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Re: Connect Arduino with Raspberry Pi 3

Transmiting some strings from the rpi to the arduino such as <32,52,63,73>. I dont have much time so i need something with the hardware i have right now. I bet there are more ways to do that .
by xmarkx
Fri Feb 02, 2018 3:32 pm
Forum: Troubleshooting
Topic: Connect Arduino with Raspberry Pi 3
Replies: 23
Views: 12050

Connect Arduino with Raspberry Pi 3

Hello everyone, after some hours googling and googling I decide to write my issue here. I am another one that is trying to connect Arduino and Raspberry Pi 3 using a common USB cable. I do not use any GPIO pins on my Raspberry, Just plugin the USB cable from the Arduino to one of the four USB ports ...
by xmarkx
Wed Jan 17, 2018 9:09 pm
Forum: Automation, sensing and robotics
Topic: OpenCV3 installed correctly but no module found using python3
Replies: 2
Views: 1840

Re: OpenCV3 installed correctly but no module found using python3

After several tries, i did the following.

Code: Select all

sudo apt-get install libopencv-dev python-opencv
and then run

Code: Select all

python
since it only works with python 2.7. Everything is working now. You can verify with

Code: Select all

import cv2
cv2.__version__
by xmarkx
Wed Jan 17, 2018 8:30 pm
Forum: Automation, sensing and robotics
Topic: OpenCV3 installed correctly but no module found using python3
Replies: 2
Views: 1840

OpenCV3 installed correctly but no module found using python3

Hello everyone, I have followed this guide: https://imaginghub.com/projects/144-installing-opencv-3-on-raspberry-pi-3?gclid=CjwKCAiAhfzSBRBTEiwAN-ysWGZRyGfOIpKPYXIYTZ2Kk41P7GJYavBs1hAMVKWFCP5C6xRk9y5s1hoC4SgQAvD_BwE#documentation and i think that everything went ok. But when i run python or python3 ...
by xmarkx
Thu Apr 27, 2017 4:56 pm
Forum: Troubleshooting
Topic: No wifi found in Raspberry PI Zero W
Replies: 3
Views: 507

Re: No wifi found in Raspberry PI Zero W

I had no interface on ifconfig. YES i had to redownload the lastest image. Thank you for your answer. Obviously they don' t install the latest image and something went wrong.

for a moment i was frighten that i had to wait 2 weeks again to receive another raspberry pi zero w. Thanks god.
by xmarkx
Thu Apr 27, 2017 2:42 pm
Forum: Troubleshooting
Topic: No wifi found in Raspberry PI Zero W
Replies: 3
Views: 507

No wifi found in Raspberry PI Zero W

Hello I received my rpi zero w yesterday and I can not connect to my wifi. I have boot my pi using my monitor and hover over the network settings at the desktop. There is no wifi adapter. I have also typed ifconfig and there is no interaface for the wifi. I can see only the loopback interface. What ...
by xmarkx
Mon Apr 24, 2017 10:08 am
Forum: Troubleshooting
Topic: disable UART or Serial port
Replies: 5
Views: 2134

Re: disable UART or Serial port

Official arduino are recognized as ttyACM0. So I need to disable UART only if I use GPIO pins? Right?
by xmarkx
Tue Apr 18, 2017 5:42 pm
Forum: Troubleshooting
Topic: Run python script at boot
Replies: 3
Views: 853

Re: Run python script at boot

thagrol wrote:What exactly did you put into rc.local?

Does your script have the correct permissions?
Actually with the above answer i solved it. Thank you

Solution for me:

Code: Select all

(sleep 10;/usr/bin/python /home/pi/serial2dbeg.py)&
*maybe the system couldn' t find python ...
by xmarkx
Tue Apr 18, 2017 4:44 pm
Forum: Troubleshooting
Topic: Run python script at boot
Replies: 3
Views: 853

Run python script at boot

Hi there, I am trying to do something that almost everyone have tied. Run my python script as soon as my pi boots. I do not want to run the script when I login to my XFCE or via ssh. The pi is autonomous and when I plugin it in I would like to execute a script which actually opens a socket with a se...
by xmarkx
Tue Apr 18, 2017 4:40 pm
Forum: Troubleshooting
Topic: disable UART or Serial port
Replies: 5
Views: 2134

Re: disable UART or Serial port

First: How is the Arduino connected to the Pi ? If you are using the GPIO UART pins then you can disable the console on these pins with "sudo raspi-config" ( and then selecting "interfacing" menu and then "serial ) ( Assuming that you are using an uptodate version of Raspbian Jessie ) Hello, I am c...
by xmarkx
Mon Apr 17, 2017 1:05 am
Forum: Troubleshooting
Topic: disable UART or Serial port
Replies: 5
Views: 2134

disable UART or Serial port

Heĺlo everyone i want to talk via serial with my arduino. After days of searching i know i have to disable some things. I have Rpi 3 model b with latest distro. Can anyone tell me what do i have to do? I have tried the two first pages of google search...


thank you.

Go to advanced search