Go to advanced search

by Doub
Tue Apr 16, 2019 12:33 pm
Forum: Camera board
Topic: Why no 4-lane CSI on the Zero?
Replies: 2
Views: 179

Why no 4-lane CSI on the Zero?

The Raspberry Pi Zero CSI connector has the same pinout as the compute module IO board CSI connectors, but two of the four CSI data lanes are not connected. I always assumed it was because the BCM2835 didn't have a 4-lane CSI input. But I just realized the compute module v1.1 does have a 4-lane CSI ...
by Doub
Tue Apr 16, 2019 11:56 am
Forum: Camera board
Topic: Disabling lens shading
Replies: 3
Views: 174

Re: Disabling lens shading

I did find the second link but not the first. Thanks.

Interestingly (at least to me), the red tint on the edges is even worse without lens shading. So I probably need to customize it instead of turning it off. But that's work for a later stage of the project.
by Doub
Tue Apr 16, 2019 7:12 am
Forum: Camera board
Topic: Disabling lens shading
Replies: 3
Views: 174

Disabling lens shading

My project puts a naked IMX219 sensor in a focal plane of a scavenged telescopic lens. I noticed I get some unexpected red tint near the edges of the image, and some greenish gray tint near the middle. I'm wondering if that comes from the lens shading step of the camera pipeline. I see the MMAL_PARA...
by Doub
Tue Apr 16, 2019 7:01 am
Forum: Camera board
Topic: MMAL cropping
Replies: 5
Views: 250

Re: MMAL cropping

The calculations are all buried in the firmware. Is "firmware" stuff provided by Broadcom or by the Raspberry Pi Foundation? Is it likely to evolve and improve if I suggest non-breaking changes? It'll first take the sensor mode and centre crop it I don't want the centre, but instead select a square...
by Doub
Mon Apr 15, 2019 1:56 am
Forum: Other projects
Topic: Target Camera for Long Range Shooting - Intrigued?
Replies: 3
Views: 387

Re: Target Camera for Long Range Shooting - Intrigued?

I've been working on putting a Pi Zero in my scope instead of on the target. I don't need the long range radio, but I have the same dual "at home with internet" and "at the range" problem. I found out that with the built-in Pi Zero W WiFi I can have it both as a WiFi client and an access point at th...
by Doub
Mon Apr 15, 2019 1:27 am
Forum: Camera board
Topic: MMAL cropping
Replies: 5
Views: 250

Re: MMAL cropping

Well, I don't need to record video (yet), but I need the preview to work. I managed to get something to work by changing the pixel aspect ratio (format.es.video.num/den) of the camera preview port. I feel like there's way too many scaling steps in this pipeline when all I want is stream pixels 1 for...
by Doub
Sun Apr 14, 2019 4:27 am
Forum: Camera board
Topic: MMAL cropping
Replies: 5
Views: 250

MMAL cropping

In my application I need only a square portion of the camera image, and 60 fps. So I'm running a camera v2 in mode 6, which gives me 1280x720 pixels. I'd like to only get 720x720 pixels, but choose which ones (aligned left, middle, right or anywhere in between). I've been playing with the camera com...
by Doub
Sat Apr 06, 2019 1:03 am
Forum: Camera board
Topic: How to make pi camera display stays in front of other windows
Replies: 2
Views: 266

Re: How to make pi camera display stays in front of other windows

If you "start the camera" using raspivid or similar, you can try to download and compile it from sources, and change the PREVIEW_LAYER in RaspiPreview.h to something higher than 2.
by Doub
Sat Apr 06, 2019 12:57 am
Forum: Camera board
Topic: Change resolution and transfer rate
Replies: 3
Views: 303

Re: Change resolution and transfer rate

As far as I understand the MMAL pipeline which raspivid uses only support the two official cameras, so I'm not sure you can use this to read data from your FPGA, unless it emulates one of the official cameras. I think there are other ways to get the CSI data from Linux without using the MMAL stack, ...
by Doub
Sun Feb 10, 2019 3:04 pm
Forum: Camera board
Topic: segmentation fault on second mmal_port_destroy
Replies: 4
Views: 247

Re: segmentation fault on second mmal_port_destroy

You shouldn't use m_pool after calling destroy. This is C (as oppposed to C++), the mmal_port_pool_destroy function cannot set your pointer to NULL, the caller is responsible for that. This is just like calling "free" twice on the same pointer.
by Doub
Wed Feb 06, 2019 10:11 am
Forum: Camera board
Topic: One camera, 2 preview windows. Is this possible?
Replies: 1
Views: 141

Re: One camera, 2 preview windows. Is this possible?

I think the PiCamera wraps and connect the camera and renderer components. What you need is insert a splitter and add a second renderer. You probably need to go one level deeper into the MMAL binding and connect the components yourself. Maybe get the sources for the PiCamera class and modify it to s...
by Doub
Fri Feb 01, 2019 9:16 pm
Forum: Camera board
Topic: Camera V2.1 not (or no longer) working on Pi Zero W
Replies: 4
Views: 426

Re: Camera V2.1 not (or no longer) working on Pi Zero W

What is the output of "vcgencmd get_camera" with v2 camera connected? Here is what I get with one of the non-working V2 cameras. [email protected]:~ $ vcgencmd get_camera supported=1 detected=1 [email protected]:~ $ raspivid -f mmal: mmal_vc_component_enable: failed to enable component: ENOSPC mmal: camera com...
by Doub
Fri Feb 01, 2019 4:01 pm
Forum: Camera board
Topic: Camera V2.1 not (or no longer) working on Pi Zero W
Replies: 4
Views: 426

Re: Camera V2.1 not (or no longer) working on Pi Zero W

wh7qq wrote:
Thu Jan 31, 2019 1:14 am
There have been a number of posts here on the fragility of the camera connector on the RPi Zero...any variant...due to its small size and delicacy. That is the most likely scenario for your problem.
But the cameras v1 are still working. Wouldn't a broken connector affect all cameras equally?
by Doub
Wed Jan 30, 2019 5:06 am
Forum: Camera board
Topic: Looking for community interest in making new sensor board
Replies: 6
Views: 495

Re: Looking for community interest in making new sensor board

I for one would be very interested in more camera options. I'd be happy to provide some software development time if I can use it on my own project. I always assumed the MIPI CSI input had to go through closed source drivers and it was impossible to make third party camera modules not based on the t...
by Doub
Wed Jan 30, 2019 4:43 am
Forum: Camera board
Topic: Camera V2.1 not (or no longer) working on Pi Zero W
Replies: 4
Views: 426

Camera V2.1 not (or no longer) working on Pi Zero W

I've been playing with cameras on a Pi Zero W for a while, and I recently purchased a NoIR Camera V2.1, which worked for a few days. I manipulated it a bit to test mechanical mounting on my project, and at some point it stopped working. I have two Pi Zero W on hand, and both had the same issue (with...
by Doub
Sat Jan 19, 2019 11:52 am
Forum: Camera board
Topic: Schematic for camera v2 flex PCB
Replies: 4
Views: 596

Re: Schematic for camera v2 flex PCB

By schematic I meant the electronic schematic of the flex PCB, how the 65 pins of the IMX219 are connected to the 30 pins of the DF37 connector and to the 10 pins of the 5 passives around the sensor. The images you included don't show any of that, and I can't find a link on the AliExpress page. Did ...
by Doub
Sat Jan 19, 2019 3:42 am
Forum: Camera board
Topic: Schematic for camera v2 flex PCB
Replies: 4
Views: 596

Schematic for camera v2 flex PCB

I'd like to use a Pi Zero with an IMX219 camera sensor and a custom lens, but I need to mount the sensor very precisely on the optics. So I'd like to reuse the camera V2 intermediate PCB, but have a different flex PCB that I could mount more precisely to my lens. There are such third party IMX219 fl...
by Doub
Wed Jan 16, 2019 4:24 pm
Forum: Camera board
Topic: Buying authentication chips
Replies: 2
Views: 366

Buying authentication chips

For a hobby project I need some kind of compact computer with a qHD (or better) 60FPS camera sensor interface and HDMI output. The Raspberry Pi Zero with the camera v2 is almost perfect for that. But I need the image sensor on a rigid PCB with specific size constraints. It looks like it should be po...
by Doub
Fri Apr 07, 2017 10:19 pm
Forum: Other projects
Topic: No ODC for gadget to bind to
Replies: 2
Views: 868

Re: No ODC for gadget to bind to

I'm trying to create a UVC gadget with a Pi Zero W. But the last line of the script fails with the error "ls: write error: No such device". The only thing in /sys/class/udc is a symbolic link named "20980000.usb" pointing to "../../devices/platform/soc/20980000.usb/udc/20980000.usb". What's yours lo...

Go to advanced search