Go to advanced search

by jimmyeao
Mon Mar 13, 2017 1:55 pm
Forum: Troubleshooting
Topic: Install AirSonos
Replies: 3
Views: 2589

Re: Install AirSonos

What issues did you have? That's my blog referenced, recently validated and edited the page to make sure it works with the latest Rasbian Pixels
by jimmyeao
Wed Jun 01, 2016 3:10 pm
Forum: Automation, sensing and robotics
Topic: Pi Zero as a Camera Remote
Replies: 15
Views: 5280

Re: Pi Zero as a Camera Remote

In order to take a picture you'll need the focus and shutter buttons shorting to ground (*but see below). As discussed, an opto-isolator is the safest option, but it isn't really necessary. See what David Hunt did here : http://davidhunt.ie/wp-content/uploads/2013/01/Shutter.png Note that you'll ne...
by jimmyeao
Fri May 27, 2016 10:11 am
Forum: Automation, sensing and robotics
Topic: Pi Zero as a Camera Remote
Replies: 15
Views: 5280

Re: Pi Zero as a Camera Remote

I have a Pi Zero, and plan to use it as a remote shutter release for my camera, for doing time-lapse etc.. the lead for my Camera (A Sony Alpha DSLR) is remarkably simple with 3 pins; 1 Ground 2 Focus 3 Shutter release Focus is achieved by connecting pin 2 to pin 1, and a release is a connection be...
by jimmyeao
Thu May 26, 2016 6:58 pm
Forum: Automation, sensing and robotics
Topic: Pi Zero as a Camera Remote
Replies: 15
Views: 5280

Re: Pi Zero as a Camera Remote

It's an A550. It does have ir but I want to be behind the camera..
by jimmyeao
Thu May 26, 2016 2:23 pm
Forum: Automation, sensing and robotics
Topic: Pi Zero as a Camera Remote
Replies: 15
Views: 5280

Re: Pi Zero as a Camera Remote

Yes, I think I need to investigate what an opto-isolater is, and how to use one! My goal is to have a pi-zero and associated electronics in a small case with a lead and a display, that can be controlled wirelessly from a laptop/phone/tablet. I could by a ready made device cheaper, but wheres the fun...
by jimmyeao
Wed May 25, 2016 4:01 pm
Forum: Automation, sensing and robotics
Topic: Pi Zero as a Camera Remote
Replies: 15
Views: 5280

Re: Pi Zero as a Camera Remote

No voltage is used in theses systems , so I am trying to understand how I can use the pi zero to achieve this? Wrong. You don't know what voltage is used, so you would need to use something like an opto-isolator to prevent it frying your RPi and/or frying your camera. Does the camera have a USB int...
by jimmyeao
Wed May 25, 2016 2:59 pm
Forum: Automation, sensing and robotics
Topic: Pi Zero as a Camera Remote
Replies: 15
Views: 5280

Pi Zero as a Camera Remote

I have a Pi Zero, and plan to use it as a remote shutter release for my camera, for doing time-lapse etc.. the lead for my Camera (A Sony Alpha DSLR) is remarkably simple with 3 pins; 1 Ground 2 Focus 3 Shutter release Focus is achieved by connecting pin 2 to pin 1, and a release is a connection bet...
by jimmyeao
Wed Jan 20, 2016 10:44 am
Forum: Networking and servers
Topic: Webserver Froxlor
Replies: 3
Views: 4462

Re: Webserver Froxlor

Sadly this seems to be broken... 404 error after the install trying to access the /froxlor/install/install.php
this is because the froxlor directory is in /var/www/froxlor instead of /var/www/html/froxlor
by jimmyeao
Fri Feb 13, 2015 7:26 pm
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

Just fixed it... How? Replaced my Home Hub :/
by jimmyeao
Fri Feb 13, 2015 7:03 pm
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

This makes me wonder how you connect via ssh. You seem to be using a hostname instead of an IP address? In that case, try connecting to the IP of wlan0 instead. The theory behind this is that you are using a hostname which is registrered through dhcp-dns integration on your router. Since the Pi has...
by jimmyeao
Fri Feb 13, 2015 5:08 pm
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

OK, so I am a step closer... I plugged an actual screen/keyboard in to the PI so I can see what is going on, and so far this is what I have found: WLAN 0 is coming up and obtaining an IP I can SSH from the PI into other systems, do apt-get update etc no problem. If I try and SSH into the PI, I get t...
by jimmyeao
Fri Feb 13, 2015 10:47 am
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

I have now changed my files as per below, and now the Wireless doesnt connect at all . I should point out im using WPA 2 on my router, a BT Hub 5 ifconfig -a output: eth0 Link encap:Ethernet HWaddr b8:27:eb:ee:76:24 inet addr:192.168.1.139 Bcast:192.168.1.255 Mask:255.255.255.0 UP BROADCAST RUNNING ...
by jimmyeao
Fri Feb 13, 2015 10:33 am
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

I think the config you linked to in the first post is a bit strange, try this instead: /etc/network/interfaces: auto lo iface lo inet loopback iface eth0 inet dhcp allow-hotplug wlan0 iface wlan0 inet manual wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf iface default inet dhcp /etc/wpa_supplican...
by jimmyeao
Thu Feb 12, 2015 9:53 pm
Forum: Troubleshooting
Topic: RPI sendEmail doesn't work, help!
Replies: 3
Views: 1260

Re: RPI sendEmail doesn't work, help!

it sounds like the distro you are using doesn't support apt-get or aptitude.

What flavour of Linux is it? Any particular reason you arent using Raspbian?
by jimmyeao
Thu Feb 12, 2015 9:18 pm
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

using the Edimax EW-7811UN - as I say, it connects just fine with the ethernet cable plugged in, I can even SSH into the IP of the Wireless. When I unplug the ethernet, SSH drops, however my router still shows the wireless as connected, leading me to think that maybe it is trying to route responses ...
by jimmyeao
Thu Feb 12, 2015 8:56 pm
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

ifconfig -a eth0 Link encap:Ethernet HWaddr b8:27:eb:ee:76:24 inet addr:192.168.1.139 Bcast:192.168.1.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:185 errors:0 dropped:1 overruns:0 frame:0 TX packets:96 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueu...
by jimmyeao
Thu Feb 12, 2015 8:48 pm
Forum: Troubleshooting
Topic: Wireless and Ethernet die together
Replies: 25
Views: 5945

Re: Wireless and Ethernet die together

interfaces: auto lo iface lo inet loopback iface eth0 inet dhcp allow-hotplug wlan0 iface wlan0 inet dhcp pre-up wpa_supplicant -Dwext -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf post-down killall -q wpa_supplicant /etc/wpa_supplicant/wpa_supplicant.con GNU nano 2.2.6 File: /etc/wpa_supplica...
by jimmyeao
Thu Feb 12, 2015 8:29 pm
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

Using a 2amp PSU, so no issue there,
The dongle shows up fine
The blue light is on (Flashing as you would expect)
If I disconnect the ethernet cable, the connection drops..
I'm just re-imaging the SD card to try again from scratch, will post up my config shortly..
by jimmyeao
Thu Feb 12, 2015 7:15 pm
Forum: Troubleshooting
Topic: Wireless and Ethernet die together
Replies: 25
Views: 5945

Re: Wireless and Ethernet die together

I know this is an old post, but I am having the same issue, however I'm tempted to believe it to be a routing issue on the PI. Why? Because I can see the Pi wireless associated to my wireless access point, and see the ip address it has been assigned. I can only surmise that it is trying to route out...
by jimmyeao
Thu Feb 12, 2015 5:22 pm
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

Re: No WiFi on RPi 2

Bump... Anyone? Im stumped...
by jimmyeao
Wed Feb 11, 2015 10:58 pm
Forum: Troubleshooting
Topic: No WiFi on RPi 2
Replies: 17
Views: 2224

No WiFi on RPi 2

I have tried setting up WiFi on my pi using wicd-curses (Just didn't work - disconnected me and had to reboot to regain access) and by following this guide here: http://kp4tr.org/?page_id=320 If I leave the ethernet cable connected, wifi will work. If I remove the ethernet cable, WiFi Stops working ...
by jimmyeao
Tue Mar 12, 2013 1:03 pm
Forum: Automation, sensing and robotics
Topic: PiFace Rover
Replies: 4
Views: 1807

Re: PiFace Rover

Hi Pete, hows this going? Im looking at a Piface also, I want to create an RC Rover. My plan is to print the plastic parts with a 3D printer I have, then bolt on the other bits as necessary, ot possibly buy one of these What did you use as a chassis etc? I'm also very new to python, but i am fairly ...
by jimmyeao
Thu Jun 28, 2012 7:42 am
Forum: C/C++
Topic: Recommeded C++ dev environment ?
Replies: 108
Views: 81563

Re: Recommeded C++ dev environment ?

andyl wrote:
Writing good code is about making it work, and making it right (good clean readable code with unit tests). Unfortunately most people stop once it is working.
Well said :)
by jimmyeao
Wed Jun 27, 2012 11:58 am
Forum: Media centres
Topic: Using Pi as media center
Replies: 7
Views: 10326

Re: Using Pi as media center

Worth mentioning, there is a Skype addon for XBMC, not tried it though!
by jimmyeao
Wed Jun 27, 2012 11:48 am
Forum: C/C++
Topic: Recommeded C++ dev environment ?
Replies: 108
Views: 81563

Re: Recommeded C++ dev environment ?

I think some of the analogies used here, and more worryingly, the way others extrapolate ideas from them based on their own perceived intelligence is worrying.. Bottom line? Whether you use an IDE or not, your still a developer, (in other words e-n-g-i-n-e-e-r-s) Turning a computer on and running a ...

Go to advanced search