Go to advanced search

by muekno
Mon Nov 06, 2017 3:26 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: [quick-guide] CAN bus on raspberry pi with MCP2515
Replies: 153
Views: 246420

Re: [quick-guide] CAN bus on raspberry pi with MCP2515

Hi I get can0 and MCP initialized, I can enter the send lien with no error. The only difference to you setup is I hab a 16MHz quartz, but I have changed the line in config.txt dtoverlay=mcp2515-can0,oscilator=16000000,interrup=12 but I get ~# ip -d -s link show dev can0 3: can0: <NO-CARRIER,NOARP,UP...
by muekno
Mon May 29, 2017 2:40 pm
Forum: Python
Topic: use mysql time field
Replies: 4
Views: 742

Re: use mysql time field - Solved

The type was no string, so I convert to string, then split and convert the needed parts to int and so I could calculate my needed values.
My be not the beste way but works

Thanks to everyone
by muekno
Mon May 29, 2017 10:55 am
Forum: Python
Topic: use mysql time field
Replies: 4
Views: 742

use mysql time field

I have an time field in my mysql dadabase. I can read the record and if I print the filed it shows i.e. 7:00:00 which it ist correct. Now I like to have the minutes equivalent i.e. 7 x 60 = 420. I tried to split the string with : as delimiter "min = zeit.split(':')" while zeit ist the name where the...
by muekno
Sun May 28, 2017 8:31 am
Forum: Python
Topic: Python GPIO in Use
Replies: 3
Views: 617

Re: Python GPIO in Use

Thanks to everyone for quick response

Rainer
by muekno
Sun May 28, 2017 7:57 am
Forum: Python
Topic: Python GPIO in Use
Replies: 3
Views: 617

Python GPIO in Use

Raspi 2 latest rasbian without gui, latest patches python 3 I start on python script after reboot initializing some GPIOs to input and output and states, went fine so far. Later I start another python, changing state of some outputs. I got a runtime error "GPIO is not set as output" I I define the G...
by muekno
Tue Mar 21, 2017 2:50 pm
Forum: Advanced users
Topic: Starting of eth0 problem
Replies: 1
Views: 424

Starting of eth0 problem

I have configured both et0 and wlan0 with static IP, that's working in principle. But if I start the PI eth0 unconnected ist get it's ip address and starts the interface. the wlan0 ist stated too, but if I ping i.e. the ping would go out via et0 which is not possible, no cable. What I would is that ...
by muekno
Fri Mar 17, 2017 8:25 am
Forum: General discussion
Topic: No IPv4 address
Replies: 5
Views: 10732

Re: No IPv4 address solved

You said IPv4 as default as I knew till now, thought something changed in last image.
As IPv4 should be still the default, I recked everything and found the reason, a bad ethernet cable, so i got no connection to my network and my DHCP.

Thanks for help.

Rainer
by muekno
Fri Mar 17, 2017 7:02 am
Forum: General discussion
Topic: No IPv4 address
Replies: 5
Views: 10732

No IPv4 address

Got the latest Raspbian Jessie Lite Image (2017-03-02-..) yesterday, installed it and did raspi-config activateing SSH. Then to get the IP Address with ipconfigto be able to connect with SSH, I must realize the Raspi had only IPv6 addresses, but no IPv4 address. As IPv6 addresses are not very common...
by muekno
Sun Mar 05, 2017 12:41 pm
Forum: Troubleshooting
Topic: MQTT not listen on Port
Replies: 7
Views: 7619

Re: MQTT not listen on Port

Hello thanks for help. I solved it. The -c was the way to the solution. There where errors (typo) in the conf file, but only starting mosquitto with the -c path config writes to the log file. Starting mosquitto with -v seams to fall back to a default config and works, starting as a service let ist s...
by muekno
Sat Mar 04, 2017 7:22 pm
Forum: Troubleshooting
Topic: MQTT not listen on Port
Replies: 7
Views: 7619

Re: MQTT not listen on Port

Starting mosquitto from the command line [email protected]:~# mosquitto 1488655160: mosquitto version 1.4.11 (build date Mon, 20 Feb 2017 22:47:27 +0000) starting 1488655160: Using default config. 1488655160: Opening ipv4 listen socket on port 1883. 1488655160: Opening ipv6 listen socket on port 1883. in ve...
by muekno
Sat Mar 04, 2017 7:14 pm
Forum: Troubleshooting
Topic: MQTT not listen on Port
Replies: 7
Views: 7619

Re: MQTT not listen on Port

after "service mosquitto restart" syslog Mar 4 20:05:39 home systemd[1]: Stopping LSB: mosquitto MQTT v3.1 message broker... Mar 4 20:05:39 home mosquitto[20082]: Stopping network daemon:: mosquittostart-stop-daemon: warning: failed to kill 20030: No such process Mar 4 20:05:39 home mosquitto[20082]...
by muekno
Sat Mar 04, 2017 5:56 pm
Forum: Troubleshooting
Topic: MQTT not listen on Port
Replies: 7
Views: 7619

Re: MQTT not listen on Port

Sorry I have to correct my post, did see green in service status but say exited instead of running Output see here [email protected]:~# service mosquitto restart [email protected]:~# service mosquitto status ● mosquitto.service - LSB: mosquitto MQTT v3.1 message broker Loaded: loaded (/etc/init.d/mosquitto) Active:...
by muekno
Sat Mar 04, 2017 2:58 pm
Forum: Troubleshooting
Topic: MQTT not listen on Port
Replies: 7
Views: 7619

MQTT not listen on Port

Hi, I installed a MQTT server. If I start it on the command line with mosquitto -v all went fine, port 1883 listens If I start it with service mosquitto start, and check that with service mosquitto status it says running, but port 1883 remains closed. For installation I followed http://www.switchdoc...

Go to advanced search