Go to advanced search

by steeley
Wed Jul 29, 2020 8:01 am
Forum: Troubleshooting
Topic: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss
Replies: 10
Views: 411

Re: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss

Thanks - interesting that it uses a seemingly different driver.
by steeley
Tue Jul 28, 2020 1:36 pm
Forum: Troubleshooting
Topic: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss
Replies: 10
Views: 411

Re: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss

I have now tried 2 different RTl8812 dongles and both show the same issue. I also tried an RTL8811 dongle and that had the same problem. I have borrowed 2 dual-band dongles that use the RT3572 and RT5572 chips and these work correctly. These are an older chipset I guess, so not so easy to find. Also...
by steeley
Tue Jul 28, 2020 11:05 am
Forum: Troubleshooting
Topic: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss
Replies: 10
Views: 411

Re: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss

Thanks - don't see any channels missing with those iw commands. Tried many things , and have spent several days trying to fix.

Looking around the other Internet forums seem to indicate 8812au goes through various stages of working /not working correctly.
by steeley
Mon Jul 27, 2020 9:50 pm
Forum: Troubleshooting
Topic: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss
Replies: 10
Views: 411

Re: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss

Thanks for the info - I'm aware of the difference between using and not using sudo with iwlist scan. been caught out with that before! I can confirm that it gives an updated as opposed to a cached(?) scan when using sudo iwlist scan wlan0. The problem seems to be that it misses certain access points...
by steeley
Mon Jul 27, 2020 8:53 pm
Forum: Troubleshooting
Topic: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss
Replies: 10
Views: 411

Re: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss

Thanks - I have a nasty feeling its something to do with the 8812au driver.... I borrowed some other dual-band dongles and if I try those they work ok - they use the RT3572 chipset. I used the MrEngman script to get the TP-Link (8812au) working. I seem to be up to date with the OS: Operating System:...
by steeley
Fri Jul 24, 2020 8:34 pm
Forum: Troubleshooting
Topic: TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss
Replies: 10
Views: 411

TP-link Wifi dongle (RTl8812au) not seeing all wifi networkss

I have a TP-link archer 600 T2u, using Engman driver for RTL8812au and it does not see all the available wifi networks that are available in my home.. There are 2 networks it will not find even though it finds my 5ghz network and a host of other Sky boxes and neighbours BT wifi modems etc. These net...
by steeley
Wed Apr 29, 2020 8:02 am
Forum: Graphics programming
Topic: Video acceleration on the Raspberry Pi 4
Replies: 15
Views: 10449

Re: Video acceleration on the Raspberry Pi 4

Output from mediainfo. First one (Beauty) does not play. The second one (Tracktor) does play but at a very very low frame rate. Complete name : Beauty_3840x2160_120fps_420_8bit_HEVC_MP4.mp4 Format : MPEG-4 Format profile : Base Media Codec ID : iso4 (iso4/hvc1) File size : 29.3 MiB Duration : 20 s 0...
by steeley
Tue Apr 28, 2020 9:32 pm
Forum: Graphics programming
Topic: Video acceleration on the Raspberry Pi 4
Replies: 15
Views: 10449

Re: Video acceleration on the Raspberry Pi 4

The files are fine. Turn KMS on and VLC plays but two videos show nothing, one plays at about 5 fps.
Turn KMS off and they all play correctly, although sometimes the screen goes blank for a second or two the first time you run the video.
by steeley
Tue Apr 28, 2020 7:28 pm
Forum: Graphics programming
Topic: Video acceleration on the Raspberry Pi 4
Replies: 15
Views: 10449

Re: Video acceleration on the Raspberry Pi 4

Also found that with FKMS driver enabled VLC won't play HEVC.
by steeley
Tue Apr 28, 2020 11:14 am
Forum: Graphics, sound and multimedia
Topic: Pi Zero + Camera Board = USB webcam gadget?
Replies: 75
Views: 38786

Re: Pi Zero + Camera Board = USB webcam gadget?

thanks for the script, Just some advice about the g_webcam driver in linux on pi4 it seems to be bugged.... Try to use uvc with configFS this cannot run as the directory it does not exist /sys/kernel/config/usb_gadget is not there and cannot be created manually UPDATE: I did modprobe g_webcam and it...
by steeley
Tue Apr 28, 2020 10:46 am
Forum: Graphics programming
Topic: Video acceleration on the Raspberry Pi 4
Replies: 15
Views: 10449

Re: Video acceleration on the Raspberry Pi 4

Thanks - I am up to date re. Raspbian. Will need to check FFMPEG again - its the latest from Raspian, but it was not working well at all. My OpenGl-based app. relies on the older stuff, hence it works fine on the pi3B+. Will stick with that for now as its huge work to fix, and some of that relies on...
by steeley
Tue Apr 28, 2020 9:37 am
Forum: Graphics programming
Topic: Video acceleration on the Raspberry Pi 4
Replies: 15
Views: 10449

Re: Video acceleration on the Raspberry Pi 4

Thanks for the info.. Yes agree - could probably live without the really old codecs. So far I have got VLC to play HEVC and h264 ok, but it is rather unstable. FFMPEG - despite having used this for years for encode/decode and within my own software, didn't get any hardware acceleration working on th...
by steeley
Mon Apr 27, 2020 8:32 pm
Forum: Graphics programming
Topic: Video acceleration on the Raspberry Pi 4
Replies: 15
Views: 10449

Re: Video acceleration on the Raspberry Pi 4

Pi0-3 have hardware accelerated decode for H264, MPEG4, H263, and through optional codec licences for MPEG2 and VC1. Pi4 has the same hardware accelerated decode for H264, but not the other codecs. It also has a separate block for HEVC. So is Pi4 likely to support the missing hardware acceleration ...
by steeley
Sat Apr 25, 2020 7:25 pm
Forum: Graphics, sound and multimedia
Topic: Pi Zero + Camera Board = USB webcam gadget?
Replies: 75
Views: 38786

Re: Pi Zero + Camera Board = USB webcam gadget?

How to get the RPi camera working? I had no luck. I have the same issue, shows up as camera source in Quicktime capture but shows a black screen. vlc shows a device too but won't open it. uvc-gadget shows a connection being opened and closed. Spent hours messing with this on an RPI4.... However, whe...
by steeley
Mon Jul 16, 2018 2:51 pm
Forum: Troubleshooting
Topic: Yet another "Wifi country is not set" problem
Replies: 16
Views: 22841

Re: Yet another "Wifi country is not set" problem

Yes, they have really screwed up with this built-in wifi - this issue has been going on for months.

Unfortunately, until they fix it use a USB wifi stick. This works just like the previous PIs under Raspbian Jesse etc.
by steeley
Fri Jan 19, 2018 5:46 pm
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 702
Views: 276515

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

I got one of these boards about a year ago, and have got round to using it for a project I have next week. Unfortunately as stated earlier there is some confusion about the reset line which basically means if that it is incorrect it won't work. Early B101boards seemed to have the wrong design for th...
by steeley
Wed Dec 06, 2017 6:13 pm
Forum: Troubleshooting
Topic: ffmpeg h264_omx encoder - libomxcore.so missing.
Replies: 2
Views: 3301

Re: ffmpeg h264_omx encoder - libomxcore.so missing.

I found this too, and installed that bellagio library. However, although the compile worked I still have no OMX enabled codec.

What compile string did you use?

thx
by steeley
Fri Oct 07, 2016 8:41 pm
Forum: General discussion
Topic: Startup screen -- PI logo
Replies: 9
Views: 2259

Re: Startup screen -- PI logo

Interesting - I've just tried this on my PI3 with the current Raspbian and it doesn't work.
I also tried sending my console to tty3 and reducing the loglevel..

This didn't work either!

I used to do this a while back on my old Pi2s and it worked fine.

Any idea whats going on??

TIA
by steeley
Fri Jun 22, 2012 3:20 pm
Forum: General discussion
Topic: Official consumer support in the UK
Replies: 9
Views: 1471

Re: Official consumer support in the UK

Get on the phone to them and refuse to hang up until they resolve the issue.
They have to abide by the distance selling regulations so don't let them mess you about.
by steeley
Fri Jun 22, 2012 3:03 pm
Forum: General discussion
Topic: Have RS gone mad?
Replies: 10
Views: 2740

Re: Have RS gone mad?

sambartle wrote:Well they definitly have gone mental.. It just arrived.

Not really sure what I'm supposed to do with this..
Flog it on Ebay for more than you paid for it.

Go to advanced search