Go to advanced search

by uberscubajim
Mon Jul 27, 2020 4:48 pm
Forum: Raspberry Pi OS
Topic: rpi4: Module fbtft_device not found
Replies: 9
Views: 2429

Re: rpi4: Module fbtft_device not found

Please keep up the good work! I'm getting the same issues and it looks like you're getting close to an answer. Have you contacted the original author for advice?
by uberscubajim
Sun Jul 26, 2020 12:42 pm
Forum: Advanced users
Topic: Bug in 32-bit 5.4.51 kernel, root fs on USB and USB power
Replies: 0
Views: 175

Bug in 32-bit 5.4.51 kernel, root fs on USB and USB power

I've just upgraded my Pi 4B 4GB to the latest kernel. I have /boot on the SD card with everything else on an attached USB 3 SSD. Worked fine before, but after the upgrade I was just left with the rainbow screen. On investigation I found that it was just waiting for the USB SSD to come up. Not a prob...
by uberscubajim
Tue Jun 16, 2020 5:18 pm
Forum: Java
Topic: PI4J pin.low() no longer working on RBPi 3B+
Replies: 6
Views: 1387

Re: PI4J pin.low() no longer working on RBPi 3B+

Ipswich, you say? Well, one of those working on Pi4J v2 is in Ipswich (me!). The original pi4j v1 should work on anything that supports wiringpi but you have to be using Java 8. The newer pi4j v2 uses Java 11 and pigpio and works on the pi 4. However, there are still some quirks we're working on. Ho...
by uberscubajim
Mon Jun 08, 2020 11:06 am
Forum: Troubleshooting
Topic: Pi4 crashes randomly (browser runs out of memory?)
Replies: 38
Views: 10721

Re: Pi4 crashes randomly (browser runs out of memory?)

Hi James,

Many thanks for that confirmation. I shall now try out as many other monitors as I can find to see what I can find. I'll report back over time (as some of the things took a while to show).

Regards,

Jim.
by uberscubajim
Mon Jun 08, 2020 9:26 am
Forum: Troubleshooting
Topic: Pi4 crashes randomly (browser runs out of memory?)
Replies: 38
Views: 10721

Re: Pi4 crashes randomly (browser runs out of memory?)

There's just been a kernel/firmware update. I've no idea if that helps or not but I'd recommend running an update to see if anything changes.

Regards,

Jim.
by uberscubajim
Wed Jun 03, 2020 2:54 pm
Forum: Troubleshooting
Topic: Pi 4 Model B. No output on LG TV. Tried everything.
Replies: 26
Views: 2800

Re: Pi 4 Model B. No output on LG TV. Tried everything.

Hi James and others, I've seen this problem on multiple monitors. I'm using a Pi 4 with two 1920 by 1080 monitors and it took a long time to find two monitors that both worked. Even then one of them is occasionally dodgy. The monitors are both connected using the official HDMI cables into HDMI to DV...
by uberscubajim
Wed Jun 03, 2020 2:48 pm
Forum: Troubleshooting
Topic: PI 4 HDMI no signal issue
Replies: 4
Views: 813

Re: PI 4 HDMI no signal issue

I've seen this issue as well. It seems both very strange and unpredictable. I'm using two dell monitors on a Pi 4 and also find the blank screen issue on one of them. I've also tried other monitors and found the same issue. Swapping the cables over I find that the "good" monitor works on t...
by uberscubajim
Tue Jul 16, 2019 4:27 pm
Forum: Troubleshooting
Topic: Pi4 crashes randomly (browser runs out of memory?)
Replies: 38
Views: 10721

Re: Pi4 crashes randomly

OK, I've solved the issue (at least for me). It was down to a loosely fitting fan accessory that we think was causing undue noise on the 5V line. As a result of this the power wasn't as stable as it should have been and when the GPU needed a sudden surge (for scrolling video) it all got a bit overlo...
by uberscubajim
Sun Jul 14, 2019 12:08 pm
Forum: Troubleshooting
Topic: Pi4 crashes randomly (browser runs out of memory?)
Replies: 38
Views: 10721

Re: Pi4 crashes randomly

I've taken all the latest upgrades and I can still crash the machine. It looks like it has something to do with animated GIFs or videos in Chromium and then scrolling. I've had days of uptime followed by a crash within seconds if I do this. kflmiami420: It sounds like you have a dodgy power supply. ...
by uberscubajim
Thu Jul 11, 2019 4:11 pm
Forum: Troubleshooting
Topic: Pi4 crashes randomly (browser runs out of memory?)
Replies: 38
Views: 10721

Re: Pi4 crashes randomly

It does seem to be only browser use and then only on specific types of pages: in my case twitter is the worse with facebook a close second but also I've had a local newspaper. The common theme seems to be having video on the page. But I can't believe that this is affecting only a handful of users. I...
by uberscubajim
Sun Jul 07, 2019 6:52 pm
Forum: Troubleshooting
Topic: Pi4 crashes randomly (browser runs out of memory?)
Replies: 38
Views: 10721

Re: Pi4 crashes randomly

I'm using the official power supply and have given the CPU and memory a real thumping by performing a lot of C++ compilations in parallel and running the netbeans Java IDE. No problems at all. In fact, very impressive performance! Its always locked up when I've been scrolling. It doesn't seem mouse ...
by uberscubajim
Sun Jul 07, 2019 4:49 pm
Forum: Troubleshooting
Topic: Pi4 crashes randomly (browser runs out of memory?)
Replies: 38
Views: 10721

Re: Pi4 crashes randomly

I've been seeing random crashes as well on a 4GB Pi4. Well, not that random actually. They seem to occur when scrolling twitter and (less frequently) facebook pages. I haven't had this happen on other sites but then those sites don't have any embedded videos on them. This may just be a co-incidence ...
by uberscubajim
Mon Feb 27, 2017 5:45 pm
Forum: Weather station
Topic: No data in my weather station Data Base
Replies: 17
Views: 3094

Re: No data in my weather station Data Base

I have my machine running in UTC the entire time. I'm unsure if the database uploader converts to UTC when it uploads. In your case it sounds like it does (hence the times are two hours earlier).
by uberscubajim
Mon Feb 27, 2017 5:17 pm
Forum: Weather station
Topic: No data in my weather station Data Base
Replies: 17
Views: 3094

Re: No data in my weather station Data Base

You need to be very careful about timezones. I prefer to work with everything in UTC and then convert at the end.
by uberscubajim
Tue Oct 11, 2016 6:29 pm
Forum: Weather station
Topic: Wx station website
Replies: 6
Views: 1244

Re: Wx station website

The image is based on Jessie so it should be OK. However, I do need to provide an update so that when you move to pi4j 1.1 it doesn't break.
by uberscubajim
Tue Oct 11, 2016 1:59 pm
Forum: Weather station
Topic: Wx station website
Replies: 6
Views: 1244

Re: Wx station website

Dougie,

What do you mean by unsupportable? The image should be upgradable. Oh hang on, it'll upgrade pi4j which breaks the software. I need to provide upgraded jar files.

Jim.
by uberscubajim
Sun Sep 18, 2016 6:10 pm
Forum: Weather station
Topic: Change logging time interval
Replies: 8
Views: 1527

Re: Change logging time interval

Are you using the prebuilt image or the Python version?

You can delete unwanted entries for the local mysql database by using the DELETE statement in SQL (but be care what you delete).
by uberscubajim
Sun Sep 11, 2016 2:17 pm
Forum: Weather station
Topic: Upgrading the pre-built image version of the Weather Station
Replies: 4
Views: 1088

Re: Upgrading the pre-built image version of the Weather Sta

For the image version there has to be a default password (rubbish idea I know). However, it's limited to local access only and you can change it. Actually that instruction sounds like a mash-up of the image and the manual install versions. The image has a root password of tiger and a pi password of ...
by uberscubajim
Sat Sep 10, 2016 9:48 pm
Forum: Weather station
Topic: Upgrading the pre-built image version of the Weather Station
Replies: 4
Views: 1088

Re: Upgrading the pre-built image version of the Weather Sta

The Java weather station already has a non-root user id and restrictions. Check it out!

No-one actually needs to use the root login at all (just many people seem to).

Or were you referring to the Python version?
by uberscubajim
Sat Sep 10, 2016 1:05 pm
Forum: Weather station
Topic: Upgrading the pre-built image version of the Weather Station
Replies: 4
Views: 1088

Upgrading the pre-built image version of the Weather Station

It turns out that if you update the software on the image version of the Weather Station code (by running apt-get upgrade) it upgrades to the next version of pi4j which is not 100% backwards compatible. The issue presents as an error message of the form “Unrecognised hardware, hoping for the best” i...
by uberscubajim
Fri Sep 09, 2016 10:03 pm
Forum: Weather station
Topic: mysql errors [Solved}
Replies: 8
Views: 1302

Re: mysql errors

OK, it should work: are you getting readings in the local database? The issue is that when you upgrade pi4j (the underlying low-level drivers for Java access devices on the Pi) changed its interfacing and it doesn't recognise the new version. I'll update at this end and provide you with a new Weathe...
by uberscubajim
Fri Sep 09, 2016 2:57 pm
Forum: Weather station
Topic: mysql errors [Solved}
Replies: 8
Views: 1302

Re: mysql errors

I've just had a thought: did you run apt-get upgrade on the Pi at any time? More specifically, can you post the output of running “dpkg -l pi4j” for me.
by uberscubajim
Fri Sep 09, 2016 2:27 pm
Forum: Weather station
Topic: mysql errors [Solved}
Replies: 8
Views: 1302

Re: mysql errors

That looks like a Pi 2 so I don't understand why it doesn't spot it. It uses the Pi 2 values by default so that should just work. It looks like the cloud credentials aren't set correctly. The file should look something like (with my user name and my user pass changed to be your own values: { mysql :...
by uberscubajim
Fri Sep 09, 2016 1:53 pm
Forum: Weather station
Topic: mysql errors [Solved}
Replies: 8
Views: 1302

Re: mysql errors

What sort of Pi are you running it on? It should recognise the Pi 2 that he Weather Station ships with....

Don't worry about the cloud upload warning, it's just a reminder that it won't upload to the cloud without filling those credentials in.
by uberscubajim
Tue Sep 06, 2016 5:03 pm
Forum: Weather station
Topic: RTC Problem
Replies: 2
Views: 835

Re: RTC Problem

The image system doesn't, by default, use the real time clock (my bad). If you follow the instructions on the main page for Jessie it should work OK. Either that or get it access to the Internet so it can set it via NTP (that was the original plan). You want to manual RTC setup from https://www.rasp...

Go to advanced search