Go to advanced search

by skibum
Mon Dec 02, 2019 3:15 pm
Forum: Troubleshooting
Topic: Pi 4 4GB- Wifi not working when resolution is set too high
Replies: 73
Views: 5100

Re: Pi 4 4GB- Wifi not working when resolution is set too high

Fairly old firmware, have you tried a sudo apt update sudo apt full-upgrade if that doesn;t help, you could try rpi-update. Updated fully and updated firmware with rpi-update as well. They are now on :- [email protected]:~ $ vcgencmd version Nov 29 2019 18:44:32 Copyright (c) 2012 Broadcom version aabb1fb5c...
by skibum
Mon Dec 02, 2019 2:45 pm
Forum: Troubleshooting
Topic: Pi 4 4GB- Wifi not working when resolution is set too high
Replies: 73
Views: 5100

Re: Pi 4 4GB- Wifi not working when resolution is set too high

I thought I was going made until I came across this post. pi4 4gb. Official power supply and hdmi cable. Monitor is LG 43UD79 running at 4k and hdmi_enable_4p60=1 [email protected]:~ $ vcgencmd version Sep 24 2019 17:34:30 Copyright (c) 2012 Broadcom version cd3add54955f8fa065b414d8fc07c525e7ddffc8 (clean) (...
by skibum
Thu Nov 28, 2019 11:09 pm
Forum: Troubleshooting
Topic: Pi Zero W gpio pins fluctuating
Replies: 24
Views: 524

Re: Pi Zero W gpio pins fluctuating

The encoder also works connected to another Pi. The test code is very simple which generated the output. Another pi zero it always displayed 'low' which I expected with nothing plugged in. The 'problem' pi zero with nothing connected to it, gave the earlier output. So its not the wiring as there isn...
by skibum
Thu Nov 28, 2019 10:51 pm
Forum: Troubleshooting
Topic: Pi Zero W gpio pins fluctuating
Replies: 24
Views: 524

Pi Zero W gpio pins fluctuating

I was having issues getting a rotatry encoder working and no matter what I tried, nothing worked. So, I resorted to a simple loop around reading the status of the pin. To my surprise, it was just randomly switching between high and low. So, I picked another pin. Same thing. Tried another. Same thing...
by skibum
Sun Nov 17, 2019 2:02 pm
Forum: Python
Topic: ctrl-c in python (the ^C being displayed specifically)
Replies: 4
Views: 164

Re: ctrl-c in python (the ^C being displayed specifically)

You could try this https://linux.m2osw.com/remove-ctrl-C-from-being-printed-in-console just be careful not to break your ~/.bashrc file Thanks for that. Went with controlling the stty in python. With the following if anyone is interested :- import termios, sys fd = sys.stdin.fileno() old = termios....
by skibum
Sun Nov 17, 2019 1:12 pm
Forum: Python
Topic: ctrl-c in python (the ^C being displayed specifically)
Replies: 4
Views: 164

ctrl-c in python (the ^C being displayed specifically)

Ok, I'm sure I'm missing something obvious here. In the simplest form I've a program that does :- try: print("\n Hello") input(" Pause ... ") except KeyboardInterrupt: pass Not rocket science. When you run it, it waits until you press ctrl-c and exits. All good. But it also displays the '^C' on the ...
by skibum
Fri Sep 20, 2019 12:07 pm
Forum: Advanced users
Topic: Pi4 64-bit raspbian kernel for testing - Focus on Pi4
Replies: 269
Views: 52102

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

I've found a problem, not specifically with 64bit, as it happened after I've rebooted after doing the rpi-update. That is my screen in X and cli now has a 1" black border around it. I initially posted it in the troubleshooting forum here https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=252178...
by skibum
Fri Sep 20, 2019 12:07 pm
Forum: Troubleshooting
Topic: Black border on screen on an LG 43UD79-B
Replies: 2
Views: 198

Re: Black border on screen on an LG 43UD79-B

Well I've found the issue. In wanting to try the official 64bit raspian it somehow messes up the video. Even if you're still in 32bit mode.
by skibum
Thu Sep 19, 2019 8:17 pm
Forum: Troubleshooting
Topic: Black border on screen on an LG 43UD79-B
Replies: 2
Views: 198

Black border on screen on an LG 43UD79-B

I've just connected my p4 to my LG 43UD79-B monitor It has 4 hdmi: 2 are 30hz (1 & 2) and 2 are 60hz (3 & 4). As I just intended to use it in 30hz mode I plugged it into hdmi 2. The problem is that I have about a 1" black border going all around the screen. Which I don't get on my windows pcs or my ...
by skibum
Mon Aug 19, 2019 2:06 pm
Forum: General discussion
Topic: Raspberry Pi 4 Thread - general discussion
Replies: 951
Views: 114093

Re: Raspberry Pi 4 Thread - general discussion

Is the flirc case that good? I don't want to pay ~£20 for a case and it'll be crap and not work. I see some people say it's good and others not. can't decide. Also, how is the fan-shim? that's only ~£12. My Pi 4 4GB is running constantly so I'd need a fan of some sort to keep it cool. my house is l...
by skibum
Sun Aug 11, 2019 10:40 am
Forum: Troubleshooting
Topic: Problems getting adafruit ultimate gps working on 4B
Replies: 5
Views: 301

Re: Problems getting adafruit ultimate gps working on 4B

Sorted out the issue. While it wasn't connected I had installed previous the Pimoroni fanshim and the software for it. Disabling it via systemctl and rebooting seems to have fixed it. Although stopping and disabling it didn't without the reboot. But I think as I'll probably want to keep using the sh...
by skibum
Sat Aug 10, 2019 10:31 pm
Forum: Troubleshooting
Topic: Problems getting adafruit ultimate gps working on 4B
Replies: 5
Views: 301

Re: Problems getting adafruit ultimate gps working on 4B

Well adding uart5 and moving the tx/rx to pins 32/33 worked. For uart0 I tried disabling bluetooth as well. That confused me for a while as it meant that /dev/ttyS0 just gave I/O errors, but then of course I should have used /dev/ttyAMA0. Using that and its just the same. Not taking to me. Guess its...
by skibum
Sat Aug 10, 2019 6:10 pm
Forum: Troubleshooting
Topic: Problems getting adafruit ultimate gps working on 4B
Replies: 5
Views: 301

Problems getting adafruit ultimate gps working on 4B

I've got the adafruit ultimate gps and connected it via the uart to my 4B. I'm not seeing a thing from the serial port however. But the pps is working fine. same device works fine on 3B+ (stretch) and zero wh (buster lite). I'm wondering if its related to all the new uarts that the 4B as (see https:...
by skibum
Thu Aug 08, 2019 10:19 am
Forum: Troubleshooting
Topic: Raspberry Pi 4 temperature
Replies: 564
Views: 202096

Re: Raspberry Pi 4 temperature

More related to the output from vcgencmd measure_temp than the actual values, but my older Pi's all report the temperature to one decimal place :- [email protected]:~ $ vcgencmd measure_temp temp=40.6'C Where as my p4 is whole numbers only :- [email protected]:~ $ vcgencmd measure_temp temp=37.0'C Any reason we do...

Go to advanced search