Go to advanced search

by fehlfarbe
Mon Aug 12, 2019 2:27 pm
Forum: Camera board
Topic: picamera stream freezes after a while
Replies: 1
Views: 978

Re: picamera stream freezes after a while

Weird, I downgraded to kernel 4.4 via rpi-update and now it doesn't freeze anymore. With kernel >= 4.9 the image freezes after some seconds or minutes.
by fehlfarbe
Thu Jul 04, 2019 6:46 pm
Forum: Camera board
Topic: picamera stream freezes after a while
Replies: 1
Views: 978

picamera stream freezes after a while

Hi, I'm using Raspbian stretch with kernel 4.19.56, picamera 1.13 and pygame1.9.6 to display the camera livestream in a pygame surface and capture a high-res image on button press. I created this class to capture low-res images for faster livestream and take high-res images with different splitter p...
by fehlfarbe
Fri Oct 28, 2016 11:05 am
Forum: Troubleshooting
Topic: Connection problems with umts stick
Replies: 1
Views: 979

Re: Connection problems with umts stick

It's working!
I just installed and connected via sakis3g and it's working without problems :)
by fehlfarbe
Sun Oct 09, 2016 9:16 pm
Forum: Troubleshooting
Topic: Connection problems with umts stick
Replies: 1
Views: 979

Connection problems with umts stick

Hi, I want to connect my Raspberry Pi B rev2 security camera to the internet via UMTS USB stick but sometimes I have connection problems. When I connect the UMTS stick it's detected as Bus 001 Device 005: ID 19d2:0117 ZTE WCDMA Technologies MSM and /dev/ttyUSB[0-2] are avaiable. My /etc/wvdial.conf ...
by fehlfarbe
Sat Oct 24, 2015 9:54 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: reading MLX90614 IR sensor
Replies: 36
Views: 31085

Re: reading MLX90614 IR sensor

Planetibo wrote:it works if I'm not asking just after a BMP085 (humidity and temperature sensor)
I have the same problem. After reading data from BMP085, I only get -273°C from MLX90614 until reboot.
by fehlfarbe
Tue Jun 09, 2015 10:08 pm
Forum: Camera board
Topic: Low light with picamera is darker than raspistill
Replies: 0
Views: 846

Low light with picamera is darker than raspistill

Hi, I'm trying to capture a continuous stream of images at low light conditions. So i followed the tutorial at http://picamera.readthedocs.org/en/latest/recipes1.html#capturing-in-low-light but when I compare the result image with an image taken by raspistill, the picamera image is darker. My python...
by fehlfarbe
Thu Sep 25, 2014 7:15 pm
Forum: Camera board
Topic: long exposure not working on B+
Replies: 123
Views: 27316

Re: long exposure not working on B+

Thanks it's working now with a height of 1952 :)
by fehlfarbe
Wed Sep 24, 2014 8:09 pm
Forum: Camera board
Topic: long exposure not working on B+
Replies: 123
Views: 27316

Re: long exposure not working on B+

Another question: I'm using raspiyuv -rgb and I'm reading the stdout in python with width = 2592 height = 1944 buf = sys.stdin.read(width*height*3) width*height*3 = 15116544 bytes But there is more data in stdin buffer. When I'm reading the whole buffer I get 15178752 bytes for one image. The differ...
by fehlfarbe
Sun Sep 21, 2014 4:52 pm
Forum: Camera board
Topic: long exposure not working on B+
Replies: 123
Views: 27316

Re: long exposure not working on B+

Sorry, this was my fault. Now I changed my last post to "raspiyuv".
by fehlfarbe
Thu Sep 11, 2014 7:55 pm
Forum: Camera board
Topic: long exposure not working on B+
Replies: 123
Views: 27316

Re: long exposure not working on B+

Thank you very much! Now, everything is working :) I'm calling raspiyuv -rgb -tl 6000 -fp --nopreview -bm -ISO 800 -awb off -awbg 1,1 -t 999999999 -ss 6000000 -o - | ./process.py And my process.py looks like this: #!/usr/bin/env python import time, sys import numpy as np from PIL import Image width ...
by fehlfarbe
Thu Sep 11, 2014 5:19 pm
Forum: Camera board
Topic: long exposure not working on B+
Replies: 123
Views: 27316

Re: long exposure not working on B+

Geat! The >>non zero value for "-t"<< was the problem :)

Is there a way to send the last timelapse image file to a running process, e.g. a python script that creates a running average?
by fehlfarbe
Thu Sep 11, 2014 12:10 pm
Forum: Camera board
Topic: long exposure not working on B+
Replies: 123
Views: 27316

Re: long exposure not working on B+

Hm doesn't work for me :( I tried: [email protected] ~ $ raspistill -fp --nopreview -bm -v -set -ISO 100 -awb off -awbg 1.1,1 -t 0 -ss 6000000 -o t_%03d.jpg raspistill Camera App v1.3.8 Width 2592, Height 1944, quality 85, filename t_%03d.jpg Time delay 0, Raw no Thumbnail enabled Yes, width 64, height...
by fehlfarbe
Wed Sep 10, 2014 9:45 pm
Forum: Camera board
Topic: long exposure not working on B+
Replies: 123
Views: 27316

Re: long exposure not working on B+

Hi 6by9,

thank you very much for you answer and all the work :)
So I have to wait until the 'sensor mode' option gets merged? Because I tried with '-fp' option but nothing changed :(
by fehlfarbe
Mon Sep 01, 2014 9:07 pm
Forum: Camera board
Topic: long exposure not working on B+
Replies: 123
Views: 27316

Re: long exposure not working on B+

Hi, is the burst mode already merged with the official raspistill? Today I tried this after a fresh rpi-update: raspistill --nopreview -bm -tl 1000 -v -set -ISO 100 -w 1296 -h 972 -awb off -awbg 1,1 -t 180000 -ss 6000000 -o %03d.jpg I'm getting the files 001.jpg 027.jpg 040.jpg 052.jpg 065.jpg 077.j...
by fehlfarbe
Tue Oct 29, 2013 5:34 pm
Forum: Troubleshooting
Topic: Memory Split doesn't work
Replies: 3
Views: 648

Re: Memory Split doesn't work

Hi FTrevorGowen,

I tried with gpu_xxx and without. Same problem.

rpdom wrote:There is an option in raspi-config to enable/disable the camera. Try disabling it and see if that gets you 16MB.
Thanks, this works! Fortunally I don't need the camera for this project.
by fehlfarbe
Tue Oct 29, 2013 3:19 pm
Forum: Troubleshooting
Topic: Memory Split doesn't work
Replies: 3
Views: 648

Memory Split doesn't work

Hi, I'm running a Raspberry Pi Model B Rev 1 board with Raspbian. Today I tried to change the memory split with raspi-config and editing the config.txt to 16MB but it doesn't work. The free memory stays at 128MB after reboot. free -m total used free shared buffers cached Mem: 121 91 29 0 14 54 -/+ b...
by fehlfarbe
Sun Sep 08, 2013 7:19 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: reading MLX90614 IR sensor
Replies: 36
Views: 31085

Re: reading MLX90614 IR sensor

Ok, the problem is that the BCM2835 C library ( http://www.airspayce.com/mikem/bcm2835/ ) is set to RasPi rev2 settings by default which means that i2c pins are set to GPIO2 (SDA) and GPIO3 (SCL) (see: http://elinux.org/Rpi_Low-level_peripherals) and i2c channel 1 . I changed the pins in bcm2835.c f...
by fehlfarbe
Sun Sep 08, 2013 1:53 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: reading MLX90614 IR sensor
Replies: 36
Views: 31085

Re: reading MLX90614 IR sensor

Today I tested the code (same sdcard) with a rev2 board and it worked great even with the changed RPI_[V2_]GPIO_P1_03 pins in bcm2835_i2c_begin() / end().
The device is now detected at 0x5a with i2cdetect -y 1 instead of i2cdetect -y 0
by fehlfarbe
Wed Sep 04, 2013 7:57 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: reading MLX90614 IR sensor
Replies: 36
Views: 31085

Re: reading MLX90614 IR sensor

Hi joan, i2cdetect -y 0 finds the device at 0x5a 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- -- -- -- -- -- -- -- -- 10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 40: -- -- -- -- -- -...
by fehlfarbe
Wed Sep 04, 2013 6:01 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: reading MLX90614 IR sensor
Replies: 36
Views: 31085

Re: reading MLX90614 IR sensor

Hi joan, I changed the pins of bcm2835_i2c_begin() and bcm2835_i2c_end() in bcm2835.c from RPI_V2_GPIO_P1_03/RPI_V2_GPIO_P1_05 to RPI_GPIO_P1_03/RPI_GPIO_P1_05 and recompiled the lib and Gergő's C-Code but nothing changed. void bcm2835_i2c_begin(void) { // Set the I2C/BSC1 pins to the Alt 0 function...
by fehlfarbe
Wed Sep 04, 2013 3:49 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: reading MLX90614 IR sensor
Replies: 36
Views: 31085

Re: reading MLX90614 IR sensor

Hi Gergő, thanks for the code. Unfortunally it's not working with my configuration. I get a message that my device is working even if there is no device connected and then it measures strange values. Ok, your device is working!! 09-04 17:14:04 Tambi=331.12 C, Tobj=331.14 C 09-04 17:14:14 Tambi=331.1...
by fehlfarbe
Wed Jan 23, 2013 12:45 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: kernel patch for Dallas 1-wire interface
Replies: 227
Views: 154422

Re: kernel patch for Dallas 1-wire interface

Reboot doesn't help.
How can I reinstall the kernel with modules? Maybe from the repositorys.

My current kernel is:

Code: Select all

Linux servberry 3.2.27+ #307 PREEMPT Mon Nov 26 23:22:29 GMT 2012 armv6l GNU/Linux
by fehlfarbe
Tue Jan 22, 2013 10:43 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: kernel patch for Dallas 1-wire interface
Replies: 227
Views: 154422

Re: kernel patch for Dallas 1-wire interface

Hi, I set up my RasPi and a DS18S20 as described at http://www.cl.cam.ac.uk/freshers/raspberrypi/tutorials/temperature/ But when I want to load the kernel modules I get these errors: [email protected] ~ $ sudo modprobe wire ERROR: could not insert 'wire': Invalid argument [email protected] ~ $ sudo modprobe w...
by fehlfarbe
Sun Jun 24, 2012 12:39 pm
Forum: Other projects
Topic: RPi and Linux ARM support for camera input (SLR et video) for a StopMotion animation software
Replies: 7
Views: 4312

Re: RPi and Linux ARM support for camera input (SLR et video

Thx! "ptpcam --chdk" still can't connect but chdkptp works fine with root access!
by fehlfarbe
Wed Jun 20, 2012 7:55 pm
Forum: Other projects
Topic: RPi and Linux ARM support for camera input (SLR et video) for a StopMotion animation software
Replies: 7
Views: 4312

Re: RPi and Linux ARM support for camera input (SLR et video

Hi,

I compiled chdkptp on my RPi under Gentoo Linux. It starts but when I connect to my Canon IXUS60 I get a segmentation fault. Same problem with the chdkde ptpcam version. The camera and chdkde ptp works fine on my desktop pc under Ubuntu 10.04.

Has anyone an idea?

Go to advanced search