Go to advanced search

by nandor65
Tue Oct 02, 2018 7:38 am
Forum: Camera board
Topic: Cannot get specified FPS values
Replies: 6
Views: 610

Re: Cannot get specified FPS values

hi 6by9, yesterday experiment was not OK. "modprobe bcm2835-v4l2 max_video_width=1920 max_video_height=1088" did not upgrade previous "modprobe bcm2835-v4l2". so this morning i did reboot Pi with "modprobe bcm2835-v4l2 max_video_width=1920 max_video_height=1088" and "dmesg" did confirm resolution of...
by nandor65
Mon Oct 01, 2018 6:08 pm
Forum: Camera board
Topic: Cannot get specified FPS values
Replies: 6
Views: 610

Re: Cannot get specified FPS values

actual FPS equals 5.9 for 1920x1088 and with "modprobe bcm2835-v4l2 max_video_width=1920 max_video_height=1088"
by nandor65
Mon Oct 01, 2018 5:13 pm
Forum: Camera board
Topic: Cannot get specified FPS values
Replies: 6
Views: 610

Re: Cannot get specified FPS values

hello 6by9, thanks for your advice. yes, bcm2835-v4l2 is loaded without any flags. the format I capture is BGR as it is controlled by OpenCV flag of CAP_OPENNI_BGR_IMAGE for member function of cv::VideoCapture::retreive(img,flag). as a quick test I reloaded bcm2835-v4l2 max_video_width=1920 max_vide...
by nandor65
Mon Oct 01, 2018 3:03 pm
Forum: Camera board
Topic: Cannot get specified FPS values
Replies: 6
Views: 610

Cannot get specified FPS values

hi, I did some experiment with Raspberry Pi 3B+ and a NoIR camera module V1. I set camera resolution and camera fps using OpenCV VideoCapture. I measured actual FPS without showing image, because OpenCV imshow() slows down actual FPS even more. my measurements are as follows: for 1280x720 FPS set ac...
by nandor65
Thu Nov 16, 2017 6:13 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

PhilE,
many thanks, looks like I need to do some readings.
N
by nandor65
Thu Nov 16, 2017 6:07 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

the engineer who built this PCB told me to control via asynchron TTL serial port with these params: 38400bps 8bit 1stop no-parity no-flowcontrol
and I thought i need to use ttyS0.
by nandor65
Thu Nov 16, 2017 6:02 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

there is a custom built PCB attached to GPIO which controls an IR cut filter. I would like to control this PCB via dev/ttyS0.
by nandor65
Thu Nov 16, 2017 5:58 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

[email protected]:~ $ grep Revision /proc/cpuinfo
Revision : a01041
[email protected]:~ $ cat /proc/device-tree/model
Raspberry Pi 2 Model B Rev 1.1

looks like this is a RPi2.

what is the solution for RPi2 then?
by nandor65
Thu Nov 16, 2017 5:44 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

[email protected]:~ $ sudo vcdbg log msg |& grep dt 001773.554: brfs: File read: /mfs/sd/bcm2709-rpi-2-b.dtb 001773.578: Loading 'bcm2709-rpi-2-b.dtb' to 0x466130 size 0x4135 001785.313: dtdebug: delete_node(/__local_fixups__) 001793.556: dtdebug: /aliases:i2c_vc=i2c0 001799.356: dtdebug: /__symbols__:...
by nandor65
Thu Nov 16, 2017 5:32 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

and one more addition : I am using bcm2835-v4l2 module loaded.
by nandor65
Thu Nov 16, 2017 5:26 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

and I would like to add that I did not do those points you suggested in your comment of Thu Nov 16, 2017 5:47 pm since i was not sure if that is for RPi3B.
by nandor65
Thu Nov 16, 2017 5:24 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

[email protected]:~ $ grep -E "^[^#]" /boot/config.txt framebuffer_width=1280 framebuffer_height=720 dtparam=audio=on start_x=1 gpu_mem=128 enable_uart=1 [email protected]:~ $ cat /boot/cmdline.txt dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=5ac82c05-02 rootfstype=ext4 elevator=deadline fsck.repair=ye...
by nandor65
Thu Nov 16, 2017 5:11 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

[email protected]:~ $ dmesg | grep 8250
[email protected]:~ $ cat /proc/device-tree/soc/[email protected]/status
[email protected]:~ $
by nandor65
Thu Nov 16, 2017 4:55 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

Re: /dev/ttyS0 issue on Stretch

hi PhilE, thanks for your comments. RPi3 RevB [email protected]:~ $ ls /dev/tty* /dev/tty /dev/tty19 /dev/tty3 /dev/tty40 /dev/tty51 /dev/tty62 /dev/tty0 /dev/tty2 /dev/tty30 /dev/tty41 /dev/tty52 /dev/tty63 /dev/tty1 /dev/tty20 /dev/tty31 /dev/tty42 /dev/tty53 /dev/tty7 /dev/tty10 /dev/tty21 /dev/tty3...
by nandor65
Thu Nov 16, 2017 4:14 pm
Forum: Device Tree
Topic: /dev/ttyS0 issue on Stretch
Replies: 20
Views: 6681

/dev/ttyS0 issue on Stretch

Hi, I am unable to enable /dev/ttyS0 on Strech using raspi-config. Exact steps are as follows: $ sudo raspi-config Interfacing options -> Serial -> No -> Yes ... Finish -> reboot after reboot $ ls -l /dev/ttS0 /dev/ttyAMA0 answers this: ls: cannot access '/dev/ttyS0': No such file or directory crw-r...
by nandor65
Mon Mar 27, 2017 4:46 pm
Forum: Troubleshooting
Topic: Remote Desktop Connection using XRDP stopped working
Replies: 11
Views: 9896

Re: Remote Desktop Connection using XRDP stopped working

hi DougieLawson,
yes, it did help. needed a reboot too. looks like it uses quite a lot of CPU.
many thanks.
so XRDP wont be there any more?
Nandor
by nandor65
Mon Mar 27, 2017 4:25 pm
Forum: Troubleshooting
Topic: Remote Desktop Connection using XRDP stopped working
Replies: 11
Views: 9896

Re: Remote Desktop Connection using XRDP stopped working

hi there,
how to extend (raspberrypi) VNC screen? right now an LXTerminal window cannot be seen completely when I connect from windows to raspberry pi 3 using RealVNC.
XRDP is not supported any more?
thanks, Nandor
by nandor65
Sun Dec 11, 2016 2:45 pm
Forum: Camera board
Topic: Trouble with NoIR camera
Replies: 1
Views: 586

Re: Trouble with NoIR camera

hi,
I do not know RPi Web Interface, try to control your sensor via v4l2-ctl from command line.
Now you probably use auto exposure. For the night switch off AE and then set a specific period for the exposure.
$ v4l2-ctl -c auto_exposure=1
$ v4l2-ctl -c exposure_time_absolute=45
Hope this helps.
N
by nandor65
Mon Nov 28, 2016 1:05 pm
Forum: Camera board
Topic: Official V4L2 driver
Replies: 547
Views: 442667

Re: Official V4L2 driver

As I have learned recently: AE uses maximum exposure time of 1/fps. I would like to use AE and keep my fps but I would like to set my maximum exposure time different from 1/fps. Different means much shorter, and never longer exposure times than 1/fps. How is it possible?
by nandor65
Tue Nov 22, 2016 5:36 pm
Forum: Camera board
Topic: Official V4L2 driver
Replies: 547
Views: 442667

Re: Official V4L2 driver

6by9, all right, so when exposure_time_absolute=22 is set this means exposure of 2.2ms and not 22ms. I missed a zero somewhere then. what I wanted to have is a single set of sensor parameters which works for recognizing moving licence plates during the day as well as during the night. AE looks like ...
by nandor65
Tue Nov 22, 2016 3:38 pm
Forum: Camera board
Topic: Official V4L2 driver
Replies: 547
Views: 442667

Re: Official V4L2 driver

6by9, thanks for your reply. I use OpenCV 3.1, I think this is the latest version. OK, so if fps is set AE will never use longer exposure time than 1/fps. Lets say fps=45, then max exposure time is 22msec. (and min exposure time = 1 msec?) So under darker conditions - to force AE to use longest poss...
by nandor65
Tue Nov 22, 2016 1:18 pm
Forum: Camera board
Topic: Official V4L2 driver
Replies: 547
Views: 442667

Re: Official V4L2 driver

6by9, thank you for your lightning fast response. I use default values of the v4l2 driver. so scene_mode=0. exposure_auto_priority? I do not know about this control. I set width and height and fps from OpenCV like this: capture.set(CV_CAP_PROP_FRAME_WIDTH, camera_resolution.width); capture.set(CV_CA...
by nandor65
Tue Nov 22, 2016 10:52 am
Forum: Camera board
Topic: Official V4L2 driver
Replies: 547
Views: 442667

Re: Official V4L2 driver

hi,
Is it possible to use auto exposure mode and set a minimum fps other than fps=1? I am capturing videos during all day long and do not want to get blurred images of moving objects under low light condition. Maybe a minimum of fps=20 would be OK.
thanks.

Go to advanced search