Go to advanced search

by Chris D
Wed Feb 17, 2021 11:37 am
Forum: MicroPython
Topic: Where can I find a list of changes to the UF2 file?
Replies: 13
Views: 491

Re: Where can I find a list of changes to the UF2 file?

Lucky for me, I got things working again with the older version While I had an old version loaded I took the opportunity to run your code and again for the very latest source build and I couldn't see any difference in behaviour. Perhaps add some 'print' statements in so you can check to see where a...
by Chris D
Tue Feb 16, 2021 8:39 pm
Forum: MicroPython
Topic: Where can I find a list of changes to the UF2 file?
Replies: 13
Views: 491

Re: Where can I find a list of changes to the UF2 file?

Lucky for me, I got things working again with the older version and frankly, I am staying with it for now. Learning the differences of the PICO and MicroPython is plenty for me to deal with at any given time. Trying to figure out which version is installed or may be installed or what is and isn't wo...
by Chris D
Tue Feb 16, 2021 5:46 pm
Forum: MicroPython
Topic: Where can I find a list of changes to the UF2 file?
Replies: 13
Views: 491

Re: Where can I find a list of changes to the UF2 file?

Hi Hippy.

This is the only place I know how to download the file...

https://www.raspberrypi.org/documentati ... g-started/

I would assume that is the one that we are suppose to use as that is what the directions tell us to do?

Chris
by Chris D
Tue Feb 16, 2021 4:11 pm
Forum: MicroPython
Topic: Where can I find a list of changes to the UF2 file?
Replies: 13
Views: 491

Re: Where can I find a list of changes to the UF2 file?

WOW, this is interesting, this is the filename of the current download for the UF2 file... rp2-pico-20210205-unstable-v1.14-8-g1f800cac3.uf2 unstable??? That does not build a lot of confidence in a new product. If this is the current version and it is labeled as unstable, why is it even released? Ch...
by Chris D
Tue Feb 16, 2021 3:11 pm
Forum: MicroPython
Topic: Where can I find a list of changes to the UF2 file?
Replies: 13
Views: 491

Re: Where can I find a list of changes to the UF2 file?

Hi guys, thanks for the feedback. As I can't figure out the changes, perhaps someone might know what changed based on what used to work and what doesn't work. These is the "Version" information I get from Thonny about the two different PICOs. v1.13-290-g556ae7914 on 2021-01-21 v1.14 on 202...
by Chris D
Tue Feb 16, 2021 12:25 pm
Forum: MicroPython
Topic: Where can I find a list of changes to the UF2 file?
Replies: 13
Views: 491

Where can I find a list of changes to the UF2 file?

Greetings, I am having problems with a program I wrote in MicroPython. It worked good on a PICO that I loaded with the UF2 file a few weeks back. I have since setup a new PICO and loaded it with a freshly downloaded UF2 file. The program behaves differently and I am trying to debug the problem. Know...
by Chris D
Thu Feb 11, 2021 12:42 pm
Forum: MicroPython
Topic: Example code pio_uart.py does not work correctly [solved]
Replies: 5
Views: 293

Re: Example code pio_uart.py does not work correctly [solved]

So based on your findings, are we to understand that some PICOs work and other don't? If this is the case, I would hope the engineers take a close look at their quality control.
by Chris D
Mon Feb 08, 2021 11:20 am
Forum: MicroPython
Topic: Need some help on uart.read function, it is not working
Replies: 14
Views: 1051

Re: Need some help on uart.read function, it is not working

The only thing I can suggest to help a little is to NOT use read until you know there is something to read by checking with .any. The behavior of .read is such that it will sit there forever trying to read something. As to why you are not getting anything... Make sure GPS Tx goes to Rx on the PICO M...
by Chris D
Sat Feb 06, 2021 11:56 am
Forum: MicroPython
Topic: Need some help on uart.read function, it is not working
Replies: 14
Views: 1051

Re: Need some help on uart.read function, it is not working

Dan, thanks for commenting. I was able to get the .read working. The program that was transmitting the data to the PICO held the output in buffer until it had a LF/CR, thus, no data was present at the PICO. Also, using the .any command cleaned up my code, thanks for that example!

Chris D
by Chris D
Fri Feb 05, 2021 11:54 am
Forum: MicroPython
Topic: Connect MODBUS via USB UART to pico and another device via UART1
Replies: 5
Views: 624

Re: Connect MODBUS via USB UART to pico and another device via UART1

I am having the same problem.

Perhaps the engineers at Raspberry Pi will check in on these posts and offer some advice.

Chris D
by Chris D
Thu Feb 04, 2021 9:50 pm
Forum: MicroPython
Topic: Need some help on uart.read function, it is not working
Replies: 14
Views: 1051

Need some help on uart.read function, it is not working

Greetings, There appears to be a problem the uart.read function(s). The device I am reading from is sending me data, but no LF or CR. I need to read these 4 bytes of data but can't seem to make it happen. I have tried: uart.readline() - this just hangs uart.read() - this just hangs uart.read(1) - th...
by Chris D
Thu Feb 04, 2021 9:38 pm
Forum: MicroPython
Topic: uart com - help with sending data of a specific format
Replies: 4
Views: 215

Re: uart com - help with sending data of a specific format

This problem is resolved - issue was a timing issue.

Chris
by Chris D
Wed Feb 03, 2021 9:52 pm
Forum: MicroPython
Topic: uart com - help with sending data of a specific format
Replies: 4
Views: 215

Re: uart com - help with sending data of a specific format

Update, I found out using a bytearray seems to help... def set_target_position(target): X = ( ((target >> 7) & 1) | ((target >> 14) & 2) | ((target >> 21) & 4) | ((target >> 28) & 8), target >> 0 & 0x7F, target >> 8 & 0x7F, target >> 16 & 0x7F, target >> 24 & 0x7F) b_...
by Chris D
Wed Feb 03, 2021 7:38 pm
Forum: MicroPython
Topic: uart com - help with sending data of a specific format
Replies: 4
Views: 215

uart com - help with sending data of a specific format

Greetings, For my first PICO project, I am working with an intelligent stepper driver from Pololu that communicates via serial (uart). I am trying to send it the 'target position' data which is this according to the datasheet... Set target position Command 0xE0 Format 32-bit write Data target positi...
by Chris D
Wed Feb 03, 2021 12:47 pm
Forum: MicroPython
Topic: Uart rx not working
Replies: 3
Views: 307

Re: Uart rx not working

I suspect there is a bug in that library. the only way I could read data (being transmitted from a windows 10 computer) was to use: uart.read(1) #1 being the number of bytes to read - larger values worked too. IMPORTANT, this will not return until there is also a linefeed/carriage return sent as wel...
by Chris D
Fri Oct 23, 2020 11:48 am
Forum: General discussion
Topic: eMMC - What is this for?
Replies: 14
Views: 750

Re: eMMC - What is this for?

Thank you all very much - that is a very interesting technology.

Chris
by Chris D
Wed Oct 21, 2020 10:43 am
Forum: General discussion
Topic: eMMC - What is this for?
Replies: 14
Views: 750

eMMC - What is this for?

Sorry folks I am stupid and thus far not been able to understand what it is, what is is for? To me it looks like the Computer module 4 has two types of RAM - but why?

Thanks for the clarification,

Chris
by Chris D
Wed Oct 14, 2020 7:09 pm
Forum: General discussion
Topic: Recommendation for a 5" touch screen?
Replies: 2
Views: 136

Re: Recommendation for a 5" touch screen?

I gave up on the last two displays - no idea why they won't work, at this point don't care. I picked up the Adafruit 5" backpack with touch at the local MicroCenter this morning. Plugged it in, configured the config.txt file per their instructions and all is good. Perhaps an example of getting ...
by Chris D
Tue Oct 13, 2020 8:42 pm
Forum: General discussion
Topic: Recommendation for a 5" touch screen?
Replies: 2
Views: 136

Recommendation for a 5" touch screen?

Looking for a working 5" touch screen display and have some serious bad luck or ??? I was expecting that these displays would be a snap to setup and get running like the official 7" touch screen - however, not so much. I would use the 7" display, however I simply don't have room for t...
by Chris D
Mon Sep 14, 2020 7:43 pm
Forum: General discussion
Topic: Auto program run with @python3 returns Command Not Found???
Replies: 6
Views: 321

Re: Auto program run with @python3 returns Command Not Found???

Thanks - using the full path certainly would fix that problem! It has been one of those weeks for me.

Thanks everyone, things are working as I wanted.

Chris
by Chris D
Mon Sep 14, 2020 7:19 pm
Forum: General discussion
Topic: Auto program run with @python3 returns Command Not Found???
Replies: 6
Views: 321

Re: Auto program run with @python3 returns Command Not Found???

THANKS FOR THE FAST RESPONSES!!!!! Regarding not using the @ on the command prompt helped me to understand what was happening. When I did that, my program "crashed" because it could not load a file because it was not in the PROG directory. With that knowledge, I then copied my program and ...
by Chris D
Mon Sep 14, 2020 6:54 pm
Forum: General discussion
Topic: Auto program run with @python3 returns Command Not Found???
Replies: 6
Views: 321

Auto program run with @python3 returns Command Not Found???

Greetings, I am trying to start a python program automatically upon boot. I have edited the /etc/xdg/lxsession/LXDE-pi/autostart file by adding in the following line at the end @python3 /home/pi/desktop/PROG/PROG.py When I boot the PI nothing happens. So I entered @python3 /home/pi/desktop/PROG/PROG...
by Chris D
Sun Sep 13, 2020 3:09 pm
Forum: Camera board
Topic: problem with "Sunny" chip on HQ Camera?
Replies: 17
Views: 938

Re: problem with "Sunny" chip on HQ Camera?

Being that the power supply is different between my two setups, I thought I would measure the voltage on the working one, then adjust the voltage on the non-working one if they were different. The working one as measured on the GPIO was 5.28V and the same pins on the non-working one were 4.89 volts....
by Chris D
Sun Sep 13, 2020 3:02 pm
Forum: Camera board
Topic: problem with "Sunny" chip on HQ Camera?
Replies: 17
Views: 938

Re: problem with "Sunny" chip on HQ Camera?

Read the words on that dinky little brown ribbon cable. Then lean a thumb on it until it clicks back home in the connector below it. Hi Dougie, Thanks for the suggestion, however, that does not exist on the HQ Camera as noted above. The HQ camera is a completely different beast. However, I think I ...
by Chris D
Sun Sep 13, 2020 2:28 pm
Forum: Camera board
Topic: problem with "Sunny" chip on HQ Camera?
Replies: 17
Views: 938

Re: problem with "Sunny" chip on HQ Camera?

Looking back at your OP (apologies I didn't pickup that your problem was with the HQ camera) you don't state which camera software was giving you the "SUNNY error". Maybe it isn't sufficiently up to date to recognise the HQ camera and "thinks" there's a SUNNY connector problem? ...

Go to advanced search