Go to advanced search

by crashboogie
Sun May 28, 2017 7:56 pm
Forum: General discussion
Topic: How would I turn Alexa software off from the cmd line?
Replies: 0
Views: 290

How would I turn Alexa software off from the cmd line?

Got Alexa-avs-sample-app up and running on my Pi3, but I want to be able to turn it on and off through Home-assistant. I made a script to get it turned on, so that's good to go, but I need a command line call that will close the three moving parts which are: cd ~/Desktop/alexa-avs-sample-app/samples...
by crashboogie
Sun May 28, 2017 3:21 am
Forum: General discussion
Topic: Struggling with Emulated Hue/ Alexa setup
Replies: 1
Views: 1696

Re: Struggling with Emulated Hue/ Alexa setup

Welp, think I figured out why it's not working after setting up an HA-bridge instead of the Hue Emulator.... "The software Alexa does not search for any home automation devices locally, that is disabled in that software. Only the hardware echo's do that." :o :cry: :cry: :cry: Incredibly surprised th...
by crashboogie
Sat May 27, 2017 5:09 pm
Forum: General discussion
Topic: OpenVPN on Ethernet problem
Replies: 11
Views: 2889

Re: OpenVPN on Ethernet problem

I remember having a similar issue and messing with the iptables. That seemed to be the trick from what I remember. Try to use this code found here
https://arashmilani.com/post?id=53
by crashboogie
Fri May 26, 2017 11:19 pm
Forum: General discussion
Topic: Struggling with Emulated Hue/ Alexa setup
Replies: 1
Views: 1696

Struggling with Emulated Hue/ Alexa setup

I posted this on Reddit as well but figured it couldn't hurt to try here as well for some good ideas. Essentially I've got a Pi3 that I just got Alexa working on. Works great but now I want to have it talk to my Home-Assistant Pi and it's giving me a pretty good amount of grief. Pi3 IP = 192.168.0.2...
by crashboogie
Fri May 19, 2017 2:04 pm
Forum: General discussion
Topic: Need some help setting up Jasper
Replies: 3
Views: 1078

Re: Need some help setting up Jasper

YES!!!! Been stuck on this for a week now and I think that did the trick. I'm getting a 403 error code now but it says it's likely the google API key so I'll tinker on that when I get home. You're a genius. Thank you kind stranger :D
by crashboogie
Fri May 12, 2017 12:36 am
Forum: General discussion
Topic: Need some help setting up Jasper
Replies: 3
Views: 1078

Need some help setting up Jasper

Not entirely sure whats going on. Trying to setup my Raspberry Pi 3 with Jasper using a Fifine K668 USB mic https://www.amazon.com/Microphone-Fifine-Condenser-Recordings-YouTube/dp/B01D4HTIOY and just a standard speaker plugged into the on-board audio out jack. Not even 100% whether the USB mic is c...
by crashboogie
Sun Apr 30, 2017 9:02 pm
Forum: General discussion
Topic: Pi Zerow, no WIFI
Replies: 12
Views: 1806

Re: Pi Zerow, no WIFI

The Raspian w Pixel was actually the first OS I tried, then I moved to Noobs thinking the wifi didnt like Raspian for some reason. I would LOVE to be able to SSH into it but again no net connection and couldn't get the gadget thing suggested above to work. I did find this post and was going to give ...
by crashboogie
Sun Apr 30, 2017 8:00 pm
Forum: General discussion
Topic: Pi Zerow, no WIFI
Replies: 12
Views: 1806

Re: Pi Zerow, no WIFI

nope, no love there either. Even the WPA supllicant conf file has all the network credentials already in there. Still says no interfaces. Should've just bought the Pi3 again.
by crashboogie
Sun Apr 30, 2017 7:48 pm
Forum: General discussion
Topic: Pi Zerow, no WIFI
Replies: 12
Views: 1806

Re: Pi Zerow, no WIFI

I actually had a thought that I'm not 100% will work or not, but I just ran the apt-get rpi-update, apt-get dist-upgrade, etc etc on my Pi3 and I'm copying the SD card and I'll just plug in the copied card into my Pizero. Any downfalls to this? Any command I need to enter to enable the wifi once it ...
by crashboogie
Sun Apr 30, 2017 5:54 pm
Forum: General discussion
Topic: Pi Zerow, no WIFI
Replies: 12
Views: 1806

Re: Pi Zerow, no WIFI

The Ethernet 'gadget' was a good idea. But I set everything up and tried to connect and ended up connecting to my other pi on the network. Looked for the Pi Zero on the Device Manager and nothing on the COM ports or anything. Think I might just have to break down and buy the damn ethernet adapter. A...
by crashboogie
Sun Apr 30, 2017 4:07 am
Forum: General discussion
Topic: Pi Zerow, no WIFI
Replies: 12
Views: 1806

Pi Zerow, no WIFI

PiZeroW says no interfaces, WIFI not turning on, read that it may need an update. Any way to get Wifi without Net connection? Noobs 2.4, tried messing with etc/network/interfaces and no luck, not going to buy the Ethernet adapter (defeats the purpose of having wifi, that and I'd only use it once to ...
by crashboogie
Thu Apr 27, 2017 1:18 am
Forum: General discussion
Topic: IR Repeater/ Range extension suggestions
Replies: 2
Views: 619

Re: IR Repeater/ Range extension suggestions

OMG! I forgot! Genius! Thanks man :D
by crashboogie
Thu Apr 27, 2017 1:13 am
Forum: General discussion
Topic: Case suggestions for Pi?
Replies: 4
Views: 820

Re: Case suggestions for Pi?

That's a tough one, I've had issues with cases and keeping the shields and such on there as well. This guy in my class modified his case to accommodate his add-ons using one of those layered cases, sort of like this: https://www.amazon.com/Eleduino-Raspberry-Acrylic-Enclosure-Cooling/dp/B00REOH26U/r...
by crashboogie
Thu Apr 27, 2017 1:02 am
Forum: General discussion
Topic: IR Repeater/ Range extension suggestions
Replies: 2
Views: 619

IR Repeater/ Range extension suggestions

So I've got an IR shield on my Pi3 thats controlling a few things in my living room with home-assistant, but I've also got a few things in the bedroom that would be cool to control with it, problem is the range. I was thinking an IR repeater would do the trick, but I haven't found one online yet tha...
by crashboogie
Tue Apr 25, 2017 5:54 am
Forum: Automation, sensing and robotics
Topic: LIRC, IR LED is turning on but devices not responding
Replies: 6
Views: 2254

Re: LIRC, IR LED is turning on but devices not responding

By the way, just out of curiosity, this is how I have the IR LED wired, does this look correct? http://imgur.com/UgXeAgW
by crashboogie
Tue Apr 25, 2017 5:48 am
Forum: Automation, sensing and robotics
Topic: LIRC, IR LED is turning on but devices not responding
Replies: 6
Views: 2254

Re: LIRC, IR LED is turning on but devices not responding

I tried that and unfortunately didn't work either. did the "irsend SEND_START" command and the LED blinks but no go on turning anything on. I was reading that some LEDs (for some odd reason) might not be compatible so I shot for this https://www.amazon.com/Infrared-Shield-RPi/dp/B01C2AQL62 to see if...
by crashboogie
Sun Apr 23, 2017 5:30 am
Forum: Automation, sensing and robotics
Topic: LIRC, IR LED is turning on but devices not responding
Replies: 6
Views: 2254

LIRC, IR LED is turning on but devices not responding

Finally got LIRC to work, verified that the LED lights up when "irsend SEND_ONCE /home/pi/tvon.conf KEY_POWER" is sent, but unfortunately the signals are not getting to the devices. Tried to record, and re-record a couple of different devices/ config files but neither of them turned on or off. I put...
by crashboogie
Sun Apr 23, 2017 4:55 am
Forum: General discussion
Topic: LIRC, IR LED is turning on but devices not responding
Replies: 1
Views: 412

Re: LIRC, IR LED is turning on but devices not responding

Oh and I hooked up my Arduino with an IR receiver and put it in front of the IR LED after running irsend SEND_START /home/pi/tvon.conf KEY_POWER and the receiver lights up so the signal is definitely getting out, its just not translating to my AC or TV for some reason. Receiver stopped responding on...
by crashboogie
Sun Apr 23, 2017 4:23 am
Forum: General discussion
Topic: LIRC, IR LED is turning on but devices not responding
Replies: 1
Views: 412

LIRC, IR LED is turning on but devices not responding

Finally got LIRC to work, verified that the LED lights up when "irsend SEND_ONCE /home/pi/tvon.conf KEY_POWER" is sent, but unfortunately the signals are not getting to the devices. Tried to record, and re-record a couple of different devices/ config files but neither of them turned on or off. I put...
by crashboogie
Sun Apr 23, 2017 3:59 am
Forum: Bare metal, Assembly language
Topic: Printing characters on monitor connected to raspberry pi 3?
Replies: 10
Views: 2384

Re: Printing characters on monitor connected to raspberry pi

Also, this article goes into some depth, and if you get stuck it'd be a good resource.

http://www.circuitbasics.com/how-to-wri ... pberry-pi/
by crashboogie
Sun Apr 23, 2017 3:57 am
Forum: Bare metal, Assembly language
Topic: Printing characters on monitor connected to raspberry pi 3?
Replies: 10
Views: 2384

Re: Printing characters on monitor connected to raspberry pi

After logging into your Rpi, type this command: sudo apt-get install python3 click yes if it asks to install after its done type sudo nano ~/hello world.py Once you're in nano (text editor) you'll see a blank screen. Type #!/usr/bin/python print "Hello, World!"; From here type CTRL+X, then "Y" to sa...
by crashboogie
Sat Apr 22, 2017 11:00 pm
Forum: General discussion
Topic: Having trouble with LIRC and light not responding
Replies: 3
Views: 970

Re: Having trouble with LIRC and light not responding

Progressed a bit further. Rewired everything from this http://www.raspberry-pi-geek.com/var/rpi/storage/images/archive/2015/10/raspberry-pi-ir-remote/figure-2/16808-1-eng-US/Figure-2_lightbox.png to this https://cdn.instructables.com/F04/OYYA/J1CENHSD/F04OYYAJ1CENHSD.LARGE.jpg Now when I run blinkin...
by crashboogie
Sat Apr 22, 2017 8:54 pm
Forum: General discussion
Topic: Having trouble with LIRC and light not responding
Replies: 3
Views: 970

Re: Having trouble with LIRC and light not responding

Already tried the LED both ways round, as well as the transistor, and already let the .py program run for ~60 seconds whilst viewing through the camera and still nothing =/
by crashboogie
Sat Apr 22, 2017 7:13 pm
Forum: General discussion
Topic: Not receiving signals from IR remote to LIRC
Replies: 2
Views: 1376

Re: Not receiving signals from IR remote to LIRC

Thanks for the response. I ended up just connecting the receiver directly to the pi through different wiring and was able to capture the codes. Now the light is not responding though. Some of your posts actually helped me a great deal though, like for example the one here: https://raspberrypi.stacke...

Go to advanced search