Go to advanced search

by Hydrael
Fri May 15, 2015 9:43 am
Forum: Advanced users
Topic: Two SPI attached ST7735R displays
Replies: 7
Views: 2893

Re: Two SPI attached ST7735R displays

Unfortunately I still need some fine-polishing help :? I'm starting two separate X servers and two instances of a little Qt Hello World application that just shows a Main Window with a label showing the display id: FRAMEBUFFER=/dev/fb1 startx& FRAMEBUFFER=/dev/fb2 startx& DISPLAY=:0 ./test.py 1& DIS...
by Hydrael
Wed May 06, 2015 6:16 pm
Forum: Advanced users
Topic: Two SPI attached ST7735R displays
Replies: 7
Views: 2893

Re: Two SPI attached ST7735R displays

Ok, got it

Code: Select all

status = "okay";
was missing in the sainsmart devices.

Now it's working. Thanks a lot for your inspiration again ;)
by Hydrael
Wed May 06, 2015 4:32 pm
Forum: Advanced users
Topic: Two SPI attached ST7735R displays
Replies: 7
Views: 2893

Re: Two SPI attached ST7735R displays

Ok, I finally got to try the DT overlay. The overlay loads as I can see in vcdbg. I can also see, that the sainsmart fragments are there ls /proc/device-tree/soc/[email protected]/ -l total 0 -r--r--r-- 1 root root 4 May 6 16:19 #address-cells -r--r--r-- 1 root root 4 May 6 16:19 clocks -r--r--r-- 1 root...
by Hydrael
Fri May 01, 2015 9:00 pm
Forum: Advanced users
Topic: Two SPI attached ST7735R displays
Replies: 7
Views: 2893

Re: Two SPI attached ST7735R displays

Thanks a lot - that sounds very promising!
I'll give it a try as soon as I get the time.
by Hydrael
Fri May 01, 2015 10:34 am
Forum: Advanced users
Topic: Two SPI attached ST7735R displays
Replies: 7
Views: 2893

Two SPI attached ST7735R displays

Hi, I would like to attach two of these SainSmart 1.8" displays via SPI to my Raspberry Pi 2 for a little project. Since the RPi2 has two SPI CS pins and plenty of spare GPIOs I think this shouldn't be a problem from the wiring side. I'm not sure about the software side though. Regarding this I have...
by Hydrael
Tue Jun 05, 2012 8:38 am
Forum: Troubleshooting
Topic: Video streaming over WLAN
Replies: 2
Views: 1000

Re: Video streaming over WLAN

Almost forgot: My WLAN stick is in a Belkin F5U404 powered 4-port USB hub (which is on the verified peripherals list). I tried two different 5V/1000mA PSUs, tried powering the Pi through the USB hub, used four different USB cables for powering the RPi. A 'normal' USB keyboard is also in the USB hub....
by Hydrael
Tue Jun 05, 2012 7:14 am
Forum: Troubleshooting
Topic: Video streaming over WLAN
Replies: 2
Views: 1000

Video streaming over WLAN

Hello everyone, like many other people I've been struggling the last few days getting my WLAN/powered USB hub/keyboard environment up and running. After hours of reading forums, trying different setups and much, much trial and error, I finally got it working - my Netgear WG111 got an IP Address on t...
by Hydrael
Sat Jun 02, 2012 11:04 am
Forum: General discussion
Topic: WG111v2 and WPA ?
Replies: 14
Views: 7162

Re: WG111v2 and WPA ?

Ok, my problems are now solved with a new USB hub.

I had a Belkin F4U018 (7-port), which was NOT working.

The new one is a Belkin F5U404 (4-port, as suggested in the verified peripherals list) and it works perfectly.
by Hydrael
Fri Jun 01, 2012 8:24 pm
Forum: Troubleshooting
Topic: Network issues - could this really be power issue?
Replies: 25
Views: 5938

Re: Network issues - could this really be power issue?

Did using another powered USB hub help?
I'm having the exact same issue with the same setup and I'd love to know if this is a power-supply based or wifi stick based problem.
by Hydrael
Fri Jun 01, 2012 8:23 pm
Forum: General discussion
Topic: WG111v2 and WPA ?
Replies: 14
Views: 7162

Re: WG111v2 and WPA ?

Have you had any luck with another powered USB hub?
I'm having the exact same issues with the same set up and I'd really love to know if this is a power based or wifi stick based problem

Go to advanced search