Go to advanced search

by GHPoe105
Tue May 17, 2016 3:19 am
Forum: Troubleshooting
Topic: UART Issue
Replies: 10
Views: 3263

Re: UART Issue

Thanks everyone, I to have confirmed that running the following commands gets the UART working.

sudo pigpiod
pigs m 14 0 m 15 0 # Set GPIO 14/15 to ALT0
by GHPoe105
Mon May 16, 2016 12:45 am
Forum: Troubleshooting
Topic: UART Issue
Replies: 10
Views: 3263

Re: UART Issue

rzusman wrote:You probably also need to disable the getty process, too.
Google for it.
This was done in the following command.
sudo raspi-config

dmesg | grep tty

also confirmed that the 'console [ttyAMA0] enabled' was not present.
by GHPoe105
Sun May 15, 2016 8:44 pm
Forum: Troubleshooting
Topic: UART Issue
Replies: 10
Views: 3263

Re: UART Issue

Here are some more details that might be relevant. Running a Raspberry Pi Model 2 on distro Raspbian (jessie). The following are my notes up to this point. Steps to fix Raspberry even though a US keyboard was selected during installation After Install to fix the keyboard \ and # characters sudo setx...
by GHPoe105
Sun May 15, 2016 6:00 am
Forum: Troubleshooting
Topic: UART Issue
Replies: 10
Views: 3263

UART Issue

I've been racking my brain on this one, I'm wondering if anyone can offer any ideas to whats going on? I can confirm my UART is working during startup when the boot messages are being displayed. Once I disable the boot message logging (in sudo raspi-config, advanced, ...), and write a python script ...

Go to advanced search