Go to advanced search

by martinmmps
Fri May 31, 2019 12:09 pm
Forum: Troubleshooting
Topic: Run python script as cgi under apache2 server[my experience]
Replies: 10
Views: 19231

Re: Run python script as cgi under apache2 server[my experience]

What Python Code do I need to get 2 buttons on the Apache Site which run separate functions?

e.g.

Code: Select all

def function1():
	pass
	
def function2():
	pass
by martinmmps
Thu May 30, 2019 5:53 pm
Forum: Python
Topic: Apache2 Python Button
Replies: 1
Views: 220

Apache2 Python Button

I have set up apache2 and followed the instructions on viewtopic.php?t=155229 In HTML there is the <button> tag which allows you to create a button. Lets say i have this python script: def function1(): print("Button One Pressed!") def function2(): print("Button Two Pressed!") How would i get 2 butto...
by martinmmps
Wed May 29, 2019 6:10 pm
Forum: Automation, sensing and robotics
Topic: Motors - What Type, How to use?
Replies: 7
Views: 749

Re: Motors - What Type, How to use?

I have finally got everything to work. It took a while as i needed some more solder but after fixing the grounds and calibrating the motors, i made a python script to run everything with pigpio ( http://abyz.me.uk/rpi/pigpio/python.html#set_servo_pulsewidth ). Now i am working on a Apache Server. Th...
by martinmmps
Mon May 06, 2019 11:15 am
Forum: Automation, sensing and robotics
Topic: Motors - What Type, How to use?
Replies: 7
Views: 749

Re: Motors - What Type, How to use?

Right, I've got the motors to spin. My setup is as follows: The white wires of the motors are connected to Pin 38 & 40 (GPIO 20 & 21). The motors are drawing power from my laptop USB. The USB cable I have soldered headers to the Red and Black wires and are powering the motors without problem. The in...
by martinmmps
Sun May 05, 2019 7:14 am
Forum: Automation, sensing and robotics
Topic: Motors - What Type, How to use?
Replies: 7
Views: 749

Re: Motors - What Type, How to use?

After taking apart some bits and bobs i have found the motor online: https://www.parallax.com/product/900-00025 Is there a tutorial for these types of motors? I have found a helpful grid on some documentation ( https://www.parallax.com/sites/default/files/downloads/900-00025-High-Speed-CR-Servo-Guid...
by martinmmps
Sat May 04, 2019 7:34 am
Forum: Automation, sensing and robotics
Topic: Motors - What Type, How to use?
Replies: 7
Views: 749

Motors - What Type, How to use?

I have 2 motors. Each one has 2 bunches of cables. In each bunch of cables there is a Black, Red, and White wire. Anybody seen these before? The Red wire is in the middle. Which cable do i power via the pins or is there not enough power to do them. When using the RPi.GPIO module, if i power the pins...
by martinmmps
Wed Jul 25, 2018 8:47 am
Forum: Troubleshooting
Topic: Raspberry pi 3b overheating
Replies: 9
Views: 690

Re: Raspberry pi 3b overheating

Thanks for the quick answer, i'll have a go at de-soldering it, if it does fix it will i still be able to use the GPIO if i don't replace it?

Thanks!
by martinmmps
Mon Jul 23, 2018 7:07 pm
Forum: Troubleshooting
Topic: Raspberry pi 3b overheating
Replies: 9
Views: 690

Re: Raspberry pi 3b overheating

there could have been a short circuit since it was outside measuring the temperature. would there be any way to disable the gpio manually to get it to work again?
by martinmmps
Mon Jul 23, 2018 4:44 pm
Forum: Troubleshooting
Topic: Raspberry pi 3b overheating
Replies: 9
Views: 690

Re: Raspberry pi 3b overheating

If resistor r24 and capacitor c65 are to hot to touch I suspect some thing on your pi has failed and is drawing to much current, the red led also being out would suggest there is a very high load on the 5v supply causing the voltage to drop below the threshold or the thermal fuse to blow. you could...
by martinmmps
Mon Jul 23, 2018 11:31 am
Forum: Troubleshooting
Topic: Raspberry pi 3b overheating
Replies: 9
Views: 690

Raspberry pi 3b overheating

Hello, when i plug in my raspberry pi, neither the pwr or act led will switch on. when i felt around the pi to see if anything was hot, chip r24 and c65 next to the gpio near the end of the pi were too hot to touch, i am running raspbian on a 64 gb as card and i was using a sense hat. for about half...
by martinmmps
Sat Jun 02, 2018 8:38 am
Forum: Advanced users
Topic: Files stored in what folder?
Replies: 13
Views: 6081

Re: Files stored in what folder?

Why are you even using the desktop/GUI version of Raspbian to run a Minecraft server? I run my Creeper-Pi3 server on Raspbian Lite to free up as much RAM as possible (the server needs it). Good Point, Thanks! Annoyingly, my router crashed when someone tried to connect to the server, i gave up event...
by martinmmps
Fri Jun 01, 2018 10:37 am
Forum: Advanced users
Topic: Files stored in what folder?
Replies: 13
Views: 6081

Re: Files stored in what folder?

I have found out what is wrong, i had uninstalled some crucial files with: sudo apt-get autoremove Have a look at this: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=193818&p=1214142#p1214142 and this: https://www.raspberrypi.org/forums/viewtopic.php?t=179389 Basically, to fix it i just ha...
by martinmmps
Sat Oct 07, 2017 7:03 am
Forum: AIY Projects
Topic: Audio only working with AIY sound HAT
Replies: 8
Views: 1605

Re: Audio only working with AIY sound HAT

and if i do this (from: https://www.raspberrypi.org/documentati ... -config.md):

Code: Select all

[email protected]:~ $ amixer cset numid=3 2
amixer: Cannot find the given element from control default

[email protected]:~ $ 
this is meant to set the sound to hdmi
by martinmmps
Wed Oct 04, 2017 5:33 am
Forum: AIY Projects
Topic: Audio only working with AIY sound HAT
Replies: 8
Views: 1605

Re: Audio only working with AIY sound HAT

Here is the output: [email protected]:~ $ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: sndrpigooglevoi [snd_rpi_googlevoicehat_soundcar], device 0: Google voiceHAT SoundCard HiFi voicehat-hifi-0 [] Subdevices: 1/1 Subdevice #0: subdevice #0 [email protected]:~ $ and i used this image: http...
by martinmmps
Sun Oct 01, 2017 6:39 am
Forum: AIY Projects
Topic: Audio only working with AIY sound HAT
Replies: 8
Views: 1605

Re: Audio only working with AIY sound HAT

Here is the output of the command:

[email protected]:~ $ aplay -I
aplay: playbackv:3145: You need to specify 1 files
by martinmmps
Fri Sep 22, 2017 6:47 pm
Forum: Troubleshooting
Topic: My "startx" command doesn't work.
Replies: 3
Views: 3912

Re: My "startx" command doesn't work.

this will get your desktop back:

Code: Select all

sudo apt-get update && sudo apt-get install raspberrypi-ui-mods && apt-cache depends raspberrypi-ui-mods && sudo reboot
hope this helps! :P
by martinmmps
Fri Sep 22, 2017 6:43 pm
Forum: AIY Projects
Topic: Audio only working with AIY sound HAT
Replies: 8
Views: 1605

Re: Audio only working with AIY sound HAT

Please can someone help?
by martinmmps
Thu Sep 21, 2017 6:24 am
Forum: AIY Projects
Topic: Audio only working with AIY sound HAT
Replies: 8
Views: 1605

Re: Audio only working with AIY sound HAT

Also the name of the hat is the Voice HAT
by martinmmps
Wed Sep 20, 2017 5:19 pm
Forum: Troubleshooting
Topic: systemd prevents deleting user pi
Replies: 2
Views: 1493

Re: systemd prevents deleting user pi

try doing sudo su first then deluser... that will log you in as root so be careful what commands you do
by martinmmps
Wed Sep 20, 2017 5:03 pm
Forum: AIY Projects
Topic: Audio only working with AIY sound HAT
Replies: 8
Views: 1605

Audio only working with AIY sound HAT

After i did the AIY project my audio with HDMI and headphones stopped working now i can only play sound using the HAT, which is really annoying. when i click on the volume button in the taskbar it shows normally then when i right click it shows snd_rpi_googlevoicehat_soundcar in the list and externa...
by martinmmps
Thu May 25, 2017 5:58 pm
Forum: Beginners
Topic: Changing mount point
Replies: 3
Views: 2358

Re: Changing mount point

I really need to know this also, I am making a file server and I want to mount my hard drive in the shared folder
by martinmmps
Mon Apr 17, 2017 11:04 am
Forum: Advanced users
Topic: Custom Commands
Replies: 5
Views: 694

Custom Commands

I've been using the pi for quite a long time and i have just been wandering is there any way to make your own custom commands for example i have been looking at cmatrix sudo apt-get update && sudo apt-get install cmatrix which you run by doing cmatrix that uses some kind of custom command but i have...
by martinmmps
Mon Apr 17, 2017 9:28 am
Forum: Troubleshooting
Topic: startx goes blank please help!
Replies: 12
Views: 1507

Re: startx goes blank please help!

That worked well thanks!
by martinmmps
Wed Apr 05, 2017 3:48 pm
Forum: Troubleshooting
Topic: startx goes blank please help!
Replies: 12
Views: 1507

Re: startx goes blank please help!

Thanks, I'll try that.
by martinmmps
Mon Apr 03, 2017 8:56 am
Forum: Troubleshooting
Topic: startx goes blank please help!
Replies: 12
Views: 1507

Re: startx goes blank please help!

Thank You!

I think i might have messed up python, i tried reinstalling it by doing,

Code: Select all

sudo apt-get install python3
that didn't install all the default libraries, does anybody have a command to do so?

Go to advanced search