Go to advanced search

by gchirico
Tue May 17, 2016 2:19 pm
Forum: Advanced users
Topic: RB Pi 3 fail to load SPI1
Replies: 7
Views: 3858

Re: RB Pi 3 fail to load SPI1

Great, thanks!

Disabling the BT solved the problem.

I just used:

Code: Select all

dtoverlay=pi3-disable-bt
sudo systemctl disable hciuart
Now the SPI1 channel works as expected, so it really seems that the BT and the SPI1 share something on the SOC.
Thank you very much for your help.
by gchirico
Fri Apr 29, 2016 9:23 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Maximum SPI Devices
Replies: 15
Views: 2556

Re: Maximum SPI Devices

Hi Joan,
thanks for the information.

Best Regards,
Giovanni
by gchirico
Fri Apr 29, 2016 8:26 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Maximum SPI Devices
Replies: 15
Views: 2556

Re: Maximum SPI Devices

Hi Joan,
I too have the same problem with SPI1 aux on RBPi 3.
If I add "dtoverlay=spi1-3cs" to /boot/config.txt the RBPi3 won't boot.

I'm running 4.5.2-v7+ on a Pi3 so gave it a go.

Are you able to solve the problem ?

Thanks in advance,
Giovanni
by gchirico
Thu Apr 28, 2016 4:29 pm
Forum: Advanced users
Topic: RB Pi 3 fail to load SPI1
Replies: 7
Views: 3858

RB Pi 3 fail to load SPI1

Hi All, I have a Raspberry Pi 3 with Kernel 4.4.8-v7+ installed via rpi-update. I'm tryng to enable SPI1 with this line in the /boot/config.txt dtoverlay=spi1-3cs,cs0_spidev=disabled,cs1_spidev=disabled,cs2_spidev=disabled When I enable this line the Raspberry Pi 3 stops and starts very slowly (unus...

Go to advanced search