Go to advanced search

by nuttingcdef
Fri Mar 27, 2015 9:02 pm
Forum: Troubleshooting
Topic: Pi not booting (solved)
Replies: 6
Views: 803

Re: Pi not booting

OK - latest version of Raspbian worked. One happy Pi!

Many thanks,

David
by nuttingcdef
Thu Mar 26, 2015 9:34 pm
Forum: Troubleshooting
Topic: Pi not booting (solved)
Replies: 6
Views: 803

Re: Pi not booting

Thanks for the thoughts. I'll try a fresh download. I'm not concerned about my SD card - I have 4 cards and 3 Pis (including the one I've been using here) and have backups of the images I use with WinDiskImager so re-imaging mine is not a problem. I'm fairly certain that the school's SD card was sup...
by nuttingcdef
Thu Mar 26, 2015 8:28 pm
Forum: Troubleshooting
Topic: Pi not booting (solved)
Replies: 6
Views: 803

Re: Pi not booting

Thanks for the idea - no I hadn't tried the clothes peg trick - now I have - though (sadly) it made no difference. So still scratching my head / hoping for inspiration from someone!

David
by nuttingcdef
Thu Mar 26, 2015 1:11 pm
Forum: Troubleshooting
Topic: Pi not booting (solved)
Replies: 6
Views: 803

Pi not booting (solved)

I'm looking at a Pi owned by a school that I need to use with their Year 7 and 8s next term. But when I power it up, the PWR LED comes on and stays on (nice and bright), the ACT LED flashes briefly ONCE (and once only - not repeated) and then nothing - just sitting there with PWR LED on. I've tried ...
by nuttingcdef
Fri Jun 01, 2012 7:10 am
Forum: Beginners
Topic: Sound in Scratch
Replies: 21
Views: 11902

Re: Sound in Scratch

You may need to log in as root to do this - not as pi.

If you log in as pi, you can set the root password using 'sudo passwd root'. Then logout and log in again as root.
by nuttingcdef
Thu May 31, 2012 6:11 pm
Forum: OpenGLES
Topic: OenGL ES Sample problem
Replies: 17
Views: 5535

Re: OenGL ES Sample problem

Thank you - as a newbie (to OpenGL), issues related to versions (of anything) never feel nice and clean. This one wouldn't have arisen if the sample code linked to the OpenGL ES 2.0 book on GitHub hadn't had a bug that appears to be related to which version of OpenGL is being used.
by nuttingcdef
Thu May 31, 2012 4:43 pm
Forum: OpenGLES
Topic: OenGL ES Sample problem
Replies: 17
Views: 5535

Re: OenGL ES Sample problem

Solved! :D The issue was with the indices being passed to glDrawElements. The sample code had these as GLuints - changing them (and all other relevant references etc.) to GLubyte got everything working. There is a possible documentation issue here - documentation for glDrawElements at http://www.ope...
by nuttingcdef
Thu May 31, 2012 2:02 pm
Forum: OpenGLES
Topic: OenGL ES Sample problem
Replies: 17
Views: 5535

Re: OenGL ES Sample problem

OK, this is weird! Looks like the problem is with glDrawElements. If I do a kludge with glDrawArrays I get a rotating red image on the screen as expected (junk because vertex data isn't set up right to do it that way but it proves all the other rendering code / shaders etc. are working). Checked val...
by nuttingcdef
Thu May 31, 2012 12:20 pm
Forum: OpenGLES
Topic: OenGL ES Sample problem
Replies: 17
Views: 5535

Re: OenGL ES Sample problem

redneon Agree that that sounds likely, though exactly what the differences would be I'm not sure. A few thoughts: * Looking at which of the samples and which don't, I've a fairly strong hunch that this is down to issues with 3D stuff. As far as I can see, all the 2D samples work fine. I've tried mes...
by nuttingcdef
Thu May 31, 2012 11:26 am
Forum: OpenGLES
Topic: OenGL ES Sample problem
Replies: 17
Views: 5535

Re: OenGL ES Sample problem

Not being an OpenGL expert I'm not sure what the implications are, but hello_triangle includes <GLES/gl.h> but the sample includes <GLES2/gl2.h>. Changing the sample include means it fails to build, so there are clearly GLES2 dependencies. I still haven't got this working, but does this give anyone ...
by nuttingcdef
Thu May 31, 2012 9:51 am
Forum: OpenGLES
Topic: OenGL ES Sample problem
Replies: 17
Views: 5535

OenGL ES Sample problem

To introduce myself to OpenGL (having done more in the past with DrectX / XNA) I've grabbed the raspi version of the OpenGL ES 2.0 book samples from GitHub. They all build fine and most of them run / display as expected. But for (e.g.) the Chapter 8 / Simple_VertexShader sample I just get the black ...
by nuttingcdef
Sun May 27, 2012 10:27 am
Forum: Beginners
Topic: First experiences - with a few tips and pointers
Replies: 2
Views: 1733

First experiences - with a few tips and pointers

OK, I'm 24 hours in to my Raspberry Pi. It hasn't been without it's glitches, but most things seem to be fine now. Hopefully these notes might help others through a few hurdles. I'm using the Debian Squeeze 19/04/2012 build. General impressions are very favourable - this has to be the coolest thing ...

Go to advanced search