Go to advanced search

by AdrianM
Tue Jan 08, 2019 10:10 pm
Forum: Camera board
Topic: 1W IR illuminator isn't really
Replies: 4
Views: 848

Re: 1W IR illuminator isn't really

Collector and emitter of Q2 are reversed. This is a typical Chinese crap design, The person who designed this will have known that the LED should not use more than about 50mA, as that is about the maximum you can draw though the thin wires of the flex-PCB cable with impunity, and also about the max...
by AdrianM
Wed Jan 02, 2019 10:41 pm
Forum: Camera board
Topic: 1W IR illuminator isn't really
Replies: 4
Views: 848

Re: 1W IR illuminator isn't really

The schematic:
cct.png
cct.png (41.21 KiB) Viewed 844 times
by AdrianM
Wed Jan 02, 2019 10:38 pm
Forum: Camera board
Topic: 1W IR illuminator isn't really
Replies: 4
Views: 848

1W IR illuminator isn't really

I bought a pair of IR leds advertised for use with Raspberry Pi NOIR cameras. These pop up in all the usual online seller listings. They are usually advertised as having 1W 850nm LEDs with automatic dusk/dawn sensing. I've quite often seen them appear on these forums with little in the way of commen...
by AdrianM
Thu Aug 30, 2018 8:59 am
Forum: Camera board
Topic: Fixed my zero w system lockups when using the camera
Replies: 16
Views: 3998

Re: Fixed my zero w system lockups when using the camera

Thanks for the offer to try out my image but I have another zero+camera that I'm about to test against a clone and a fresh install. Anyway, since restoring the core to 1.4V along with turbo forced on, it's back to working perfectly again. One permutation I've yet to try is leaving the core at 1.4V b...
by AdrianM
Wed Aug 29, 2018 2:54 pm
Forum: Camera board
Topic: Fixed my zero w system lockups when using the camera
Replies: 16
Views: 3998

Re: Fixed my zero w system lockups when using the camera

Hi itsmedoofer, that's interesting - what kind of SD card do you have in the Camera Pi? Mine has a 32Gb SanDisk Extreme pro class 10 I can now see that my pet theory about the dynamic clocking alone being a remedy wasn't correct. It crashed out with a kernel oops after just four hours at the default...
by AdrianM
Wed Aug 29, 2018 10:33 am
Forum: Camera board
Topic: Fixed my zero w system lockups when using the camera
Replies: 16
Views: 3998

Re: Fixed my zero w system lockups when using the camera

I know four months have passed since the last post in this thread but I think the information in this topic is valuable and have some observations to add of my own. I've also been struggling to get reliable operation of a Pi Zero + camera setup as a security camera using RPi Cam Web Interface. The s...
by AdrianM
Sat Aug 25, 2018 9:13 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4982
Views: 1249707

Re: RPi Cam Web Interface

I had hoped to be able to turn on/off motion detection by sending http requests from another client on the same LAN to the RPi Cam control port. I thought /etc/motion/motion.conf had to have the localhost setting to off to permit this... control_port 6642 control_localhost off control_html_output of...
by AdrianM
Sat Aug 18, 2018 12:57 pm
Forum: Camera board
Topic: Sharing my experience on long exposures
Replies: 1
Views: 606

Re: Sharing my experience on long exposures

Thanks for sharing! I've just mounted a pi on a telescope along with the V2 camera to get me started with astro imaging.
2018-08-18 13.47.38.jpg
2018-08-18 13.47.38.jpg (53.28 KiB) Viewed 547 times
So far its all been 3D printing and getting an interface to the motor drives working - next is camera software so your findings are very helpful.
by AdrianM
Mon Aug 13, 2018 8:28 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4982
Views: 1249707

Re: RPi Cam Web Interface

<Shrug> New SD card arrived, Flashed latest Raspbian Stretch and followed installation instructions again for Nginx server. This time it worked first time.
by AdrianM
Sat Aug 11, 2018 3:16 pm
Forum: General discussion
Topic: Serial over network difficulties
Replies: 2
Views: 259

Re: Serial over network difficulties

Nothing to see here. I put a jumper to link RX & TX on the end of my FTDI cable in the certainty that this was looping back. After everything else I checked continuity between the link and yellow RX wire (by poking a pin in the yellow insulation). Open-circuit! break.jpg On closer inspection the in...
by AdrianM
Sat Aug 11, 2018 10:49 am
Forum: General discussion
Topic: Serial over network difficulties
Replies: 2
Views: 259

Re: Serial over network difficulties

When I start the hub4com batch file from Power Shell it produces the following output: PS C:\Users\adrian\hub4com-2.0.1.0> .\com2tcp-rfc2217.bat \\.\CNCB0 192.168.1.111 2217 C:\Users\adrian\hub4com-2.0.1.0>"hub4com" --create-filter=escparse,com,parse --create-filter=pinmap,com,pinmap:"--rts=cts --dt...
by AdrianM
Fri Aug 10, 2018 9:25 pm
Forum: General discussion
Topic: Serial over network difficulties
Replies: 2
Views: 259

Serial over network difficulties

I'm trying to "cut the cable" between some astronomy software on a PC that normally direct-wires to a telescope guidance device over a serial COM port by using a Pi as a WiFi station go-between. At the Windows PC side I've got com0com set up to provide a virtual COM port and use it in conjunction wi...
by AdrianM
Wed Aug 08, 2018 11:15 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4982
Views: 1249707

Re: RPi Cam Web Interface

Following the elinux.org installation instructions, I opted to use nginx as server during installation but the permissions for www folders seem to be causing problems:- e.g. on starting I see warnings like: [email protected]:~/RPi_Cam_Web_Interface $ ./start.sh [email protected]:~/RPi_Cam_Web_Interface $ ...
by AdrianM
Mon Nov 07, 2016 5:58 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

That seems to have done the trick, fantastic! Mounting with NFS seems to be marginally more sane than using cifs so I think I'll stick with it now it's working. The media folder and subfolders ownership & permissions now look like this: [email protected]:~ $ stat /home/pi/NAS/pikrellcam/media File: ‘/h...
by AdrianM
Mon Nov 07, 2016 9:02 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

Permissions again :-( From the log: 08:51:51 : command_process: motion_enable toggle 08:51:54 : Could not create video file /home/pi/NAS/pikrellcam/media/videos/motion_2016-11-07_08.51.49_0.mp4.h264. Permission denied 08:51:54 : event preview save: copy /run/pikrellcam/mjpeg.jpg -> /run/pikrellcam/m...
by AdrianM
Mon Nov 07, 2016 8:55 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

After this upgrade it doesn't crash out, it starts - but the motion detection doesn't start any recording nor does the snapshot take any stills. Here's the output anyway: [email protected]:~ $ pikrellcam -v ======================================================== ======= PiKrellCam 3.1.3 started at 201...
by AdrianM
Sun Nov 06, 2016 8:23 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

OK, great, here's the terminal output: [email protected]:~ $ pikrellcam -v ======================================================== ======= PiKrellCam 3.1.2 started at 2016-11-06 20:20:26 ======================================================== check_modes(/home/pi/pikrellcam/www) using FIFO: /home/pi/...
by AdrianM
Sat Nov 05, 2016 9:30 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

I had deleted the two folders I made by hand so I started by re-creating them (which worked OK) and then ran it: [email protected]:~ $ sudo mkdir -p /home/pi/NAS/pikrellcam/media/thumbs [email protected]:~ $ sudo mkdir -p /home/pi/NAS/pikrellcam/media/timelapse [email protected]:~ $ pikrellcam -v ===========...
by AdrianM
Sat Nov 05, 2016 9:03 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

Did any of videos, thumbs, stills or timelapse subdirectories get created under /home/pi/NAS/pikrellcam/media? Just a videos folder was added into media. If not, does this work running from the command line: sudo mkdir -p /home/pi/NAS/pikrellcam/media/videos But if those directories are not getting...
by AdrianM
Sat Nov 05, 2016 5:00 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

OK, it's not running. If I revert to SD storage and get it running from the command line, opening another terminal I see process running under lxterminal. If I revert to the NAS storage in .conf and try running from the command line it gives the following errors: [email protected]:~ $ /home/pi/pikrellc...
by AdrianM
Sat Nov 05, 2016 2:20 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

The log shows: ======================================================== ======= PiKrellCam 3.1.1 started at 2016-11-04 22:15:00 ======================================================== using FIFO: /home/pi/pikrellcam/www/FIFO using mjpeg: /run/pikrellcam/mjpeg.jpg 22:15:00 : execl:[sudo chown pi.ww...
by AdrianM
Sat Nov 05, 2016 10:06 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

Yes, the sudo runuser touch command successfully created the testfile on the NAS. Testfile properties show-up as follows:

Code: Select all

Owner: www-data
Group: www-data
View content: Anyone
Change content: Anyone
Execute: Nobody
by AdrianM
Fri Nov 04, 2016 11:06 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1438
Views: 297025

Re: PiKrellCam: motion vector detect + OSD web interface

Just got going with this great bit of software. It all works fine for me using the default file structure but I'm having a problem setting up media and archiving on a NAS while trying to follow the help page and various bits of info in this big thread. Basically I already have a working NFS share (s...
by AdrianM
Sun Mar 27, 2016 1:29 pm
Forum: General discussion
Topic: BBC: Amazon connects Pi to Alexa
Replies: 20
Views: 4186

Re: BBC: Amazon connects Pi to Alexa

I'm trying to follow the walkthrough on github but it's been written assuming Raspbian Wheezy is the OS. All roads now seem to lead to Jessie and I think this may be where I'm running into difficulties. I've got a clean install of Jessie on a rpi3 and the walkthrough only gets me as far as step 2.5 ...

Go to advanced search