Go to advanced search

by treefella
Tue May 21, 2019 1:16 am
Forum: General discussion
Topic: RPI acting both as slave and as master device on its usb ports
Replies: 22
Views: 868

Re: RPI acting both as slave and as master device on its usb ports

Oh hey guys didn't mean to start a riot here haha.... Not sure if "Mesh Network" is the correct term here. Open to correcting my terminology as it may help me in my searches. Some details on my use case: I am developing a system for modular video synthesis with raspberry pis. The idea is to route GP...
by treefella
Fri May 17, 2019 9:31 pm
Forum: General discussion
Topic: RPI acting both as slave and as master device on its usb ports
Replies: 22
Views: 868

Re: RPI acting both as slave and as master device on its usb ports

Hey there, wondering If you where able to get this to work? I'm thinking of creating a device with the Compute Module and using the USB as a way to bridge a network connection between multiple Pis in a sort of mesh network. One could use an ethernet controller like the one implemented on the bigger ...
by treefella
Mon Apr 25, 2016 5:26 pm
Forum: Graphics programming
Topic: Pi Zero + OpenCV: Illegal instruction
Replies: 5
Views: 6087

Re: Pi Zero + OpenCV: Illegal instruction

I tried recompiling OpenCV and disabling SSE / SSE2 as suggested by some other threads but this did not help. I looked at the address where the crash was happening and found this in the disassembly: 0x00027408 <+160>: mov r0, r3 => 0x0002740c <+164>: vmov.f32 s0, #112 ; 0x70 0x00027410 <+168>: bl 0x...
by treefella
Thu Apr 21, 2016 3:41 pm
Forum: Graphics programming
Topic: Pi Zero + OpenCV: Illegal instruction
Replies: 5
Views: 6087

Pi Zero + OpenCV: Illegal instruction

Hey all, I'm trying to get OpenCV to work on my Pi B+1.2 or Zero and on both platforms I get an "Illegal instruction" error at runtime due to OpenCV functions. I have built OpenCV from scratch on the Zero and B+ & this identical program runs just fine on both the Pi2 & Pi3. The crash in GDB: Program...
by treefella
Thu Apr 21, 2016 12:11 am
Forum: Compute Module
Topic: USB Gadget Mode on Compute Module
Replies: 12
Views: 5157

Re: USB Gadget Mode on Compute Module

I have unsoldered R12 and now I can ground OTGID whenever I don't need gadget mode.

Thanks for your help! :D
by treefella
Tue Apr 05, 2016 12:03 am
Forum: Compute Module
Topic: USB Gadget Mode on Compute Module
Replies: 12
Views: 5157

USB Gadget Mode on Compute Module

Hey all! Is it possible to use the otg port on the compute module dev board for USB gadget mode? I am using the midi gadget & I have gotten gadget mode to work on the zero sending signals back and forth. The CM's OS opens the port internally and seems to be set up exactly like the zero but it is not...
by treefella
Fri Apr 01, 2016 11:48 pm
Forum: General discussion
Topic: BLE MIDI GATT Service on Pi3
Replies: 8
Views: 4740

Re: BLE MIDI GATT Service on Pi3

Very well, I will give BlueZ a go and report back.

Thanks Douglass!
by treefella
Tue Mar 29, 2016 11:39 pm
Forum: General discussion
Topic: BLE MIDI GATT Service on Pi3
Replies: 8
Views: 4740

BLE MIDI GATT Service on Pi3

Hey all! I am trying to get my pi to work as a bluetooth MIDI device according to the new spec: https://developer.apple.com/bluetooth/Apple-Bluetooth-Low-Energy-MIDI-Specification.pdf I have been able to set up connections and send/recieve data using gatttool, but I cannot seem to figure out how to ...
by treefella
Fri Mar 25, 2016 12:05 am
Forum: Advanced users
Topic: Pi Zero OTG MIDI
Replies: 1
Views: 2091

Re: Pi Zero OTG MIDI

I'm currently on a similar journey. Follow this guide: http://blog.gbaman.info/?p=699 Replace module names with "g_midi" when you activate the module name. Skip to the MIDI section on this page: https://github.com/torvalds/linux/blob/master/Documentation/usb/gadget-testing.txt Follow the directions ...

Go to advanced search