Go to advanced search

by PiBurner
Tue Aug 13, 2019 12:17 am
Forum: Troubleshooting
Topic: Buster can't see other computers on network
Replies: 9
Views: 627

Re: Buster can't see other computers on network

So, you're saying Buster won't allow me to browse the network.
Guess I'll stay with the older versions of raspbian (and not update anymore).
In my book, network browsing if a feature, not a fault.
Thanks for the help.
by PiBurner
Mon Aug 12, 2019 3:04 pm
Forum: Troubleshooting
Topic: Buster can't see other computers on network
Replies: 9
Views: 627

Re: Buster can't see other computers on network

The reason that your clients can only see one share is because you are telling Samba not to advertise the other two with 'browseable = no', though if you connect as the user 'pi', you should get two shares. This is not a problem at this point. I'll add shares after the problem seeing other pc's is ...
by PiBurner
Sun Aug 11, 2019 11:47 pm
Forum: Troubleshooting
Topic: Buster can't see other computers on network
Replies: 9
Views: 627

Re: Buster can't see other computers on network

There's no provision for the WINS server on the Buster samba.conf. It's just the default samba.conf with the workgroup changed. # # Sample configuration file for the Samba suite for Debian GNU/Linux. # # # This is the main Samba configuration file. You should read the # smb.conf(5) manual page in or...
by PiBurner
Sun Aug 11, 2019 3:16 pm
Forum: Troubleshooting
Topic: Buster can't see other computers on network
Replies: 9
Views: 627

Buster can't see other computers on network

I have set up a new install of Buster on a Pi3, it can't see the other Pi or Win7 pc's on the network. All I get when using filemanage network search is an icon for etwork:///dnssd-domain-PIDEVBUSTER._smb._tcp and smb-root.I have installed samba and samba common, changed the workgroup name. Using a ...
by PiBurner
Thu Apr 18, 2019 1:13 am
Forum: Java
Topic: How to get GUI to show
Replies: 5
Views: 4727

Re: How to get GUI to show

There's something wrong in you app. Once you get it working in a terminal window with 'java -jar / path to the jar file / program name .jar', you can make it and other jar files launch with a double click this way: To set association for java .jar files so you can double click on it and launch, do t...
by PiBurner
Thu Apr 18, 2019 1:01 am
Forum: Java
Topic: Create executable of java program
Replies: 10
Views: 15324

Re: Create executable of java program

Assuming you have version 9 Stretch from April 2019 running on you pi: Once you have the .jar file made, I now have an easier way to set an association that has some advantages: To set association for java .jar files so you can double click on it and launch, do the following: Click on the start rasp...
by PiBurner
Thu Jan 03, 2019 8:54 pm
Forum: Advanced users
Topic: Worried with power outages and abrupt power loss
Replies: 9
Views: 755

Re: Worried with power outages and abrupt power loss

Perhaps a 'shutdown' script ("shutdown now" or such) that runs when a pair of GPIO pins are closed?
Still, you would need to remove all power and apply again to restart.
by PiBurner
Wed Jul 11, 2018 5:08 pm
Forum: Java
Topic: Create executable of java program
Replies: 10
Views: 15324

Re: Create executable of java program

See my updated post below.
by PiBurner
Fri Mar 23, 2018 1:54 am
Forum: Troubleshooting
Topic: Path= ignored if destop file is in autostart
Replies: 5
Views: 595

Solved, sort of Re: Path= ignored if destop file is in autostart

After scouring the 'net for a solution, I came upon a resolution that actually fits my need better. From SO posters Benny Neugebauer and dusan in https://stackoverflow.com/questions/320542/how-to-get-the-path-of-a-running-jar-file/320595#320595 I modified the suggestion slightly and put it in a meth...
by PiBurner
Thu Feb 15, 2018 4:58 pm
Forum: Troubleshooting
Topic: Path= ignored if destop file is in autostart
Replies: 5
Views: 595

Re: Path= ignored if destop file is in autostart

Path= is validated if the file is launched from the desktop. Not when launched from /.config/autostart.
This is the same if Working Directory is set from the Properties of the .desktop file on the desktop.
by PiBurner
Wed Feb 14, 2018 8:43 pm
Forum: Troubleshooting
Topic: Path= ignored if destop file is in autostart
Replies: 5
Views: 595

Re: Path= ignored if destop file is in autostart

Still the working directory is only /home/user.
by PiBurner
Wed Feb 14, 2018 4:53 pm
Forum: Troubleshooting
Topic: Path= ignored if destop file is in autostart
Replies: 5
Views: 595

Path= ignored if destop file is in autostart

I have a java app that needs to load a configuration file. The app and the file are in a specific folder under the /home/user/ folder. If I create a .desktop file (shortcut) and include the line 'Path=xxxx', the app starts correctly when I launch it from the desktop. But if the .desktop ( a copy) is...
by PiBurner
Sun Nov 12, 2017 4:42 pm
Forum: Beginners
Topic: Audio streaming using B.U.T.T.
Replies: 9
Views: 5043

Re: Audio streaming using B.U.T.T.

One more thing, BUTT wouldn't restart after the first time I used it. The following error to got written in the BUTT notices: PA: Format not supported: Device unavailable I ended up editing the .buttrc file in /home/[username]/ and set the device under the [Audio} section to '0'. Now it starts corre...
by PiBurner
Sun Nov 12, 2017 4:25 pm
Forum: Beginners
Topic: Running applications on startup
Replies: 29
Views: 106588

Re: Running applications on startup

to auto start apps in raspbian Stretch you need a folder in /home/[user]/.config (whatever your user name is) named autostart. In this folder you create text files named [filename].desktop (any filename will do) and put the following in it: [Desktop Entry] Type=Application Exec= the name and path to...
by PiBurner
Thu Nov 09, 2017 3:47 pm
Forum: Beginners
Topic: Audio streaming using B.U.T.T.
Replies: 9
Views: 5043

Re: Audio streaming using B.U.T.T.

This doesn't work 11/9/17 on rasbian Stretch. gives the following error: ~/software/source/fdk-aac $ ./autogen.sh ./autogen.sh: 2: ./autogen.sh: autoreconf: not found and: ./configure checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes /home...
by PiBurner
Fri Mar 17, 2017 2:42 pm
Forum: Automation, sensing and robotics
Topic: rivendell radio automation
Replies: 7
Views: 4341

Re: rivendell radio automation

It turns out the SD card I was using was the problem getting audio to work on Rivendell. The OS was so slow... that made me think I'd seen this before. I made a new card (sandisk) and now everything is working.
by PiBurner
Sun Mar 12, 2017 5:52 pm
Forum: Automation, sensing and robotics
Topic: rivendell radio automation
Replies: 7
Views: 4341

Re: rivendell radio automation

I downloaded the Pixel build from sourceforge, and it doesn't work. No audio. The menu item under rdadmin for alsa setup shows that a file is missing. Air play seems to be playing the test audios, but no sound from HDMI or my USB audio dongle. Both worked before with a Jessie build with VLC, etc. Do...
by PiBurner
Tue Mar 07, 2017 3:19 am
Forum: General discussion
Topic: latest Jessie downloar corrupt?
Replies: 6
Views: 1117

Re: latest Jessie downloar corrupt?

It unzips just fine with Bitzer. I was surprised to see that large a number, didn't know Win 7 could count that high :lol: I put the Pixel build on my old Pi2 to get chromium to work, and boy does it ever work! I use it on my large TV for browsing the web, the TV doesn't have a browser. Now, back to...
by PiBurner
Mon Mar 06, 2017 1:22 am
Forum: General discussion
Topic: latest Jessie downloar corrupt?
Replies: 6
Views: 1117

latest Jessie downloar corrupt?

I just downloaded the latest Jessie build 2017-03-02, and it won't unzip. Says I need an additional 734 PB (yes, PetaBytes) of disk space.
That's a mighty big server array you got there :P
by PiBurner
Tue May 17, 2016 2:01 am
Forum: Beginners
Topic: Epiphany bookmarks & homepage
Replies: 9
Views: 7671

Re: Epiphany bookmarks & homepage

It should work with the launcher under Menu-Internet-Web Browser. If so, you can then replace the Web Icon on the Application Launch Bar by right clicking on the Web icon, select 'Web browser under 'Launchers', and choose remove. Add the one from the Menu by clicking on 'Internet' in the right pane,...
by PiBurner
Thu Apr 28, 2016 4:45 pm
Forum: Raspbian
Topic: Main Menu editor
Replies: 2
Views: 1198

Main Menu editor

After doing an update/upgrade, the Main Menu Editor no longer works. Any new items don't show up, changes to existing entries don't change. Is there a way to re-install the editor (alacarte)?

Go to advanced search