Go to advanced search

by st0rmforce
Thu May 31, 2018 1:10 pm
Forum: Advanced users
Topic: Shutdown indicator?
Replies: 4
Views: 416

Re: Shutdown indicator?

thagrol wrote:
Thu May 31, 2018 12:33 pm
Have a look at the gpio_poweroff devicetree overlay.
Brilliant, that's exactly what I want :D
by st0rmforce
Thu May 31, 2018 12:05 pm
Forum: Advanced users
Topic: Shutdown indicator?
Replies: 4
Views: 416

Re: Shutdown indicator?

maybe some kind of pin-flashing program could be run at startup and I could make a circuit to monitor it, then turn off the power a number of seconds after the pin stops flashing? In that case your problem is solved, because a number (10?) of steady flashes of the green Activity led, followed by on...
by st0rmforce
Thu May 31, 2018 11:37 am
Forum: Advanced users
Topic: Shutdown indicator?
Replies: 4
Views: 416

Shutdown indicator?

I hope this is the best place for this. Is there a pin can be used, or configured to be used, as an indicator that the pi has finished shutting down? I'm working on a project with a pi 2 (although I may be swapping it out for a pi 3 at some point, if that matters) that's going to run from an ATX pow...
by st0rmforce
Mon Mar 07, 2016 11:54 am
Forum: Troubleshooting
Topic: Issue with Gert Enable_UART for Gertbot on Pi 2 .
Replies: 9
Views: 1613

Re: Issue with Gert Enable_UART for Gertbot on Pi 2 .

By the way, I also had trouble with the C and python drivers. Not sure if it's related to the OS update. Basically, the GUI binary worked fine once I'd enabled the uart, I could control 4 motors perfectly. Downloaded the driver, opened up python, made a little test: nothing. Realised I was using pyt...
by st0rmforce
Mon Mar 07, 2016 11:06 am
Forum: HATs and other add-ons
Topic: Gertbot Control using Python Drivers
Replies: 8
Views: 6176

Re: Gertbot Control using Python Drivers

I managed to fix it, although I haven't had time to work out what the problem was. I rewrote the python driver myself, working from the control commands from the GUI log output and it works fine. I didn't use the termios library commands that are in the enable_uart function, I just opened the tty (b...
by st0rmforce
Sun Mar 06, 2016 4:06 pm
Forum: HATs and other add-ons
Topic: Gertbot Control using Python Drivers
Replies: 8
Views: 6176

Re: Gertbot Control using Python Drivers

After some fiddling about with the uart I've managed to get the GUI to work and spin my motors. I then tried using the python drivers, nothing. Tried the python test code from the site, nothing. Tried downloading the updated version and making sure I'm running python 3.4.2. Nothing. Does anybody hav...
by st0rmforce
Wed Mar 02, 2016 11:51 am
Forum: Troubleshooting
Topic: Issue with Gert Enable_UART for Gertbot on Pi 2 .
Replies: 9
Views: 1613

Re: Issue with Gert Enable_UART for Gertbot on Pi 2 .

I got around the problem by doing it manually. All the enable uart app does, is removes references to the ttyAMA0 uart from /boot/cmdline.txt and inittab. Seeing as inittab doesn't exist I just manually went in and stripped it out of cmdline.txt. I just made a backup and then removed "console=ttyAMA...

Go to advanced search