Go to advanced search

by smarz2
Sun Feb 21, 2016 8:17 am
Forum: Troubleshooting
Topic: pi button audio not working
Replies: 3
Views: 1118

Re: pi button audio not working

I figured out my problem, My python script had the line below: os.system('mpg123 -q Memo.mp3 &') This code worked great from a command line while I was logged in as"pi", but when the script is run on boot from /etc/rc.local, the file takes on root's environment variables, and the Memo.mp3 file which...
by smarz2
Sun Feb 21, 2016 8:16 am
Forum: Troubleshooting
Topic: STICKY: Setting up HDMI output when video output is wrong.
Replies: 528
Views: 835556

Re: Setting up HDMI output when video output isn't what you

I figured out my problem, My python script had the line below: os.system('mpg123 -q Memo.mp3 &') This code worked great from a command line while I was logged in as"pi", but when the script is run on boot from /etc/rc.local, the file takes on root's environment variables, and the Memo.mp3 file which...
by smarz2
Sun Feb 21, 2016 1:50 am
Forum: Troubleshooting
Topic: STICKY: Setting up HDMI output when video output is wrong.
Replies: 528
Views: 835556

Re: Setting up HDMI output when video output isn't what you

FAQ Logout [ smarz2 ] smarz2 Unread PostsNew Posts pi button audio not working Post a reply Watch 2 posts Report this post Reply with quote Permalink by cmlop02 » Sat Oct 03, 2015 7:42 am i've been trying to do this project https://learn.adafruit.com/playing-soun ... i/overview my wireing is right b...
by smarz2
Sun Feb 21, 2016 1:48 am
Forum: Troubleshooting
Topic: pi button audio not working
Replies: 3
Views: 1118

Re: pi button audio not working

I have a python script which plays an mp3 file using mpg123. When I run the python script from a command line, the mp3 file plays. When I place the python script in /etc/rc.local to run the python script on R-Pi bootup, most of the script runs perfectly except the mp3 file does not play, and I recei...
by smarz2
Sun Feb 14, 2016 6:04 am
Forum: Automation, sensing and robotics
Topic: Parallax PING))) ?
Replies: 21
Views: 12462

Re: Parallax PING))) ?

My code gets stuck in the starttime calculation:
starttime-watchtime

This value is always zero for me. Do I need to add a time delay between starttime and watchtime value collection?

Go to advanced search