Go to advanced search

by Grumpy Mike
Mon Apr 13, 2020 4:00 pm
Forum: Python
Topic: Tkinter - How to get a slider's value
Replies: 6
Views: 311

Re: Tkinter - How to get a slider's value

What are you expecting the value to do once it arrives at the GPIO pin? Just sending it an int will set the pin low for a value of zero and high for any other value. I think this is not what you want to do is it? From the origional post I see you want an LED to reflect the brightness of the slider, ...
by Grumpy Mike
Mon Apr 13, 2020 10:49 am
Forum: Python
Topic: SPI transfer speed using pigpio
Replies: 0
Views: 80

SPI transfer speed using pigpio

I am using the pigpio library with python to transfer bytes to the SPI port. Using a Pi 4 and version 74. For testing I am using the following code:- import pigpio import os import time os.system("sudo pigpiod") time.sleep(1.0) pi = pigpio.pi() # open SPI device on channel 1 in mode 3 at 50000 bits ...
by Grumpy Mike
Sun Apr 05, 2020 3:48 pm
Forum: Python
Topic: Python audio output from an algorithm
Replies: 0
Views: 80

Python audio output from an algorithm

I seem to remember that at one time I saw something that would allow you to write individual samples into a fifo buffer, and the buffer would be played out to the audio. I think it either used a USB sound card or an I2S board to do this. However now I come to search for it again I can't find anythin...
by Grumpy Mike
Mon Feb 17, 2020 3:17 pm
Forum: Troubleshooting
Topic: Independent Sound HDMI0 and HDMI1
Replies: 27
Views: 10949

Re: Independent Sound HDMI0 and HDMI1

Looks like it is broken again. I has buster working in November but had to reinstall it last week NOOBS_v3_3_0 and now I can't get sound out of either HDMI socket.
Any ideas?
by Grumpy Mike
Sun Feb 16, 2020 1:15 pm
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

Thanks joan - Yes, I am not complaining about it, I just didn't realise the latency of a call back. So any mistake is down to me not the system. I was hoping to use a simpler algorithm but I will have to have the edge triggered events on both pins. Another algorithm would involve changing the edge a...
by Grumpy Mike
Sat Feb 15, 2020 8:23 pm
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

I don't know what you try to measure, but I cannot believe what you state. Well sorry it is true. Reason was that default pigpio sample rate is 5us: I can see that might be a problem if you are trying to produce a single digit microsecond length pulse, but I am not talking about an output pulse her...
by Grumpy Mike
Sat Feb 15, 2020 11:56 am
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

Or reading a pin at the wrong logic level when an edge is detected from another pin. Well I have sorted that one. I didn't quite realise just how none real time pigpio is. It can take about 6mS on top of the glitch filter time to report a falling edge meaning the data I was looking for was sometime...
by Grumpy Mike
Sat Feb 15, 2020 6:32 am
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

The module should normally be left unchanged OK that's fine but it means I can't use it, due to contractual obligations of how I must present code. So I will write my own. Incidentally I am not convinced that pigpio actually does what is says on the can. Its response to signals does not match up to...
by Grumpy Mike
Fri Feb 14, 2020 7:10 am
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

Ok some progress. I have found out that the error message Can't lock /var/run/pigio.pid Can't initialise pigio library Occurs if pigio is already running. If this happens you should issue a "sudo killall pigiod" and then reissue the "sudo pigiod" I am still not 100% on why sometimes it is running fr...
by Grumpy Mike
Fri Feb 14, 2020 4:39 am
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

Thanks, but:- The pigpio daemon is not started, start it I did try. I typed sudo pigpiod in the command window. It gave me the error message:- Can't lock /var/run/pigio.pid Can't initialise pigio library The pigio.pid file contains just the number 3858. This is on a fresh install yesterday of the OS...
by Grumpy Mike
Thu Feb 13, 2020 6:06 pm
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

Sorry it is this one I am trying to use:- https://pypi.org/project/pigpio-encoder/ I looked at the code on your site and quite honestly I can't make much sense of it. It seems to be written in the sort of python style that is totally alien to me. But now pigpio is refusing to run it is reporting:- "...
by Grumpy Mike
Thu Feb 13, 2020 3:24 pm
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

Thanks, but that's the one I am using.
by Grumpy Mike
Thu Feb 13, 2020 10:10 am
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

Re: pigpio_encoder not installing on Buster

Perhaps you just need import pigpio_encoder. Thanks I did try that and got the same sort of error message. I did copy the example over to my local directory and try including it from there. That actually worked but unfortunately was a bit rubbish. Every encoder movement reported back as a short cli...
by Grumpy Mike
Thu Feb 13, 2020 5:43 am
Forum: Python
Topic: pigpio_encoder not installing on Buster
Replies: 19
Views: 873

pigpio_encoder not installing on Buster

I am trying to get the pigpio encoder working to read a KY040 rotary encoder. I am using the Buster OS. I have installed it and attempts to reinstall it give me:- [email protected]:~ $ sudo pip3 install pigpio_encoder Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple Requirement...
by Grumpy Mike
Wed Jan 01, 2020 10:29 pm
Forum: Python
Topic: Circuit Python output array
Replies: 2
Views: 271

Re: Circuit Python output array

Thanks a lot, you gave me the clue as to what I needed to do. Perhaps you could better explain what you mean by "can not be replaced by a variable". There is a rule in programming that if you find yourself writing almost the same lines over and over, then you need to find a better way. In this case ...
by Grumpy Mike
Wed Jan 01, 2020 5:07 pm
Forum: Python
Topic: Circuit Python output array
Replies: 2
Views: 271

Circuit Python output array

I am trying to define an array of outputs using Circuit Python. The only way I can do it is by using this stupid turgid method: LEDs = [] led = io.DigitalInOut(board.D5) led.direction = io.Direction.OUTPUT LEDs.append(led) led = io.DigitalInOut(board.D6) led.direction = io.Direction.OUTPUT LEDs.appe...
by Grumpy Mike
Tue Dec 10, 2019 7:09 am
Forum: General discussion
Topic: Pi 4 a cautionary tale
Replies: 14
Views: 1247

Re: Pi 4 a cautionary tale

Thanks for all the input. I have removed "self adhesive" heat sinks with a small screwdriver in the past quite successfully, but always with much bigger chips. No damage to the tracks on the Pi's PCB by the way. I will not use a fan end of. There is no need, but I have been using thick aluminum base...
by Grumpy Mike
Mon Dec 09, 2019 5:16 am
Forum: General discussion
Topic: Pi 4 a cautionary tale
Replies: 14
Views: 1247

Pi 4 a cautionary tale

I got all the components together to try out my new Pi 4 this weekend. This included the nice looking wrap around heat sink. This made the Wi-Fi performance a lot less sensitive as I suspected, but the connection was also dropping out regularly. Therefore I removed the heatsink top and just screwed ...
by Grumpy Mike
Fri Dec 06, 2019 3:10 pm
Forum: Python
Topic: Pi 4 How to install IDLE3 ?
Replies: 2
Views: 309

Re: Pi 4 How to install IDLE3 ?

Thanks, but I have already found this thread. It was for the Pi 3 and as you know when you change the Pi model along with the OS the normal state of things is that all posts prior to that new release no longer work. One reply stated:- idle 3.7 is not in 'Stretch' but will be in 'Buster' when it is r...
by Grumpy Mike
Fri Dec 06, 2019 2:43 pm
Forum: Python
Topic: Pi 4 How to install IDLE3 ?
Replies: 2
Views: 309

Pi 4 How to install IDLE3 ?

Just trying to set up my new Pi4 today. As usual with a new OS nothing much works.
So has anyone got an idea of how to install IDLE3?
I tried apt and pip and they both failed.
Thanks
by Grumpy Mike
Thu Sep 05, 2019 4:21 pm
Forum: Networking and servers
Topic: VNC working one way but not the other
Replies: 12
Views: 901

Re: VNC working one way but not the other

Thanks. Well the good news is that I got it working over Wi-Fi by using the sudo raspi-config Method which I did try yesterday to no effect. Mind you yesterday I was trying to use the Ethernet cable which is now not working but hey such is Linux. Now to try and get the cable working again. Thanks fo...
by Grumpy Mike
Thu Sep 05, 2019 2:57 pm
Forum: Networking and servers
Topic: VNC working one way but not the other
Replies: 12
Views: 901

Re: VNC working one way but not the other

I didn't say it was from something you put but something has stopped the Ethernet cable from working. Obvious statement - does it have the GUI running at start up? Yes the Pi is set to boot up into the desktop. Can I check what version of the OS you are using? Not sure if it is relevant because it h...
by Grumpy Mike
Thu Sep 05, 2019 2:18 pm
Forum: Networking and servers
Topic: VNC working one way but not the other
Replies: 12
Views: 901

Re: VNC working one way but not the other

Thanks for the reply. Sadly like most things Linux related when you try and fix things it gets worse. As a result of trying the stuff yesterday I can no longer get an Ethernet connection. All I get is alternate flashing arrows on the network icon and words saying "configuring" after half an hour, I ...
by Grumpy Mike
Wed Sep 04, 2019 4:22 pm
Forum: Networking and servers
Topic: VNC working one way but not the other
Replies: 12
Views: 901

Re: VNC working one way but not the other

Thanks for the responses, Are you using a beta OS on your Mac? No I am using Mojave V 10.14.6 latest update from only yesterday. I had the same problem last week before the update. Are you using the RealVNC client (VNC Viewer) on the Mac? Yes. Have you registered the client on the Pi? It does not ma...
by Grumpy Mike
Wed Sep 04, 2019 1:06 pm
Forum: Networking and servers
Topic: VNC working one way but not the other
Replies: 12
Views: 901

VNC working one way but not the other

I am trying to share the Raspberry Pi's screen on my Mac. I can successfully do it the other way round and control my Mac's screen from the Pi but when I try to connect from the Mac to the Pi using RealVNC I either get a "no response from computer" or a time out. I do not get the validation box on t...

Go to advanced search