Go to advanced search

by jezmck
Tue Mar 08, 2016 8:21 pm
Forum: Troubleshooting
Topic: Error when using PHP to run Shell script to play whitenoise
Replies: 1
Views: 334

Re: Error when using PHP to run Shell script to play whiteno

I should have waited a little longer before posting!

I'll leave the answer I found here for anyone else though.

http://sox.10957.n7.nabble.com/Execute- ... p1078.html

Code: Select all

sudo usermod -a -G audio www-data
sudo apachectl restart
by jezmck
Tue Mar 08, 2016 8:16 pm
Forum: Troubleshooting
Topic: Error when using PHP to run Shell script to play whitenoise
Replies: 1
Views: 334

Error when using PHP to run Shell script to play whitenoise

Hi, I have the following PHP: if (...) { $path = '/home/pi/noise.sh'; echo `sh $path 2>&1`; } and bash script: #!/bin/bash len=${1-00:00:05} play --single-threaded -t sl - synth $len whitenoise band -n 1200 200 tremolo 20 .1 < /dev/zero and these two give me the rather saddening ALSA lib confmisc.c:...
by jezmck
Sun Mar 23, 2014 5:26 pm
Forum: Gaming
Topic: NEW: Darkplaces Quake engine up and running on Raspberry PI
Replies: 112
Views: 58686

Re: NEW: Darkplaces Quake engine up and running on Raspberry

...Here is an example of real-time system monitoring while running the engine. This tool runs as a service under NodeJS and is displayed in a browser on a desktop system: https://lh3.googleusercontent.com/-oAGR3XyM3ig/Uyd7HzG6ezI/AAAAAAAAAGE/AI3wR2kGqiY/w512-h227-no/piface1_512.jpg What's that? Loo...
by jezmck
Fri May 24, 2013 10:50 am
Forum: Camera board
Topic: More Timelapse
Replies: 10
Views: 1962

Re: More Timelapse

Why does everyone keep saying that?

That's a rotation not a mirror/flip.
by jezmck
Fri May 24, 2013 10:49 am
Forum: Camera board
Topic: EXIF Data - Please include the date/time by default
Replies: 6
Views: 1963

Re: EXIF Data - Please include the date/time by default

Those second two dates aren't held in the EXIF.
by jezmck
Thu May 23, 2013 9:49 pm
Forum: Camera board
Topic: EXIF Data - Please include the date/time by default
Replies: 6
Views: 1963

Re: EXIF Data - Please include the date/time by default

BTW, I've not yet even managed to set it using the -x param. :oops:
Should I assume that I need to some absurd US date format instead of ISO8601?
By the looks of exif's debug output the key is DateTime.
Double quotes to surround the value?

exif shows

Code: Select all

Date and Time | 1970:01:01 00:00:00
by jezmck
Thu May 23, 2013 9:33 pm
Forum: Camera board
Topic: EXIF Data - Please include the date/time by default
Replies: 6
Views: 1963

EXIF Data - Please include the date/time by default

Thanks to everyone who's made the camera happen - I'm getting great results with it already! :D

Could someone please post a patch (to be merged into raspistill) to include the date/time in the EXIF data by default?

I'd love to see how that's actually done, but am busy this weekend (at a wedding).
by jezmck
Thu May 23, 2013 9:28 pm
Forum: Camera board
Topic: More Timelapse
Replies: 10
Views: 1962

Re: More Timelapse

Some camera are outputting mirrored images, this'll be fixed with the next software update.
by jezmck
Wed May 22, 2013 6:14 pm
Forum: Camera board
Topic: image is horizontally flipped
Replies: 6
Views: 1501

Re: image is horizontally flipped

Mine is horizontally flipped (need `-hf` to fix it).

Sounds like it's different for different people - is that true?
by jezmck
Wed May 22, 2013 6:12 pm
Forum: Camera board
Topic: webcam project
Replies: 2
Views: 2520

Re: webcam project

Some useful info, thanks.
Esp the exposure issue and the overlay graphic. :)
by jezmck
Wed May 22, 2013 6:03 pm
Forum: Camera board
Topic: Raspicam Command Line Generator
Replies: 26
Views: 6250

Re: Raspicam Command Line Generator

Very nice.

I guess -vs Turn on video stabilisation is also a raspivid specific setting though.
by jezmck
Fri Apr 26, 2013 6:25 pm
Forum: General discussion
Topic: CLI output of webcam (i.e. in ASCII)
Replies: 3
Views: 1172

Re: CLI output of webcam (i.e. in ASCII)

Yep, that's the option I've had most success with.

But .... It only draws a few frames, seems to always update only the area circled, and then hangs.

The pi is then usuable (in a different ssh session), but vlc uses ~91% cpu and is unkillable!

Image
by jezmck
Thu Apr 25, 2013 5:51 pm
Forum: General discussion
Topic: CLI output of webcam (i.e. in ASCII)
Replies: 3
Views: 1172

CLI output of webcam (i.e. in ASCII)

Hi everyone, I'd like to be able to see output from my webcam (either live video or a single frame) on the command line. I've been misunderstood elsewhere, so I'll reiterate: on the command line, via ssh (putty), as ASCII, I don't want to stream anything, I don't want to save a jpg or mpg or any oth...
by jezmck
Tue Jan 15, 2013 6:34 pm
Forum: General discussion
Topic: Can't see links
Replies: 19
Views: 4749

Re: Can't see links

It can't be hard to add

Code: Select all

a.postline { text-decoration: underline; }
to bootstrap-raspi.css, can it?
About line 127 would be good.
by jezmck
Thu Jul 19, 2012 2:31 pm
Forum: General discussion
Topic: Can't see links
Replies: 19
Views: 4749

Re: Can't see links

That's mental. Give me access and I'll fix it in two minutes.
by jezmck
Wed Jul 18, 2012 6:52 pm
Forum: General discussion
Topic: Can't see links
Replies: 19
Views: 4749

Re: Can't see links

bump!
by jezmck
Sat Jun 09, 2012 9:10 am
Forum: Troubleshooting
Topic: Unable to mount root fs
Replies: 7
Views: 5036

Re: Unable to mount root fs

Can you try the other OSs? e.g. Arch.
by jezmck
Thu May 31, 2012 5:49 pm
Forum: Graphics, sound and multimedia
Topic: USB Webcam? (Command Line)
Replies: 7
Views: 12341

Re: USB Webcam? (Command Line)

Ooh, cool.
I'll try the rpi-update firmware updater by Hexxeh.
by jezmck
Wed May 30, 2012 10:42 pm
Forum: Troubleshooting
Topic: Logitech webcams
Replies: 12
Views: 13236

Re: Logitech webcams

Is there really no way to do it without creating a new kernel?!
by jezmck
Wed May 30, 2012 10:38 pm
Forum: Troubleshooting
Topic: Unable to mount root fs
Replies: 7
Views: 5036

Re: Unable to mount root fs

I had the same problem with 4 SD cards.

I ended up ordering a preloaded card from ebay, and my pi now works fine.
by jezmck
Wed May 30, 2012 7:09 am
Forum: General discussion
Topic: Raspberry Pi ASCII Art
Replies: 34
Views: 45578

Re: Raspberry Pi ASCII Art

Nvm, it works after a reboot.
by jezmck
Tue May 29, 2012 11:02 pm
Forum: Graphics, sound and multimedia
Topic: USB Webcam? (Command Line)
Replies: 7
Views: 12341

USB Webcam? (Command Line)

I'm quite an experienced linux user when it comes to using it as a web server, but need help with this. (Debian) I've seen a number of pages about using a webcam from the command line, in particular this page , but /dev/video0 doesn't exist. Running usb-devices I get T: Bus=01 Lev=02 Prnt=02 Port=01...
by jezmck
Tue May 29, 2012 10:48 pm
Forum: General discussion
Topic: Raspberry Pi ASCII Art
Replies: 34
Views: 45578

Re: Raspberry Pi ASCII Art

The message isn't showing up for me.

Using debian.

On other machines I've edited /etc/motd.tail so I tried that here, but to no avail.

Any ideas?
by jezmck
Tue May 29, 2012 8:53 pm
Forum: General discussion
Topic: Can't see links
Replies: 19
Views: 4749

Can't see links

If people put links inline with the text, it's nigh-on impossible to see them.

Can we have a colour or underline style please?

Go to advanced search