Go to advanced search

by gsh
Wed Jan 02, 2019 10:47 am
Forum: Compute Module
Topic: Flashing IO board
Replies: 2
Views: 675

Re: Flashing IO board

If the board is getting really hot then something is wrong with either it or the CMIO board... I'd suggest returning
by gsh
Fri Dec 28, 2018 9:37 am
Forum: Compute Module
Topic: About the jtag
Replies: 2
Views: 457

Re: About the jtag

That is correct... The JTAG on the PCB is the videocore one, the arm JTAG can be enabled on the gpio connector

Turns out Eben talked our management at the time to add the arms to the device just for future interesting opportunities... Which of course turned out to be raspberry pi

Gordon
by gsh
Tue Dec 18, 2018 12:06 pm
Forum: Official Foundation Display
Topic: Upper half of the digitizer is not working [NOOB edition]
Replies: 23
Views: 4578

Re: Upper half of the digitizer is not working [NOOB edition]

Yes, just waiting for jamesh to test it and then we should be able to diagnose what has gone wrong...

Gordon
by gsh
Thu Nov 29, 2018 2:12 pm
Forum: Official Foundation Display
Topic: Display's interrupt pin question
Replies: 5
Views: 1064

Re: Display's interrupt pin question

You're right, it's just the camera and display on that bus. But it shouldn't use the bus directly...

Would it instead be better to develop a mailbox interface to access the I2C interface in a suitably locked manor?

Gordon
by gsh
Thu Nov 29, 2018 11:18 am
Forum: Official Foundation Display
Topic: Display's interrupt pin question
Replies: 5
Views: 1064

Re: Display's interrupt pin question

Also since you're now directly controlling the I2C from the ARM then the GPU can no longer control the PMU and it's likely to cause problems with crashing as soon as it moves to turbo...

Or are you using some mailbox to communicate the I2C commands across to the GPU?

Gordon
by gsh
Sun Nov 18, 2018 2:31 pm
Forum: General discussion
Topic: 3A+ usbboot/rpiboot
Replies: 28
Views: 1973

Re: 3A+ usbboot/rpiboot

Yes, that's right... The whole problem is as described above... RE OTP bits that have been set and why this causes a problem. It only effects booting from USB as a device (i.e. using rpiboot). Although if you want to make the 3A+ into an ethernet RNDIS device (so it appears on your computer's networ...
by gsh
Fri Nov 16, 2018 6:22 pm
Forum: General discussion
Topic: 3A+ usbboot/rpiboot
Replies: 28
Views: 1973

Re: 3A+ usbboot/rpiboot

Depends what you mean, you can run the port in device mode fine, you just need to add mode=peripheral to the dwc3 line.

You just can't boot from USB in device mode... And as I sat we're thinking about changing that decision

Gordon
by gsh
Fri Nov 16, 2018 4:59 pm
Forum: General discussion
Topic: 3A+ usbboot/rpiboot
Replies: 28
Views: 1973

Re: 3A+ usbboot/rpiboot

No the connection is under the processor
by gsh
Fri Nov 16, 2018 1:21 pm
Forum: General discussion
Topic: 3A+ usbboot/rpiboot
Replies: 28
Views: 1973

Re: 3A+ usbboot/rpiboot

No the problem is that we've enabled host booting on 3A+ without realising the problem this subsequently causes for device booting... There are two bits in the OTP for the Raspberry Pi chip, one which enables device booting (i.e. using rpiboot so it comes up as a device) and a separate bit to enable...
by gsh
Tue Nov 13, 2018 11:57 am
Forum: Official Foundation Display
Topic: official display with dsi interface for bought
Replies: 6
Views: 2318

Re: official display with dsi interface for bought

You'll have to go look at the up-streamed GPU code in the linux kernel. We do not support this interface at the moment so cannot offer any further support

https://github.com/torvalds/linux/blob/ ... chscreen.c

Gordon
by gsh
Tue Oct 30, 2018 9:36 am
Forum: Official Foundation Display
Topic: Upper half of the digitizer is not working [NOOB edition]
Replies: 23
Views: 4578

Re: Upper half of the digitizer is not working [NOOB edition]

Can you email [email protected] and mention we asked you to for the attention of JamesH, it'd be good to get it back here and test directly...

Gordon
by gsh
Sun Oct 28, 2018 6:09 am
Forum: Compute Module
Topic: ssh over usb to a Compute Module 3
Replies: 5
Views: 2977

Re: ssh over usb to a Compute Module 3

So you're still getting the error message in dmesg at bootup? Can you paste the relevant bit of the message

Gordon
by gsh
Thu Oct 25, 2018 1:21 pm
Forum: Official Foundation Display
Topic: Upper half of the digitizer is not working [NOOB edition]
Replies: 23
Views: 4578

Re: Upper half of the digitizer is not working [NOOB edition]

OK, that's wierd!

If you can give us any information about the versions of update you did... We'll see if we can reproduce, but it sounds like it is some combination of software and hardware problem.

Gordon
by gsh
Tue Oct 02, 2018 11:57 am
Forum: Compute Module
Topic: cm3 boot problem eMMC
Replies: 1
Views: 564

Re: cm3 boot problem eMMC

Does it still work if you use a Raspbian image on there?

i.e. just dd a Raspbian Lite image to the CM3
by gsh
Mon Oct 01, 2018 10:53 am
Forum: HATs and other add-ons
Topic: Anybody interested in talking direct! to IDE/SATA?
Replies: 28
Views: 6106

Re: Anybody interested in talking direct! to IDE/SATA?

Probably best to look at the sources in the linux kernel

https://github.com/raspberrypi/linux/bl ... 2835_smi.c
by gsh
Fri Sep 28, 2018 2:13 pm
Forum: Compute Module
Topic: rpiboot can't see CM1.1 with Elpida memory
Replies: 6
Views: 927

Re: rpiboot can't see CM1.1 with Elpida memory

Can you email me [email protected] I think it's worth retrieving them and having a look...
by gsh
Fri Sep 28, 2018 12:29 pm
Forum: Compute Module
Topic: multi-Programmer or customizing service
Replies: 4
Views: 636

Re: multi-Programmer or customizing service

Don't forget you only need to connect to the PC to upload the initial image. Once you've done that (if you're doing something like scriptexecutor) you can use any of the interfaces on your target hardware to get the image from. For the Slice project, we just took the compute module and put it into t...
by gsh
Fri Sep 28, 2018 9:26 am
Forum: Compute Module
Topic: LAN9514
Replies: 24
Views: 2762

Re: LAN9514

Also upvote John's post...
by gsh
Fri Sep 28, 2018 9:10 am
Forum: Compute Module
Topic: rpiboot can't see CM1.1 with Elpida memory
Replies: 6
Views: 927

Re: rpiboot can't see CM1.1 with Elpida memory

Just tried rebuilding and running rpiboot on a Pi 3B+ with both Samsung and Elpida memories on RPI-CM v1.1 boards Both boot fine for me Can you check the quality of the USB cable you are using, we have found some issues with some cables, although not at this stage in the boot process. At the stage o...
by gsh
Fri Sep 28, 2018 8:59 am
Forum: Compute Module
Topic: rpiboot can't see CM1.1 with Elpida memory
Replies: 6
Views: 927

Re: rpiboot can't see CM1.1 with Elpida memory

What host are you running rpiboot on? A Raspberry Pi or a PC?

Gordon
by gsh
Thu Sep 27, 2018 10:45 am
Forum: Compute Module
Topic: rpiboot can't see CM1.1 with Elpida memory
Replies: 6
Views: 927

Re: rpiboot can't see CM1.1 with Elpida memory

When you say you 'downloaded' rpiboot, did you use git clone to get it from https://github.com/raspberrypi/usbboot
by gsh
Wed Sep 26, 2018 12:38 pm
Forum: Compute Module
Topic: LAN9514
Replies: 24
Views: 2762

Re: LAN9514

The great thing about a competitive landscape for components like this is that you get to vote with your feet. There are many other devices available to you. The idea we had was 'our idea' - we asked them whether it was possible - they gave us a method for implementing it This isn't a case of them g...
by gsh
Wed Sep 26, 2018 10:54 am
Forum: Compute Module
Topic: LAN9514
Replies: 24
Views: 2762

Re: LAN9514

No, the undocumented features are actually test modes of the device. It is completely normal not to document test modes. We just came up with an idea of how to use one of their test modes.
by gsh
Wed Sep 26, 2018 9:57 am
Forum: Compute Module
Topic: LAN9514
Replies: 24
Views: 2762

Re: LAN9514

The reason we have this different setup is due to undocumented changes to reduce power consumption of the 9514 device. I'm sorry but we can't release the documentation to you on this. I would suggest you just wire it up like the app note and ignore the way the Raspberry Pi is wired.

Gordon
by gsh
Mon Sep 24, 2018 2:48 pm
Forum: Compute Module
Topic: CM3 and CM1 SDX_VREF question
Replies: 4
Views: 624

Re: CM3 and CM1 SDX_VREF question

No you need to connect pins 4 and 6 of your compute module connector to 3.3v that is not the same as GPIO4 and GPIO6 (pins 15 and 21 respectively)

Go to advanced search