Go to advanced search

by gsh
Tue Oct 02, 2018 11:57 am
Forum: Compute Module
Topic: cm3 boot problem eMMC
Replies: 1
Views: 140

Re: cm3 boot problem eMMC

Does it still work if you use a Raspbian image on there?

i.e. just dd a Raspbian Lite image to the CM3
by gsh
Mon Oct 01, 2018 10:53 am
Forum: Add-ons
Topic: Anybody interested in talking direct! to IDE/SATA?
Replies: 28
Views: 3966

Re: Anybody interested in talking direct! to IDE/SATA?

Probably best to look at the sources in the linux kernel

https://github.com/raspberrypi/linux/bl ... 2835_smi.c
by gsh
Fri Sep 28, 2018 2:13 pm
Forum: Compute Module
Topic: rpiboot can't see CM1.1 with Elpida memory
Replies: 6
Views: 257

Re: rpiboot can't see CM1.1 with Elpida memory

Can you email me [email protected] I think it's worth retrieving them and having a look...
by gsh
Fri Sep 28, 2018 12:29 pm
Forum: Compute Module
Topic: multi-Programmer or customizing service
Replies: 4
Views: 224

Re: multi-Programmer or customizing service

Don't forget you only need to connect to the PC to upload the initial image. Once you've done that (if you're doing something like scriptexecutor) you can use any of the interfaces on your target hardware to get the image from. For the Slice project, we just took the compute module and put it into t...
by gsh
Fri Sep 28, 2018 9:26 am
Forum: Compute Module
Topic: LAN9514
Replies: 23
Views: 809

Re: LAN9514

Also upvote John's post...
by gsh
Fri Sep 28, 2018 9:10 am
Forum: Compute Module
Topic: rpiboot can't see CM1.1 with Elpida memory
Replies: 6
Views: 257

Re: rpiboot can't see CM1.1 with Elpida memory

Just tried rebuilding and running rpiboot on a Pi 3B+ with both Samsung and Elpida memories on RPI-CM v1.1 boards Both boot fine for me Can you check the quality of the USB cable you are using, we have found some issues with some cables, although not at this stage in the boot process. At the stage o...
by gsh
Fri Sep 28, 2018 8:59 am
Forum: Compute Module
Topic: rpiboot can't see CM1.1 with Elpida memory
Replies: 6
Views: 257

Re: rpiboot can't see CM1.1 with Elpida memory

What host are you running rpiboot on? A Raspberry Pi or a PC?

Gordon
by gsh
Thu Sep 27, 2018 10:45 am
Forum: Compute Module
Topic: rpiboot can't see CM1.1 with Elpida memory
Replies: 6
Views: 257

Re: rpiboot can't see CM1.1 with Elpida memory

When you say you 'downloaded' rpiboot, did you use git clone to get it from https://github.com/raspberrypi/usbboot
by gsh
Wed Sep 26, 2018 12:38 pm
Forum: Compute Module
Topic: LAN9514
Replies: 23
Views: 809

Re: LAN9514

The great thing about a competitive landscape for components like this is that you get to vote with your feet. There are many other devices available to you. The idea we had was 'our idea' - we asked them whether it was possible - they gave us a method for implementing it This isn't a case of them g...
by gsh
Wed Sep 26, 2018 10:54 am
Forum: Compute Module
Topic: LAN9514
Replies: 23
Views: 809

Re: LAN9514

No, the undocumented features are actually test modes of the device. It is completely normal not to document test modes. We just came up with an idea of how to use one of their test modes.
by gsh
Wed Sep 26, 2018 9:57 am
Forum: Compute Module
Topic: LAN9514
Replies: 23
Views: 809

Re: LAN9514

The reason we have this different setup is due to undocumented changes to reduce power consumption of the 9514 device. I'm sorry but we can't release the documentation to you on this. I would suggest you just wire it up like the app note and ignore the way the Raspberry Pi is wired.

Gordon
by gsh
Mon Sep 24, 2018 2:48 pm
Forum: Compute Module
Topic: CM3 and CM1 SDX_VREF question
Replies: 4
Views: 148

Re: CM3 and CM1 SDX_VREF question

No you need to connect pins 4 and 6 of your compute module connector to 3.3v that is not the same as GPIO4 and GPIO6 (pins 15 and 21 respectively)
by gsh
Mon Sep 24, 2018 12:46 pm
Forum: Compute Module
Topic: Carrier Board RPI CM3 USB_OTGID help?
Replies: 6
Views: 250

Re: Carrier Board RPI CM3 USB_OTGID help?

You do not need a pullup on the OTG_ID line, the pin on the 2835/6/7 has one integrated. Just wire the USB_OTGID pin to pin 4 on the uUSB connector.

You will need a 100k pullup to 1v8 on the HDMI_HPD_N_1V8 line
by gsh
Mon Sep 24, 2018 12:39 pm
Forum: Compute Module
Topic: CM3 and CM1 SDX_VREF question
Replies: 4
Views: 148

Re: CM3 and CM1 SDX_VREF question

There is a jumper on CM3 lite to connect this supply to the device, so you don't require an external switch. You should follow the CMIO3 PCB schematics in this respect

Gordon
by gsh
Mon Sep 24, 2018 8:39 am
Forum: Compute Module
Topic: Carrier Board RPI CM3 USB_OTGID help?
Replies: 6
Views: 250

Re: Carrier Board RPI CM3 USB_OTGID help?

I would suggest you check the CMIO schematic for the pullup connection and value.
by gsh
Fri Sep 21, 2018 2:35 pm
Forum: Compute Module
Topic: Carrier Board RPI CM3 USB_OTGID help?
Replies: 6
Views: 250

Re: Carrier Board RPI CM3 USB_OTGID help?

If you're happy with software solution then you can ignore the OTG_ID pin completely and just add dr_mode=peripheral to the dtoverlay line dtoverlay=dwc2,dr_mode=peripheral Otherwise if you want to be able to use the special host cable in the uUSB plug so you can use OTG to switch between host and d...
by gsh
Tue Sep 11, 2018 3:22 pm
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 709

Re: scriptexecutor problem

If you had a 1V8 pullup then it wouldn't be detecting any HDMI, and therefore, it wouldn't try reading EDID...

Try adding hdmi_ignore_edid=1 to config.txt that should stop it from reading the EDID

Gordon
by gsh
Tue Sep 11, 2018 10:32 am
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 709

Re: scriptexecutor problem

Do you have the same response on a CMIO3 board?
by gsh
Tue Sep 11, 2018 9:06 am
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 709

Re: scriptexecutor problem

Do you have a pullup to 1v8 on HDMI_HPD_N_1V8
by gsh
Mon Sep 10, 2018 1:53 pm
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 709

Re: scriptexecutor problem

Just rebuild it and use the latest firmware
by gsh
Sun Sep 09, 2018 6:20 pm
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 709

Re: scriptexecutor problem

You could try enabling the UART output on bootcode.bin using strings bootcode.bin | grep BOOT_UART=0 Should give you BOOT_UART=0 by default on a clean recent bootcode.bin (if I've got this wrong it may be UART_BOOT instead), then do: sed -i -e "s/BOOT_UART=0/BOOT_UART=1/" bootcode.bin This should en...
by gsh
Wed Sep 05, 2018 2:20 pm
Forum: Compute Module
Topic: Unable to flash the eMMC on a Compute Module
Replies: 3
Views: 287

Re: Unable to flash the eMMC on a Compute Module

Does rpiboot complete successfully if you run it from the command line?

Have you tried running etcher to detect the device
by gsh
Tue Aug 28, 2018 2:30 pm
Forum: Compute Module
Topic: Compute module lite not booting (LED on then off)
Replies: 32
Views: 817

Re: Compute module lite not booting (LED on then off)

I'd suggest you read through the CMIO schematics in terms of the module boot options and make sure that you're reproduced this circuit correctly, R10 is there to make sure EMMC_EN_N_1V8 can't float...

Gordon
by gsh
Tue Aug 28, 2018 10:08 am
Forum: Add-ons
Topic: POE Hat - possible boot loader issue
Replies: 7
Views: 584

Re: POE Hat - possible boot loader issue

The positive is that it does get to the splash screen which means whatever it is, it's not a problem with the hardware! Should be software fixable!

Gordon
by gsh
Thu Aug 23, 2018 8:24 am
Forum: Compute Module
Topic: Compute module lite not booting (LED on then off)
Replies: 32
Views: 817

Re: Compute module lite not booting (LED on then off)

aBUGSworstnightmare wrote:
Thu Aug 23, 2018 7:55 am
Rick123,
your LCD is connected to DPI Interface, right? Which Kind of connector is on your PCB (i.e. FFC connector)?

DPI_10 (=GPIO14) and DPI_11(=GPIO15) are the pins required for the UART. So it should be possible to debug.
Good point, you do have access to the UART...

Go to advanced search