Go to advanced search

by alessandrodn
Wed Aug 24, 2016 3:49 am
Forum: Bare metal, Assembly language
Topic: Raspberry JTAG Debug under Linux
Replies: 0
Views: 657

Raspberry JTAG Debug under Linux

Hi all, I am trying to connect to the RPi2 JTAG. I have the following setup - Raspberry Pi 2 running Raspbian 8.0 (Jessie) - OpenOCD 0.9.0 with a J-Link EDU connected to a Ubuntu system. I setup the GPIO as instructed in other posts and the JTAG connection works: I can halt/resume processors. The is...
by alessandrodn
Mon May 02, 2016 4:15 pm
Forum: Bare metal, Assembly language
Topic: Using the serial port with kernel_old=1
Replies: 4
Views: 1214

Re: Using the serial port with kernel_old=1

With kernel_old=1 all cores start at 0x0. With kernel_old=0 core 0 starts at 0x8000 and cores 1-3 are waiting in a loop continuously reading a mailbox to get their start address. IRQs are by default only directed to core 0. This could make a difference. I think this scrambled serial output problem ...
by alessandrodn
Mon May 02, 2016 1:38 pm
Forum: Bare metal, Assembly language
Topic: Using the serial port with kernel_old=1
Replies: 4
Views: 1214

Re: Using the serial port with kernel_old=1

It is likely that the 4 CPU cores of the RPi 2 are all running the same code in your program. I am a little bit confused :? I have other examples with LED, Timers and Interrupts and they all worked flawless, and behave the same with kernel_old set to either `1` or `0`. If the issue with serial is r...
by alessandrodn
Mon May 02, 2016 6:03 am
Forum: Bare metal, Assembly language
Topic: Using the serial port with kernel_old=1
Replies: 4
Views: 1214

Using the serial port with kernel_old=1

Hi Guys, I am following on trying to make my own bare metal examples on the RPi 2. I would like to boot with kernel_old=1 in order to understand all the steps to bring the system up. Programs run fine but the serial output is screwed; I tried both the PL011 and the mini UART and they both behave the...
by alessandrodn
Sat Apr 30, 2016 4:48 pm
Forum: Bare metal, Assembly language
Topic: disable_cmd_atags with Bare Metal Programs
Replies: 2
Views: 437

Re: disable_cmd_atags with Bare Metal Programs

Actually it worked, either by not loading the ATAGS or moving the kernel around.

Thanks!
by alessandrodn
Sat Apr 30, 2016 4:35 pm
Forum: Bare metal, Assembly language
Topic: disable_cmd_atags with Bare Metal Programs
Replies: 2
Views: 437

disable_cmd_atags with Bare Metal Programs

Dear all, I am experiencing something odd when trying to avoid the ARM stub loader in bare metal programs. Basically I would like to boot the ARM CPU in Secure SVC with the option `kernel_old=1` in `config.txt`. I noticed that binary file with size greater than 0x100 byte do not work! I added the op...
by alessandrodn
Sun Apr 03, 2016 8:35 am
Forum: Linux Kernel
Topic: Freeze on wfi when not using FIQ
Replies: 1
Views: 972

Re: Freeze on wfi when not using FIQ

Very interesting project.
Do you provide source code implementation?

Alessandro

Go to advanced search