Go to advanced search

by shusheer
Mon Mar 13, 2017 3:19 pm
Forum: Camera board
Topic: Converting white balance between images
Replies: 1
Views: 317

Converting white balance between images

Hello All, (but probably mostly hello to those who know the insides of the camera pipe!) I have been trying to work out the exact relationship between the AWB values that are captured with images and the processing of the image data to simulate an image taken with a different set of white balance ga...
by shusheer
Tue Mar 08, 2016 12:23 pm
Forum: Troubleshooting
Topic: RPi 3 - Very poor wifi performance
Replies: 77
Views: 105869

Re: RPi 3 - Very poor wifi performance

Just dropping a note to confirm that my Pi3 wifi issues (long ping-time, drop-outs) were fixed by adjusting power management. Doing this sudo iwconfig wlan0 power off on the Pi3 whilst pinging it from another machine on the network completely solved the problem: 64 bytes from 192.168.1.135: icmp_seq...
by shusheer
Thu Mar 03, 2016 8:28 pm
Forum: Troubleshooting
Topic: RPi 3 - Very poor wifi performance
Replies: 77
Views: 105869

Re: RPi 3 - Very poor wifi performance

Just to add my verification of the problem - as pointed out, with Pi3 connecting to wifi (channel 11, TP-Link WDR3600 router with dd-wrt running) I get ping times up to 3000ms. This makes SSH rather less responsive, but not impossible to use. wget gives me about 4MByte/sec downloads from another mac...
by shusheer
Thu Feb 18, 2016 3:44 pm
Forum: Camera board
Topic: Frame synchronisation
Replies: 82
Views: 28325

Re: Frame synchronisation

6by9 wrote: Not an accurate signal that I can think of. MMAL only sees the frames after they've been through the ISP to convert from Bayer to YUV, and there will be jitter in the timing of that. What you really want is a trigger off the frame start interrupt, but that's not exposed. Linux task sche...
by shusheer
Thu Feb 18, 2016 1:17 am
Forum: Camera board
Topic: Frame synchronisation
Replies: 82
Views: 28325

Re: Frame synchronisation

Hi All, This rather long thread seems to have died down, but I can't seem to find anyone reporting a nice way to hardware-synchronise multiple cameras for video without drift (e.g. 3D video using 2 cameras). I'm wondering if something along the following lines might work? * Have a network of Pis all...
by shusheer
Mon Jan 04, 2016 10:27 am
Forum: Camera board
Topic: NoIR images randomly pink
Replies: 7
Views: 1701

Re: NoIR images randomly pink

Hi All, Some progress to report on this. It appears that the dynamic range compression option (-drc high) triggers a recalculation of white-balance in the same way as adding a stats pass (-st or --stats) - i.e. this prevents the setting of fixed white balance gains. I have not found any documentatio...
by shusheer
Thu Dec 31, 2015 5:45 pm
Forum: Camera board
Topic: NoIR images randomly pink
Replies: 7
Views: 1701

Re: NoIR images randomly pink

Hi Gavin and Aron, Unfortunately I'm fairly sure this is NOT some "normal pink from IR sources" - the room lights are indeed tungsten, so there is absolutely loads of IR in the room as well as vis, but it is very consistent in level. No other IR emitters. Also this effect is only very occasional - p...
by shusheer
Mon Dec 28, 2015 10:06 pm
Forum: Camera board
Topic: NoIR images randomly pink
Replies: 7
Views: 1701

NoIR images randomly pink

Hi All, I am capturing images using raspistill on a NoIR camera. Every now and again images under "reasonable" (indoor) lighting seem to go pink for just one or a few frames. I assume this is some kind of issue with the AWB, so I have tried setting this to off, and also using --stats which is suppos...
by shusheer
Sat Nov 07, 2015 12:00 am
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

Ok, finally got my hands back on the compute module hardware, so I could try installing clean images. This problem has existed all the time I've had the compute modules, but seems to have become dramatically more sensitive due to whatever upgrades and s/w I have installed recently. The test code pre...
by shusheer
Mon Nov 02, 2015 10:22 pm
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

Another interesting finding - by looking through some old code from around the start of September, I found some that did a rather similar set of captures, and worked then, but fails now. That suggests some kind of update has happened to cause this issue. I therefore did an sudo rpi-update ea072e1d61...
by shusheer
Sun Nov 01, 2015 9:46 pm
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

More progress, if you could call it that. If you just copy-and-paste both the lines below into your ssh session, as a single paste job (i.e. so the line-break causes the two instructions to run immediately one after the other), then you also get the failure: raspistill -set -n -cs 0 -o /dev/shm/test...
by shusheer
Sun Nov 01, 2015 8:57 pm
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

Another possible hint - this output came when using the -set option of raspistill during a crash, but it only happened once so not sure that it is "real": mmal: mmal_vc_component_create: failed to create component 'vc.ril.image_encode' (1:ENOMEM) mmal: mmal_component_create_core: could not create co...
by shusheer
Sun Nov 01, 2015 1:20 pm
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

Not sure if it's any use at all, but here's the logfile from a Pi-V2 running the same code (but obviously only for a single camera) - it seems to have some asserts as well at about the same time (all the machines were restarted within about a minute of each other, so I think all these logs represent...
by shusheer
Sun Nov 01, 2015 1:14 pm
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

Ok, spotted something in the logfile after another camera crash on each machine, but not sure how useful it will be. On the first compute module (I have a pair of them): $ sudo vcdbg log assert 002831.474: assert( card not initialised ) failed; ../../../../../filesystem/media/sdcard/sdcard.c::sdhost...
by shusheer
Sat Oct 31, 2015 9:41 pm
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

FYI, I have added "start_debug=1" to boot/config.txt as suggested, and then triggered my master.sh script with delay 0.1 and observed failure, but "sudo vcdbg log assert" shows nothing new. It does however show one entry, which seems odd (this is always there after boot): 002831.474: assert( card no...
by shusheer
Fri Oct 30, 2015 7:58 pm
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

I think you might be onto something. One strange error code I saw whilst trying to get to the minimum script to induce failure was the following: tvservice-client: Failed to connect to TV service: -1 It only happened once, not consistently, so I thought it wasn't that bit of a hint, but a google on ...
by shusheer
Fri Oct 30, 2015 12:00 am
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Re: Raspistill causes system lock-up when used with two came

No, no 3D processing, not even using gfx (no HDMI plugged in, just SSH over ethernet via USB). I get exactly those 5 items as a result of vcgencmd cache_flush sudo vcdbg reloc Try removing the sleep $2 lines in slave.sh altogether, and perhaps running e.g. 10 raspistill commands in a row on each cam...
by shusheer
Wed Oct 28, 2015 4:13 pm
Forum: Compute Module
Topic: Raspistill causes system lock-up when used with two cameras
Replies: 12
Views: 1844

Raspistill causes system lock-up when used with two cameras

Hi All, I seem to have found a bug in raspistill (or possibly deeper in the system). It seems only to happen on a compute module with 2 cameras, and results in raspistill locking up either it's own process, or occasionally the entire system (e.g. system no longer responds to ping when USB ethernet a...

Go to advanced search