Go to advanced search

by leemoore1966
Tue May 15, 2018 11:47 am
Forum: General discussion
Topic: STICKY: TUTORIAL: Update NOOBS without Re-Installing It (When Your Raspberry Pi 3B+ Will Not Boot!)
Replies: 24
Views: 9239

Re: STICKY: TUTORIAL: Update NOOBS without Re-Installing It (When Your Raspberry Pi 3B+ Will Not Boot!)

Hi Mike Many thanks for posting this, a great tutorial I was very worried about having to port to the 3B+ due to the extensive changes I have made to a Jessie system! A few minor tweaks to my own environment in addition to your flow described - and I now have this working successfully on a Pi3B+ man...
by leemoore1966
Mon Mar 19, 2018 10:34 am
Forum: Troubleshooting
Topic: New P3 B Plus problem
Replies: 13
Views: 935

Re: New P3 B Plus problem

ks234 wrote:
Sun Mar 18, 2018 1:44 pm
Many thanks to everyone. Now have new B plus up and running, and learned something along the way!
Hi ks234
can you describe which of the many methods above worked for you when migrating from Pi3B to Pi3B+ ?

Thx
Lee
by leemoore1966
Fri Mar 09, 2018 5:42 pm
Forum: Troubleshooting
Topic: RPi3 WiFi bug in UDP transmission
Replies: 4
Views: 296

Re: RPi3 WiFi bug in UDP transmission

I've run UDP packets 15 times per second for hours at a time with no fail between a RPi3 and an RPi zero. I'm using Python and C. Hi Tim, Thanks for the reply I do not get a 'fail' in the sense that the data is lost, the data arrives, but it is stalled for 3-5 seconds at 120 second intervals Are yo...
by leemoore1966
Fri Mar 09, 2018 5:03 pm
Forum: Troubleshooting
Topic: RPi3 WiFi bug in UDP transmission
Replies: 4
Views: 296

Re: RPi3 WiFi bug in UDP transmission

Hi All An update on this - would appreciate any feedback and help possible My requirement is to send out one small 4kb UDP packet every second. The receiver would like to get a packet once a second but MUST get a packet within 5 seconds, this is a hard time requirement If I only send a UDP packet on...
by leemoore1966
Tue Mar 06, 2018 1:17 pm
Forum: General discussion
Topic: Wireless firmware testers wanted
Replies: 81
Views: 12047

Re: Wireless firmware testers wanted

The driver knows which firmware to load - that folder contains loads for different sorts of wireless adaptor. Things have moved on a bit - we did release the latest firmware but have had some regressions so have rolled it back (we think we now know the problem - currently testing a fix). Might be w...
by leemoore1966
Tue Mar 06, 2018 10:53 am
Forum: General discussion
Topic: Wireless firmware testers wanted
Replies: 81
Views: 12047

Re: Wireless firmware testers wanted

Sure, something along these lines (i have simply typed these in here, not C&P, so may be typo's) unzip the file to produce the brcmfmac43430-sdio.bin file unzip brcmfmac43430-sdio.zip Backup old file sudo cp /lib/firmware/brcm/brcmfmac43430-sdio.bin /lib/firmware/brcm/brcmfmac43430-sdio.bin.old Cop...
by leemoore1966
Tue Mar 06, 2018 10:07 am
Forum: General discussion
Topic: Wireless firmware testers wanted
Replies: 81
Views: 12047

Re: Wireless firmware testers wanted

Sure, something along these lines (i have simply typed these in here, not C&P, so may be typo's) unzip the file to produce the brcmfmac43430-sdio.bin file ... Hi James, Apologies for the long time getting back to this. Finally got around to trying the patch (even though I could see it had been pull...
by leemoore1966
Wed Jan 24, 2018 3:08 pm
Forum: General discussion
Topic: Wireless firmware testers wanted
Replies: 81
Views: 12047

Re: Wireless firmware testers wanted

Hi
I am an interested party who logged issues on github
Sorry if its a dumb question, can you provide a instructions for an installation procedure

Thx
Lee
by leemoore1966
Sun Dec 17, 2017 5:15 pm
Forum: Troubleshooting
Topic: RPi3 WiFi bug in UDP transmission
Replies: 4
Views: 296

Re: RPi3 WiFi bug in UDP transmission

Having downloaded the Linux driver code and searching for a suspicious 120, I found the following in cfg80211.c #define BRCMF_SCAN_PASSIVE_TIME 120 ... err = brcmf_fil_cmd_int_set(ifp, BRCMF_C_SET_SCAN_PASSIVE_TIME, BRCMF_SCAN_PASSIVE_TIME); Hmm, could this be causing my issue ? I wonder if there is...
by leemoore1966
Sun Dec 17, 2017 3:27 pm
Forum: Troubleshooting
Topic: RPi3 WiFi bug in UDP transmission
Replies: 4
Views: 296

RPi3 WiFi bug in UDP transmission

Hi All I am pretty sure I have discovered a bug in the UDP transmission using the internal WiFi, interested in others thoughts. I had noticed that when streaming UDP Unicast from the RPi3 I would get quite high losses, upon further investigation it seems that at a periodic interval of 120 seconds th...
by leemoore1966
Sat Dec 16, 2017 4:26 pm
Forum: Troubleshooting
Topic: Stall every 120 seconds on Wlan0 using UDP
Replies: 0
Views: 88

Stall every 120 seconds on Wlan0 using UDP

Hi All, I have been experiencing strange behavior on RPi3 using built in Wlan0 using UDP in my application. I seem to get a stall every 120 seconds If I run the test outlined earlier in the thread with the iperf udp server running on ubuntu linux PC and iperf udp client running on RPi3 - I see a fai...
by leemoore1966
Sat Dec 16, 2017 2:20 pm
Forum: General discussion
Topic: UDP Unicast Tx Buffer not flushing
Replies: 3
Views: 365

Re: UDP Unicast Tx Buffer not flushing

Are you using the Pi 3 on-board WiFi?
Yes that is correct.
I am not totally convinced it is connected to the on-board WiFi, because if I recall correctly, I had the same behavior with an RT5370

Although I will try a test going through eth0 to see if it is reproducible on that interface

Thx
Lee
by leemoore1966
Sat Dec 16, 2017 12:55 pm
Forum: General discussion
Topic: UDP Unicast Tx Buffer not flushing
Replies: 3
Views: 365

Re: UDP Unicast Tx Buffer not flushing

A further update on this Something is happening periodically which I can observe easily. it would appear that at every 120 second interval - the RPI stops sending UDP packets for about 3-4 seconds I have a test setup, whereby I am sending UDP messages from RPi and listening on a WiFi connected ubunt...
by leemoore1966
Fri Dec 15, 2017 6:12 pm
Forum: General discussion
Topic: UDP Unicast Tx Buffer not flushing
Replies: 3
Views: 365

UDP Unicast Tx Buffer not flushing

Hi All I am seeing some very strange behavior, and very difficult to reproduce. on an RPi3 I have a UDP client which is sending data to a number of servers over wlan0 The RPi3 is configured as a hotspot running hostapd, with 5 clients. UDP data is sent from the RPi3 using unicast, the bandwidth is q...
by leemoore1966
Sat Nov 04, 2017 5:19 pm
Forum: Advanced users
Topic: Pulseaudio in Read-Only Environment
Replies: 4
Views: 743

Re: Pulseaudio in Read-Only Environment

Hi

I have the same issue, did you ever get to a solution?

Thx
Lee
by leemoore1966
Tue Jan 31, 2017 10:02 pm
Forum: General discussion
Topic: Hostapd affecting eth0
Replies: 4
Views: 623

Re: Hostapd affecting eth0

Thanks for the reply

Interested to know, do you think this could affect the slowdown poor performance and disconects of ssh over eth0 when hostapd is up and running ?

Thx
Lee
by leemoore1966
Sat Jan 28, 2017 8:56 am
Forum: General discussion
Topic: Hostapd affecting eth0
Replies: 4
Views: 623

Hostapd affecting eth0

Hi All Would really appreciate some advice here. I am running raspbian jessie on rpi2. Configured as a wireless hotspot on wlan0, using a combination of dnsmasq, dhcpcd and hostapd Starting Reference here https://frillip.com/using-your-raspberry-pi-3-as-a-wifi-access-point-with-hostapd/ I have notic...
by leemoore1966
Mon Jan 23, 2017 10:56 pm
Forum: Networking and servers
Topic: Pi2 gets static IP but also DHCP IP is assigned
Replies: 26
Views: 56094

Re: Pi2 gets static IP but also DHCP IP is assigned

Hi all I would really appreciate some help here, I have been having a horrenous time trying to rationalise all the opinions here, firstly let me describe my requirements I am using debian jessie (converted from wheezy) I run a number of services which I want to be accessed from Static ip on eth0 Acc...
by leemoore1966
Fri Dec 09, 2016 5:36 pm
Forum: Troubleshooting
Topic: WIFI Interface Always Busy or Down
Replies: 6
Views: 944

Re: WIFI Interface Always Busy or Down

I have the very same issue described in this thread. My power supply is fine and not the cause. I have switched from a Pi2B to a Pi2B+(v1.2) which has caused no end of trouble, I can no longer get a reliable WiFi Access point using the RT5370 does anybody have a solution to getting a Wireless SoftAP...
by leemoore1966
Thu Sep 24, 2015 11:25 am
Forum: General discussion
Topic: RT5370 / hostapd
Replies: 0
Views: 477

RT5370 / hostapd

Hi All, Any advice greatly appreciated, I have successfully configured the Pi B+ as an Access Point using raspbian, hostapd and an rt5370 I have a number of users who are trying to replicate my setup, and a number are reporting issues with the Access Point starting up. The symptom is that when hosta...
by leemoore1966
Wed Sep 02, 2015 8:38 am
Forum: General discussion
Topic: UDP broadcast appears blocked
Replies: 6
Views: 3475

Re: UDP broadcast appears blocked

Hi marked Firstly thanks for your help so far, I have made some progress, but still have issues. I have tried to reduce the problem down, and this is what I have found. Something about that code looks strange to me, but I can't think what it is of the top of my head - I certainly can't remember whet...
by leemoore1966
Tue Sep 01, 2015 9:42 am
Forum: General discussion
Topic: UDP broadcast appears blocked
Replies: 6
Views: 3475

Re: UDP broadcast appears blocked

Hi I could be showing my ignorance here :-/ Was the UDP client trying to resolve the address of where the packets were coming from? The UDP clielt is listening on INADDR_ANY, so I _assumed_ that I do not have to provide any addressing info ? As I mentioned in the initial thread if I connect the ipho...
by leemoore1966
Tue Sep 01, 2015 9:03 am
Forum: General discussion
Topic: UDP broadcast appears blocked
Replies: 6
Views: 3475

Re: UDP broadcast appears blocked

The UDP packets were on a broadcast. I have an update here, I cannot believe this is related, but ... I added into the setup for udhcpd option dns192.168.1.1 and now I am receiving the UDP packets. I find this unbelievable to be honest, I think I will go back and check that removing this, causes the...
by leemoore1966
Sat Aug 29, 2015 2:49 pm
Forum: General discussion
Topic: UDP broadcast appears blocked
Replies: 6
Views: 3475

UDP broadcast appears blocked

Hi All I seem to be seeing strange behavior, any comments welcome. I have my RPi setup as a Wireless HotSpot. I have a remote device connected to the HotSpot (iPhone) The iPhone is running a UDP broadcast server (NMEA Gps) I am running a UDP client on the RPi, but I cannot receive data from the UDP ...

Go to advanced search