Go to advanced search

by polioman
Fri Feb 24, 2017 3:13 pm
Forum: Troubleshooting
Topic: 3G/4G LTE USB modem
Replies: 6
Views: 9244

Re: 3G/4G LTE USB modem

1rst link in google is good site : http://www.daveconroy.com/verified-rasp ... om-sprint/

You may have a problem with you wvdial conf (check APN and dial number).
by polioman
Fri Feb 24, 2017 8:54 am
Forum: Advanced users
Topic: Raspberry Pi B+ turn usb power off
Replies: 46
Views: 86716

Re: Raspberry Pi B+ turn usb power off

I see my modem in the list with a different Devices number. How can I fix it? You can not change this number by yourself, the system does it automatically (as far as I know). Why do you need this USB ID, or what do you want to do with it? If you've got others USB peripherals connected, they might s...
by polioman
Fri Jan 13, 2017 9:10 am
Forum: Advanced users
Topic: Raspberry Pi B+ turn usb power off
Replies: 46
Views: 86716

Re: Raspberry Pi B+ turn usb power off

Hi,

Did you follow the instructions from here https://github.com/codazoda/hub-ctrl.c?

It seems you do not have it installed or you're in the right folder.
by polioman
Fri Feb 12, 2016 8:46 am
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

Thanks for your feedback.

I misunderstood what you were doing, I though you were using your wifi dongle as an AP, that's not the case :)

I have to read more carefully what people write :lol:
by polioman
Thu Feb 11, 2016 3:44 pm
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

Interesting. Can you explain how you did to make your setup working?

I'm curious and if it can help me solve 1 or 2 of my issues I would be very happy :D
by polioman
Thu Feb 11, 2016 8:55 am
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

Looks like I'm using wpa_supplicant, not hostapd wpa_supplicant is a software which provide WEP, WPA and WP2 support, is goes alongside of hostapd. Can you show me result of this command? ps -ef | grep -v "\[" I've got this : UID PID PPID C STIME TTY TIME CMD root 1 0 0 Feb10 ? 00:00:09 /sbin/init ...
by polioman
Wed Feb 10, 2016 2:40 pm
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

That would appear to indicate you used the wrong driver version for the version of OS you were using. Since it is a copy of a working OS, I don't undrestood why it didn't work. It's now connected via the 5ghz frequency Wi-Fi I'm broadcasting and transferring accordingly :) You said you're connected...
by polioman
Mon Feb 08, 2016 1:59 pm
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

I don't know how much power this dongle require but you could try to add in /boot/config.txt max_usb_current=1 . I had same issue on another raspberry, don't know why since it is working with a clone of my first SD card. If it can help, here is the error I got in dmesg : disagrees about version of s...
by polioman
Mon Feb 01, 2016 3:58 pm
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

It sees that hostapd from Realtke does not support 802.11ac mode, at best 802.11n (it's an old version). I was able to make it work with hostapd from repo and activate 802.11ac conf, my phone tells me my bandwidth is 54Mbits/s though :/ ### hostapd configuration file ctrl_interface=/var/run/hostapd ...
by polioman
Fri Jan 29, 2016 9:16 am
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

Alright, I don't want to change my SD card set up then. Ok, no problem, I didn't understand your previous post in that way. Anyway, so why don't you download the driver and test it yourself? Presumably you will need the hostapd that is included with Realtek drivers. Yes, I'll do that today since I ...
by polioman
Thu Jan 28, 2016 11:50 am
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

MrEngman wrote: I have not used hostapd as I do not want to change my kernel set up.
Why should you change your kernel set up? Unless you compiled it for a precise purpose, I don't understand.
by polioman
Thu Jan 28, 2016 8:31 am
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

You set on of them in AP in 80211ac?

Can you post your hostapd.conf file?
Did you use hostapd from repo or you compiled it from source or is it one from Realtek?

If you were able to do that, you could save my day (and more) :)
by polioman
Wed Jan 27, 2016 4:12 pm
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Re: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

Thank you MrEngman for your work. I'm writing a new µSD card in order to have a clean OS. I forgot to mention that I use a RPi 2, I edit my first post. I've got few questions : Do you have a wifi dongle based on RTL8821au? If yes, could test it with hostapd with your driver? Where did you find this ...
by polioman
Wed Jan 27, 2016 1:36 pm
Forum: Networking and servers
Topic: Edimax EW7811UAC (RTL8812) - 802.11ac AP mode
Replies: 39
Views: 16544

Edimax EW7811UAC (RTL8812) - 802.11ac AP mode

Hi, I have to use an Edimax EW-7811AUC wifi dongle to work as an AP. It uses a Realtek chip : RTL8812au. I under Raspbian Jessie on a Raspberry Pi 2. I was able to make it work in b/g mode on 2,4GHz and a mode on 5GHz bands. I need it to work in 8022.11ac mode and I can't find how. I was using Raspb...
by polioman
Wed Sep 09, 2015 2:29 pm
Forum: Advanced users
Topic: Raspberry Pi B+ turn usb power off
Replies: 46
Views: 86716

Re: Raspberry Pi B+ turn usb power off

I tried hub-crtl.c with some success on a Pi 2 : Reset ETH 0, and I lost my connection (have to reboot) sudo ./hub-ctrl -h 0 -P 1 -p 0 ; sleep 3; sudo ./hub-ctrl -h 0 -P 1 -p 1 Reset all USB and ETH sudo ./hub-ctrl -h 0 -P 2 -p 0 ; sleep 3; sudo ./hub-ctrl -h 0 -P 2 -p 1 Reset USB 4 sudo ./hub-ctrl ...
by polioman
Mon Sep 07, 2015 12:29 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1399
Views: 1293321

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.1.xx+

mse_68870 wrote:Hello,
I am using the WN725 as AP without issues, thanks to this thread's contributors.
Did you made a special hostapd config file?

I want to try it out.
by polioman
Mon Sep 07, 2015 10:49 am
Forum: Troubleshooting
Topic: D-Link DWA127 revB (MT7601u) AP mode
Replies: 0
Views: 1296

D-Link DWA127 revB (MT7601u) AP mode

Hi all, I try to use a DWA127 in AP mode on my Pi using hostapd but it seems not to be supported (as seen here https://wireless.wiki.kernel.org/en/users/drivers/rt2800usb) I tried to compile hostapd on he Pi, buth it doesn't work (don't have error log right now). Here is my config file [email protected] ~/s...
by polioman
Wed Sep 02, 2015 12:47 pm
Forum: Troubleshooting
Topic: Slow speed connection with 3g modem.
Replies: 1
Views: 736

Re: Slow speed connection with 3g modem.

You can change the Phone et Baud lines.
From this :

Code: Select all

Phone = *99#

Code: Select all

Baud = 460800
To this :

Code: Select all

Phone = *99*4#

Code: Select all

Baud = 115200
It may work better.
by polioman
Wed Sep 02, 2015 12:41 pm
Forum: General discussion
Topic: wvdial, USB dongle, and unexpected unplugging...
Replies: 1
Views: 404

Re: wvdial, USB dongle, and unexpected unplugging...

You can try adding a simple in crontab which test if network is responding and if it's not the case is does a

Code: Select all

service networking restart
.

If the Pi is freezing, the only possibility could be to reboot it manually though.
by polioman
Wed Sep 02, 2015 12:37 pm
Forum: Beginners
Topic: 3G blues
Replies: 1
Views: 491

Re: 3G blues

I've got few Huawei 3G/4G/LTE USB modem that work on the Pi. On a new SD card, install usb_modeswitch, wvdial and ppp. After a reboot, configure wvdial. sudo wvdialconf It will make a conf sample for wvdial with something like that inside /etc/wvdial.conf [Dialer Defaults] Phone = Username = Passwor...
by polioman
Wed Sep 02, 2015 10:09 am
Forum: Troubleshooting
Topic: 3G/4G LTE USB modem
Replies: 6
Views: 9244

Re: 3G/4G LTE USB modem

I've solved my ping issue by adding a default route on ppp0 64 bytes from 8.8.8.8: icmp_req=2 ttl=53 time=33.1 ms 64 bytes from 8.8.8.8: icmp_req=3 ttl=53 time=44.9 ms 64 bytes from 8.8.8.8: icmp_req=4 ttl=53 time=44.4 ms 64 bytes from 8.8.8.8: icmp_req=5 ttl=53 time=41.4 ms 64 bytes from 8.8.8.8: i...
by polioman
Tue Sep 01, 2015 8:49 am
Forum: Troubleshooting
Topic: Edimax EW-7711UAN
Replies: 23
Views: 8270

Re: Edimax EW-7711UAN

Thank you very much! It's working now. I've got to install driver for DWA-127 rev A now. Easier (I hope) since they are available on D-Link's website.

You saved my day!
by polioman
Mon Aug 31, 2015 3:23 pm
Forum: Troubleshooting
Topic: Edimax EW-7711UAN
Replies: 23
Views: 8270

Re: Edimax EW-7711UAN

I've got the same problem with a D-Link DWA-127 revB which use a Mediatek MT7601u chip : [email protected] ~ $ lsusb Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. B...
by polioman
Fri Aug 28, 2015 2:52 pm
Forum: Troubleshooting
Topic: 3G/4G LTE USB modem
Replies: 6
Views: 9244

Re: 3G/4G LTE USB modem

It works with this little trick. Now I've got to check the available bandwidth on my system. I noticed something weird. When I ping an address I got one "normal" (from 50 to 90 ms) and one high (110-130 ms) : 64 bytes from 8.8.8.8: icmp_req=322 ttl=57 time=127 ms 64 bytes from 8.8.8.8: icmp_req=323 ...
by polioman
Wed Aug 26, 2015 7:32 am
Forum: Troubleshooting
Topic: 3G/4G LTE USB modem
Replies: 6
Views: 9244

Re: 3G/4G LTE USB modem

I read some things about that indeed but I didn't think it would act like this. I'll try that as soon as I can.

Thanks

Go to advanced search