Go to advanced search

by Ettore_M
Tue Feb 23, 2016 11:18 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: SPI devices (LCD, nRF24L01) NOT working together
Replies: 3
Views: 1356

Re: SPI devices (LCD, nRF24L01) NOT working together

adun wrote:Is the display a real SPI device or are you just bitbangig the GPIOs connected to it.
That would explain why the sensor fails to work.
I don''t get exactly what you mean, but the display uses SPI interface and it's connected to Raspberry Pi's SPI pins.
by Ettore_M
Tue Feb 23, 2016 9:16 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: SPI devices (LCD, nRF24L01) NOT working together
Replies: 3
Views: 1356

Re: SPI devices (LCD, nRF24L01) NOT working together

*bump*

Anyone who knows something about? Has anything like this happened to anyone who run two SPI devices simultaneously?

Thanks again

EDIT: SPI devices are connected like this (in parallel and with different CEs).
by Ettore_M
Sun Feb 21, 2016 10:51 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: SPI devices (LCD, nRF24L01) NOT working together
Replies: 3
Views: 1356

SPI devices (LCD, nRF24L01) NOT working together

Hey guys! I've been lurking around here for a lot of time, and now that I want to build something, I need your help. I'm building a wireless system for monitoring temperature and humidity. I use a RPi as a base receiving messages with a nRF24L01 and two Arduino's sending wirelessly the measurements ...
by Ettore_M
Sun Dec 08, 2013 6:07 pm
Forum: Python
Topic: Python - Tap Tempo GPIO project
Replies: 6
Views: 2745

Re: Python - Tap Tempo GPIO project

Oh dude! HUGE thanks! Great idea and you got my brain going! :) Your idea didn't exactly work on its own, but I understood what's happening and what code is needed to work! ;) So, this is the result! And it's working absolutely great! :D #!/usr/bin/env python import RPi.GPIO as GPIO, time from time ...
by Ettore_M
Sun Dec 08, 2013 5:37 pm
Forum: Python
Topic: Python - Tap Tempo GPIO project
Replies: 6
Views: 2745

Re: Python - Tap Tempo GPIO project

Now, with Joan's change, it does not read the input HIGH and it displays just: "1 seconds", when I run it. But when I press the button, it quickly displays the change of the N variable to "1" and immediately to "0". It seems that it goes really quickly from the "1&...
by Ettore_M
Sun Dec 08, 2013 5:14 pm
Forum: Python
Topic: Python - Tap Tempo GPIO project
Replies: 6
Views: 2745

Re: Python - Tap Tempo GPIO project

Thanks for the replies, guys! Really appreciated!

So, my setup is this. Pretty simple!

Image

Joan, I'll try the AND operator and get back to you guys! :)

Hector
by Ettore_M
Sun Dec 08, 2013 12:23 pm
Forum: Python
Topic: Python - Tap Tempo GPIO project
Replies: 6
Views: 2745

Python - Tap Tempo GPIO project

Hi guys! This is the first time I'm starting a new topic on Python, so bare with me. ;) So, I'm working on a tap tempo project with Python and RPi.GPIO. The concept is to tap a tempo on a Normally Open SPST switch, the Pi is reading the input (two pushes on the button) and the time in which the tap ...
by Ettore_M
Tue Nov 26, 2013 4:26 pm
Forum: Raspberry Pi OS
Topic: LXDE no taskbar with raspbain
Replies: 14
Views: 27350

Re: LXDE no taskbar with raspbain

Just a follow up. This is definitely because I do my set ups headless. If I do the set up and config with a monitor attached, everything works fine. Just removing the directory ~/.config/lxpanel/ does not fix the problem until you actually connect it to a monitor, doing it headless and then using X...
by Ettore_M
Mon Jul 15, 2013 9:32 am
Forum: Troubleshooting
Topic: Getting SSH tunnelled / secured VNC to work
Replies: 13
Views: 6033

Re: Getting SSH tunnelled / secured VNC to work

Hi, Same problem here. I found a solution by replacing depth 24 by depth 16... Got icons, desktop taskbar and normal right click behaviour. Hope this will help. Denis Hi guys! I have kind of the same problem. The icons are displayed, but I can't get the taskbar to be shown. I'm getting frustrated. ...
by Ettore_M
Sun Jul 14, 2013 4:46 pm
Forum: Beginners
Topic: VNC window has no taskbar
Replies: 4
Views: 3343

Re: VNC window has no taskbar

Hi there! I have the same problem.. Even if I scroll down or change geometry, I can't find the taskbar anywhere..
Could anyone please help? I'm using Meltwater's Guide to Direct Connections with PuTTY, tightvncserver on RPi and RealVNC on my laptop..
Thank you!

Hector
by Ettore_M
Mon Jan 14, 2013 5:23 pm
Forum: Troubleshooting
Topic: unregister_netdevice Message. Pi does not respond
Replies: 4
Views: 1094

Re: unregister_netdevice Message. Pi does not respond

Happened again some times. I had to do a hard reset several times. If I'm not connected to the internet and USB WiFi is not connected to the Pi, it doesn't happen. Today (after a few days with this problem), it booted ok, I had the chance to "sudo apt-get update/upgrade" and now it's ok ag...
by Ettore_M
Fri Jan 04, 2013 8:03 pm
Forum: Troubleshooting
Topic: unregister_netdevice Message. Pi does not respond
Replies: 4
Views: 1094

Re: unregister_netdevice Message. Pi does not respond

Until now, the problem seems to be gone with just a simple "sudo apt-get update/upgrade". We 'll see how it goes...
by Ettore_M
Tue Jan 01, 2013 12:16 pm
Forum: Troubleshooting
Topic: unregister_netdevice Message. Pi does not respond
Replies: 4
Views: 1094

unregister_netdevice Message. Pi does not respond

Hey guys, I ran into a problem which isn't that much discussed in the forum. Or maybe I didn't find it in the search. So here it is anyway: after some time connected on the net via WiFi on the Pi, something happens, the WiFi disconnects, the CPU is maxxed out and the Pi doesn't respond. The only thi...
by Ettore_M
Sat Dec 29, 2012 10:19 am
Forum: Beginners
Topic: youtube playing????
Replies: 5
Views: 1092

Re: youtube playing????

XBMC is a media centre solution. But you could have a SD card with the XBMC installation and another with your preferred OS, and change between these two.

Hector
by Ettore_M
Sat Dec 29, 2012 10:03 am
Forum: Beginners
Topic: 2012-12-16-wheezy-raspbian
Replies: 10
Views: 1741

Re: 2012-12-16-wheezy-raspbian

rpi-update will get you a development grade kernel and some userland code. Most of it is intended to fix hardware or other issues that do not affect probably the vast majority of users. So if your system is working well for you, you really do not need the development quality stuff and can make bett...
by Ettore_M
Fri Dec 28, 2012 10:59 pm
Forum: Beginners
Topic: 2012-12-16-wheezy-raspbian
Replies: 10
Views: 1741

Re: 2012-12-16-wheezy-raspbian

rpi-update isn't standard since most people don't need it. You can install it as here : https://github.com/Hexxeh/rpi-update/ Easy enough to find using google....... Yeah, I know. Sorry for that. But can I ask something? Why don't people use it? I thought that most people used it for updating (at l...
by Ettore_M
Fri Dec 28, 2012 5:13 pm
Forum: Beginners
Topic: 2012-12-16-wheezy-raspbian
Replies: 10
Views: 1741

Re: 2012-12-16-wheezy-raspbian

ferdi wrote: sudo: rpi-update: command not found
which it is correct instruction ?
Yes, I get the same message when I insert "sudo rpi-update". Isn't it preinstalled in the latest Raspbian edition?

Hector
by Ettore_M
Tue Sep 11, 2012 8:51 pm
Forum: General discussion
Topic: The KindleBerry Pi!
Replies: 20
Views: 7209

Re: The KindleBerry Pi!

Amazing hack, damaru! Really excited about this one! :D
Do you know if this connection is possible with an android device? I have a 10 inch tablet that I would really want to try out...
by Ettore_M
Tue Sep 11, 2012 3:38 pm
Forum: Troubleshooting
Topic: Bricked my RPi running rpi-update
Replies: 23
Views: 7084

Re: Bricked my RPi running rpi-update

I loaded the latest image on the SD card and tried again for an rpi-update. This time it worked. I guess it was because I ran "sudo apt-get update" and "sudo apt-get upgrade" before the rest of the commands (as seen on pixelami). Now I'll know how to do it properly. To everyone w...
by Ettore_M
Mon Sep 10, 2012 10:26 am
Forum: Troubleshooting
Topic: Bricked my RPi running rpi-update
Replies: 23
Views: 7084

Re: Bricked my RPi running rpi-update

RaTTuS wrote:just replaceing the files in the dos partition should be good enough
Thanks for the answer! That was quick..
But how do I do that? Sorry if it sounds silly...
by Ettore_M
Mon Sep 10, 2012 10:16 am
Forum: Troubleshooting
Topic: Bricked my RPi running rpi-update
Replies: 23
Views: 7084

Re: Bricked my RPi running rpi-update

I have had to re-image the 2012-08-16-wheezy-raspbian.img several times, and have had the bricking experience on 2 or 3 occasions. I am not sure why it occurred (I just figured that I had done something wrong). Read this: http://blog.pixelami.com/2012/06/raspberry-pi-firmware-update-for-debian-sque...
by Ettore_M
Sun Jul 08, 2012 7:46 am
Forum: General discussion
Topic: Power supply for Raspberry Pi from USB hub?
Replies: 4
Views: 2990

Re: Power supply for Raspberry Pi from USB hub?

Thanks a lot for the answer, greypower! BUT the power supply gives 5.37 volts, which is slightly above tolerance for the Pi - however no problems yet !! Maybe this "5.37 volts" problem could be solved with the construction of a 5V regulator (7805, etc.) from the power supply to the hub. Or...
by Ettore_M
Sat Jul 07, 2012 9:27 pm
Forum: General discussion
Topic: Just ordered my 2nd RPi
Replies: 16
Views: 3518

Re: Just ordered my 2nd RPi

Heres the link to the one i have: http://www.ebay.co.uk/itm/NEW-RPi-Technicase-Case-For-Raspberry-Pi-NEW-/280912910871?pt=UK_Computing_DesktopComponents_RL&hash=item4167b6da17#ht_745wt_1063 There's plenty of cool ones on eBay but this is one of the cheapest and most practical 8-) It's indeed on...
by Ettore_M
Sat Jul 07, 2012 9:24 pm
Forum: General discussion
Topic: Power supply for Raspberry Pi from USB hub?
Replies: 4
Views: 2990

Power supply for Raspberry Pi from USB hub?

So, as I'm waiting for my R-Pi (It'll be dispatched "the week commencing 09/07/2012"! :D ), I'm stocking with the things that are needed for my R-Pi to get started with it. Keybooard, check. Mouse, check. SD card, check. Analog TV cable, check. But I don't have a USB power supply. "Re...
by Ettore_M
Mon Jul 02, 2012 2:18 pm
Forum: General discussion
Topic: Got Mine :)
Replies: 2
Views: 712

Re: Got Mine :)

Good for you! It's been a long time.. ;) Mine will be dispatched next Monday, and I hope it comes here (Greece) in one piece. I'm waiting for it from late March when I registered interest for the first time. So now, all I have to do is waiting.. :D

Hector

Go to advanced search