Go to advanced search

by greg123
Wed Aug 10, 2016 7:11 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

So I ran these commands CC=afl-clang-fast CXX=afl-clang-fast++ ./configure && make AFL_USE_ASAN=1 AFL_HARDEN=1 CC=afl-clang-fast CXX=afl-clang-fast++ ./configure --with-bzlib=no --with-djvu=no --with-dps=no --with-fftw=no --with-fpx=no --with-fontconfig=no --with-freetype=no --with-gvc=no --with-jbi...
by greg123
Wed Aug 10, 2016 6:21 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

Do I need to use llvm_mode? Can I just use regular afl?
by greg123
Wed Aug 10, 2016 4:58 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

I used sudo and it worked! Sorry I will try to break the habit. Now I ran the command cd llvm_mode and then ran sudo make -j4 but I got this error. sudo make -j4 [*] Checking for working 'llvm-config'... [*] Checking for working 'clang'... [*] Checking for '../afl-showmap'... [+] All set and ready t...
by greg123
Wed Aug 10, 2016 4:16 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

I ran the command make -j4 but it gave me this error. make -j4 [*] Checking for the ability to compile x86 code... ld: can't open output file for writing: .test, errno=13 for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation) Oops, looks like your com...
by greg123
Wed Aug 10, 2016 3:06 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

I ran the command make -j4 but it gave me this error. make -j4 [*] Checking for the ability to compile x86 code... ld: can't open output file for writing: .test, errno=13 for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation) Oops, looks like your com...
by greg123
Sun Aug 07, 2016 11:53 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

Do you build afl with sudo ./configure and then sudo make and then sudo make install?
by greg123
Sun Aug 07, 2016 11:07 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

Where can I get the source code for afl-clang-fast?
by greg123
Sun Aug 07, 2016 9:45 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

So how can I get afl-clang-fast to work on mac osx? I have clang installed along with afl-fuzz.
by greg123
Sun Aug 07, 2016 8:41 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

The config.txt file for Mac OSX was to long to post so here is a link to view it https://docs.google.com/document/d/1Wvd ... sp=sharing
by greg123
Sun Aug 07, 2016 8:11 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

Well I did the exact same thing on mac osx and got the exact same problem.
by greg123
Sun Aug 07, 2016 7:37 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

I got clang from the kali linux repos. That's also where I got afl-fuzz.
by greg123
Sun Aug 07, 2016 6:45 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Re: Error installing ImageMagick on Raspberry Pi 3

So how should I install the address sanitizer library with clang?
by greg123
Sun Aug 07, 2016 1:00 pm
Forum: General discussion
Topic: Error installing ImageMagick on Raspberry Pi 3
Replies: 24
Views: 2668

Error installing ImageMagick on Raspberry Pi 3

I am trying to fuzz ImageMagick on a Pi 3. CC=afl-clang-fast CXX=afl-clang-fast++ ./configure && sudo make worked fine but AFL_USE_ASAN=1 AFL_HARDEN=1 CC=afl-clang-fast CXX=afl-clang-fast++ ./configure --with-bzlib=no --with-djvu=no --with-dps=no --with-fftw=no --with-fpx=no --with-fontconfig=no --w...
by greg123
Sun Mar 13, 2016 2:26 pm
Forum: General discussion
Topic: make: *** [all] Error 2
Replies: 1
Views: 387

Re: make: *** [all] Error 2

I've been looking for an answer online but I am yet to find one. I was following the manual build section here https://developer.mozilla.org/en-US/doc ... _Sanitizer
by greg123
Sat Mar 12, 2016 7:41 pm
Forum: General discussion
Topic: make: *** [all] Error 2
Replies: 1
Views: 387

make: *** [all] Error 2

I got a error running make trying to build firefox. pi@raspberrypi:~/llvm/build $ sudo make -j6 Scanning dependencies of target LLVMHello_exports Scanning dependencies of target count Scanning dependencies of target compiler-rt-headers Scanning dependencies of target dfsan_abilist [ 0%] Scanning dep...
by greg123
Sat Mar 12, 2016 7:34 pm
Forum: General discussion
Topic: Raspberry Pi 3 no wifi
Replies: 39
Views: 62461

Raspberry Pi 3 no wifi

I just installed a fresh install of Raspbian and I clicked the wifi icon but it said that there are no wireless devices. I'm using a wifi adapter as a temporary solution. I typed ifconfig and the ifconfig -a but only eth0 and lo came up.
by greg123
Sat Mar 05, 2016 12:38 am
Forum: General discussion
Topic: Running the Asan version of Chromium
Replies: 0
Views: 214

Running the Asan version of Chromium

Will one of the pre compiled asan versions of chromium work with the Pi 2 or the Pi 3 https://commondatastorage.googleapis.com/chromium-browser-asan/index.html or will I have to compile them my self to run on the Pi. I'm not looked for amazing performance and I don't care if it's slow. I'm expecting...
by greg123
Tue Jan 26, 2016 6:14 pm
Forum: General discussion
Topic: Running Firefox ASan version running on Raspberry Pi
Replies: 0
Views: 210

Running Firefox ASan version running on Raspberry Pi

Hi I really like the Pi because of it's low power consumption and it seems like a good platform to do fuzzing. I would like to run Firefox ASan version on the Raspberry Pi 2B. I want to also run nodefuzz and wadi. Can the Raspberry Pi handle this task?
by greg123
Mon Jan 04, 2016 12:01 am
Forum: General discussion
Topic: I Changed Port number on my WP site it's now broken
Replies: 4
Views: 359

Re: I Changed Port number on my WP site it's now broken

I have looked over the links you gave me but I still am having trouble. I don't think it's mysql but something else.
by greg123
Sun Jan 03, 2016 10:53 pm
Forum: General discussion
Topic: Max environment operating temp?
Replies: 18
Views: 1444

Re: Max environment operating temp?

The Pi's cpi has a max temp of 85 C and according to the faq the pi should stay under 70 C. Yes but I would keep tabs on the Pi's temp and get notifications if it go too hot. I would add a fan and have it turn on if it gets too hot.
by greg123
Sun Jan 03, 2016 10:39 pm
Forum: General discussion
Topic: I Changed Port number on my WP site it's now broken
Replies: 4
Views: 359

Re: I Changed Port number on my WP site it's now broken

I don't know if it's mysql but I think it is. Normally my website has pictures and now it doesn't since I changed apache's port number. I can run wordpress on port 80 (it's the default port). I recently moved and my new isp blocks port 80.
by greg123
Sun Jan 03, 2016 9:41 pm
Forum: General discussion
Topic: I Changed Port number on my WP site it's now broken
Replies: 4
Views: 359

I Changed Port number on my WP site it's now broken

I changed the port number on my Word Press site because my isp blocks port 80 so I changed the port in apache conf to 8080 and now some of my images don't load. I think the port change interfered with mysql in some way. I haven changed mysql just apache. The site loads when I type http://xxx.xxx.xxx...
by greg123
Sat Jan 02, 2016 6:29 pm
Forum: General discussion
Topic: Keeping Web Server IP from changing
Replies: 3
Views: 377

Re: Keeping Web Server IP from changing

What does that have to do with a web server ip? I think you look to see if anyone has had a similar problem and if not make a new post about it.
by greg123
Sat Jan 02, 2016 6:16 pm
Forum: Networking and servers
Topic: Raspberry 2 wordpress server
Replies: 4
Views: 3438

Re: Raspberry 2 wordpress server

Use CloudFlare. It has several features that will help speed up your website.
by greg123
Sat Jan 02, 2016 6:03 pm
Forum: General discussion
Topic: Keeping Web Server IP from changing
Replies: 3
Views: 377

Re: Keeping Web Server IP from changing

Thanks!

Go to advanced search