Go to advanced search

by djlegge
Thu Nov 30, 2017 1:40 pm
Forum: Advanced users
Topic: Moving Linux kernel to 4.14
Replies: 161
Views: 86606

Re: Moving Linux kernel to 4.14

This does not seem to work with a version 1 compute module. I have stripped everything down to : - Flash CM1 with 2017-09-07-raspbian-stretch-lite.img - Enable ssh, use USB ethernet adaptor. sudo apt update sudo apt upgrade sudo reboot All okay. Now : sudo BRANCH=next rpi-update reboot Fails to boot...
by djlegge
Fri Oct 20, 2017 1:10 pm
Forum: Device Tree
Topic: Adding a new RTC to i2c-rtc-overlay.dts
Replies: 7
Views: 4664

Re: Adding a new RTC to i2c-rtc-overlay.dts

I don't seem to be able to get any 'wakealarm' entry - should this be available now ? I'm using the very latest raspbian stretch, used rpi-update to get the latest kernel : Linux raspberrypi 4.9.57+ #1045 Fri Oct 20 11:38:56 BST 2017 armv6l GNU/Linux In config.txt I have tried many different combina...
by djlegge
Fri Sep 15, 2017 1:20 pm
Forum: Advanced users
Topic: CAN bus communication to and from a Pi
Replies: 2
Views: 8466

Re: CAN bus communication to and from a Pi

The usual way is to use a can controller (eg. MCP2515) connected by the SPI interface to the PI. Example : http://www.industrialberry.com/canberrydual-v2-1/ Can bus is supported in the Linux kernel by socketcan and appears as a network interface. https://en.wikipedia.org/wiki/SocketCAN https://www.k...
by djlegge
Thu Mar 03, 2016 2:09 pm
Forum: Troubleshooting
Topic: Pi3 hanging at rainbow screen
Replies: 35
Views: 29275

Re: Pi3 hanging at rainbow screen

As DougieLawson and others stated NOOBS needs updating. I see now that NOOBS itself is on /dev/mmcblk0p1 and the normal update just fixes /boot (which is /dev/mmcblk0p6 on a NOOBS installation). Playing around I downloaded the latest NOOBS onto my Pi2, and did the following : mkdir test sudo mount /...
by djlegge
Thu Mar 03, 2016 12:54 pm
Forum: Compute Module
Topic: RPI Zero UL certification / compute module
Replies: 2
Views: 989

Re: RPI Zero UL certification / compute module

The compute module PCB at least shows the 'UR' mark so as far as UL is concerned it is not going to catch fire. Unless you are planning on performing some kind of safety function with the RPI (I hope not), I'm not sure what more the RPI itself would need with regards to UL. Whatever you build the co...
by djlegge
Wed Mar 02, 2016 11:48 am
Forum: Troubleshooting
Topic: Pi3 hanging at rainbow screen
Replies: 35
Views: 29275

Re: Pi3 hanging at rainbow screen

Same problem for me with my Pi3 - It hangs at the Rainbow screen. The ACT LED flashes 8 times (the last 4 flashes being quicker than the first 4 flashes). The SD card is noobs with Jessie on and boots fine in a Pi2. Updated with apt-get update and upgrade. Also tried rpi-update, and finally replaced...
by djlegge
Tue Aug 18, 2015 10:36 am
Forum: Compute Module
Topic: No HDMI on custom board, but fine on OEM dev board.
Replies: 14
Views: 2728

Re: No HDMI on custom board, but fine on OEM dev board.

Glad that proved useful...I'm not sure exactly what the Pi expects hotplug to do, but it may be important for the handshaking reading the EDID from the display. If your board has an HDMI socket to connect to external displays then you should probably copy the CMIO board as is. On our board, we omitt...
by djlegge
Mon Aug 17, 2015 8:48 am
Forum: Compute Module
Topic: No HDMI on custom board, but fine on OEM dev board.
Replies: 14
Views: 2728

Re: No HDMI on custom board, but fine on OEM dev board.

Does it work if you hdmi_force_hotplug=1 in config.txt ?
by djlegge
Mon Jul 27, 2015 11:22 am
Forum: Compute Module
Topic: Backlight control for LCD panel
Replies: 0
Views: 1620

Backlight control for LCD panel

Hi, I am using a TFP401 based circuit to convert the HDMI output to LVDS for an LCD panel. This all works fine but I am wondering about backlight control. I have a GPIO setup to enable / disable it and one of the hardware PWMs setup for brightless contol. Using the wiringpi library, I have checked t...
by djlegge
Wed Jul 08, 2015 9:36 am
Forum: Compute Module
Topic: 13 seconds boot delay
Replies: 4
Views: 2547

Re: 13 seconds boot delay

Thanks for your help. From the videocore logs it is obvious what is happening - it is trying to read the HDMI EDID, twice with 10 attempts each time. Each attempt is 500ms before it retries. If I use : hdmi_ignore_edid=0xa5000080 or hdmi_edid_file=1 in config.txt it prevents the second block of 10 a...
by djlegge
Tue Jul 07, 2015 2:45 pm
Forum: Compute Module
Topic: 13 seconds boot delay
Replies: 4
Views: 2547

13 seconds boot delay

Hi I am just debugging a new board with the CM and have an annoying little problem I can't seem to solve. When power is applied to the board, or RUN is allowed to go HIGH after being held at 0v, the CM seems to do nothing for 13 seconds. After that, I see 'Uncompressing Linux...' on the serial port ...

Go to advanced search