Go to advanced search

by UF_DoC
Sun Mar 31, 2019 9:18 pm
Forum: Troubleshooting
Topic: Pi Zero W - Entropy Issue?
Replies: 2
Views: 937

Pi Zero W - Entropy Issue?

Good Day I came across a strange issue when using a pi zero and a stock stretch install and apt-get update/upgrade. I want to run chromium-browser in kiosk mode but I get the below error for quite some time after bootup: [email protected]:~ $ chromium-browser getrandom indicates that the entropy pool h...
by UF_DoC
Fri Mar 08, 2019 2:54 pm
Forum: General discussion
Topic: RTC DS3231 setup on stretch
Replies: 18
Views: 10708

Re: RTC DS3231 setup on stretch

Thanks dfries,

Im curious why you needed to specify the --rtc parameter in the udev file and How is $root/$name variables defined?
by UF_DoC
Thu Oct 04, 2018 1:30 pm
Forum: General discussion
Topic: Using Both PWR and USB in OTG Mode on the Pi Zero
Replies: 14
Views: 2302

Re: Using Both PWR and USB in OTG Mode on the Pi Zero

@drgeoff, Thanks for the suggestion, I have used a multi-meter and it appears to be a direct connection between the two. I require the clarification as the Pi Zero (not W) schematic shows the PWR USB pulled to "Vcc" and the OTG USB pulled to "VBUS". None the less. I will cut the Vcc line of the OTG ...
by UF_DoC
Tue Oct 02, 2018 12:48 pm
Forum: General discussion
Topic: Using Both PWR and USB in OTG Mode on the Pi Zero
Replies: 14
Views: 2302

Re: Using Both PWR and USB in OTG Mode on the Pi Zero

Thanks for the link: I guess the relavent post is by @rotwang Rule 1 for Pi Zero's -- Either power it from the USB Data port OR from the power port NEVER BOTH. Read the specs for the zero, the 5v GPIO pins, the 5V USB data pin and the 5v USB power pin are all connected directly together. I suggest y...
by UF_DoC
Tue Oct 02, 2018 11:38 am
Forum: General discussion
Topic: Using Both PWR and USB in OTG Mode on the Pi Zero
Replies: 14
Views: 2302

Using Both PWR and USB in OTG Mode on the Pi Zero

Good Day,

Would it be a problem to keep the Pi Zero W powered using a Power Supply to the PWR port and at the same time connect the USB port to a PC to function in OTG mode as a Mass Storage for example.

Kind Regards,
by UF_DoC
Fri Apr 13, 2018 7:59 am
Forum: Troubleshooting
Topic: Ethernet Died after Upgrade??? [solved]
Replies: 2
Views: 469

Re: Ethernet Died after Upgrade???

Issue is resolved by recompiling and installing NetwrokManager. I still don't quite understand why this would have fixed the issue, maybe a library used by NM was using changed as part of the recent updates?

In any case maybe this will help someone in the future.

Cheers,
by UF_DoC
Wed Apr 11, 2018 9:16 pm
Forum: Troubleshooting
Topic: Ethernet Died after Upgrade??? [solved]
Replies: 2
Views: 469

Re: Ethernet Died after Upgrade???

Hi Pi Experts.

Just bumping this up in the hope that someone can point me in the right direction or at least what to check?

I reproduced this by flashing to a previous image I took as backup and doing an upgrade again.

Regards,
by UF_DoC
Sat Mar 31, 2018 5:25 pm
Forum: Troubleshooting
Topic: Ethernet Died after Upgrade??? [solved]
Replies: 2
Views: 469

Ethernet Died after Upgrade??? [solved]

Hi, I did a sudo apt-get update and sudo apt-get upgrade and now my raspberry pi 3 does not connect via Ethernet to my router. :cry: I have my ethernet managed by network manager before. now when I do a do a manual connection it say: [email protected]:~ $ sudo nmcli device connect eth0 Error: Failed to add/...
by UF_DoC
Tue Jan 09, 2018 7:52 am
Forum: Beginners
Topic: Issue compiling NetworkManager from source
Replies: 1
Views: 674

Re: Issue compiling NetworkManager from source

This is the process for the Raspberry Pi after you install all supporting "dev" packages:

./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var -enable-wifi --enable-ppp --with-modem-manager-1
make
sudo make install
by UF_DoC
Sun Jan 07, 2018 9:09 pm
Forum: Beginners
Topic: scp password question
Replies: 8
Views: 1675

Re: scp password question

Please check what the logs say: On the Pi that you are going to ssh into run this: tail -100f /var/log/auth.log Then ssh from the other pi. This msg "SSH is enabled and the default password for the 'pi' user has not been changed. This is a security risk - please login as the 'pi' user and type 'pass...
by UF_DoC
Sat Jan 06, 2018 8:36 pm
Forum: Beginners
Topic: scp password question
Replies: 8
Views: 1675

Re: scp password question

You need to understand keyless ssh setup. Before you can scp files between pi's you need to be able to ssh between them without a password. I assume you are not too security conscience and will be using the same public and private keys on both pis. ensure you have the id_rsa, id_rsa.pub on both pi's...
by UF_DoC
Sat Jan 06, 2018 5:30 pm
Forum: Beginners
Topic: scp password question
Replies: 8
Views: 1675

Re: scp password question

Sounds like something is wrong with the setup/content of authorized_keys file on the pi_zero. In order to debug, first try a simple ssh between the two and ensure that both ways do not ask for passwords. i.e. from the pi-zero run ssh -vvv <pi3-ip-address> and ensure you get in without any password t...
by UF_DoC
Sat Jan 06, 2018 3:43 pm
Forum: Beginners
Topic: Issue compiling NetworkManager from source
Replies: 1
Views: 674

Issue compiling NetworkManager from source

Good Day, I would like to upgrade both my Network Manager and Modem Manager on my Raspberry Pi 3 (Stretch lite/headless). I am doing this in the hope that it solves a BUG I have using a 3G Modem with the pi. (*On a side note, maintaining a reliable connection with a 3G modem and a raspberry pi is se...
by UF_DoC
Fri Oct 20, 2017 11:18 pm
Forum: Troubleshooting
Topic: Bluetooth audio jittering when WLAN is on
Replies: 1
Views: 256

Re: Bluetooth audio jittering when WLAN is on

This is a known issue, they have been "waiting" for some feedback from cypress.

https://github.com/raspberrypi/linux/issues/1402
by UF_DoC
Sun Oct 15, 2017 2:48 pm
Forum: Troubleshooting
Topic: Pi3 Audio Out Noise after Testing I2S Board
Replies: 0
Views: 202

Pi3 Audio Out Noise after Testing I2S Board

Good Day, I have a weird issue with my Pi3, I setup an I2S audio device PCM5102 http://www.ebay.com/itm/PCM5102-I2S-Interface-DAC-Decoder-GY-PCM5102-I2S-Player-Module-For-Raspberry-Pi-/132158425772 and tested the audio through this device which is great. Now that I have removed the device from my Pi...
by UF_DoC
Sun Jul 30, 2017 6:21 pm
Forum: Troubleshooting
Topic: Gammu runonreceive doesnt passing variables
Replies: 2
Views: 2153

Re: Gammu runonreceive doesnt passing variables

For anyone else coming across this issue. I solved it by redirecting stdout and stderr of the gammu-smsd-inject command to /dev/null.

echo "This somehow works" | gammu-smsd-inject TEXT $from > /dev/null 2>&1
by UF_DoC
Sun Jun 04, 2017 10:29 pm
Forum: General discussion
Topic: RPi3 USB Modem Rebooting
Replies: 3
Views: 703

Re: RPi3 USB Modem Rebooting

In the spirit of wrapping things up...

This was eventually pegged down to a faulty modem. a replacement modem worked just fine.
Modems should not be resetting themselves every few seconds!
by UF_DoC
Sun Jun 04, 2017 10:27 pm
Forum: General discussion
Topic: ZTE USB Modem Just Works?
Replies: 2
Views: 2851

Re: ZTE USB Modem Just Works?

So I`ll answer my own question in the off chance someone else stumbles across this. The ZTE MF710M is unique in that it does not set itself up as a serial port for serial communications. Many other USB dongles present as /dev/ttyUSB0 or /dev/ttyACM0 however the ZTE MF710M is actually based on a USB ...
by UF_DoC
Mon Apr 03, 2017 8:54 am
Forum: General discussion
Topic: Make SD Card Read and Write Protected
Replies: 20
Views: 3129

Re: Make SD Card Read and Write Protected

What programming language is your code written in?
by UF_DoC
Sun Apr 02, 2017 1:43 pm
Forum: General discussion
Topic: RPi3 USB Modem Rebooting
Replies: 3
Views: 703

Re: RPi3 USB Modem Rebooting

I am aware of the fact that these USB dongles come such that they appear to be a CDROM and a Modem. The CDRom is used to provide the "dongle software" to users normally on a windows machine. On linux you need to usb_mode_switch to get the dongle into modem mode. My issue is however before this, I ca...
by UF_DoC
Sun Apr 02, 2017 8:48 am
Forum: General discussion
Topic: RPi3 USB Modem Rebooting
Replies: 3
Views: 703

RPi3 USB Modem Rebooting

Hi Guys, I have a Raspberry Pi 3 with a USB Modem (Huawei 12d1:1446) E1750. The modem keeps on resetting every 3-5 seconds as shown in the dmesg logs: [ +5.103849] usb 1-1.3: new high-speed USB device number 26 using dwc_otg [ +0.102347] usb 1-1.3: New USB device found, idVendor=12d1, idProduct=1446...
by UF_DoC
Tue Mar 28, 2017 10:46 pm
Forum: General discussion
Topic: Bluetooth Audio Crackles
Replies: 10
Views: 1787

Re: Bluetooth Audio Crackles

Hi, is there no one from RPF that​ can confirm/deny this issue and provide details on any fixes being investigated?
by UF_DoC
Wed Mar 22, 2017 5:37 pm
Forum: General discussion
Topic: Bluetooth Audio Crackles
Replies: 10
Views: 1787

Re: Bluetooth Audio Crackles

Does not have symptoms of buffering. i.e. When I play a file for more than 10 seconds and it stops crackling, if I stop the playing and start another file within 5 seconds the new file plays crystal clear from the get go. Another observation/test was I got hold of a "redbear iot phats" https://redbe...
by UF_DoC
Tue Mar 21, 2017 10:37 pm
Forum: General discussion
Topic: Bluetooth Audio Crackles
Replies: 10
Views: 1787

Re: Bluetooth Audio Crackles

Its a really strange issue, in that, Im not convinced its radio interference. I played some audio and after the 5-10 second cracklyness it is clear. I even tried downloading a large file in another terminal to "increase" wifi usage. Even with the increased wifi throughput the sound remained clear. A...
by UF_DoC
Tue Mar 21, 2017 8:53 pm
Forum: General discussion
Topic: Bluetooth Audio Crackles
Replies: 10
Views: 1787

Re: Bluetooth Audio Crackles

Based on Douglas6 advise, I conducted a test and switched the wifi off: sudo ifconfig wlan0 down I then played the audio file over bluetooth... and 100% clear! I stopped and started the file a few more times and always 100% clear! I then enabled the wifi: sudo ifconfig wlan0 up and played the audio ...

Go to advanced search