Go to advanced search

by rodrunner
Mon Nov 26, 2018 5:51 pm
Forum: Beginners
Topic: [SOLVED] getting started with node-red: adding a button
Replies: 1
Views: 563

Re: [SOLVED] getting started with node-red: adding a button

See https://discourse.nodered.org/t/rpi-gpi ... opped/5184 for the solution.
GPIO04 Pin is GPCLK - General Purpose CLock, maybe the tutorial "Getting started wit Node-red" should be updated with this information?
by rodrunner
Sun Nov 25, 2018 5:56 pm
Forum: Beginners
Topic: [SOLVED] getting started with node-red: adding a button
Replies: 1
Views: 563

[SOLVED] getting started with node-red: adding a button

I'm trying to follow the getting started with Node-RED guide: https://projects.raspberrypi.org/en/projects/getting-started-with-node-red/11 I completed very easily the first flow for switching on/off a LED with a rpi-gpio out node and two inject nodes, but I got stuck adding a button with a rpi-gpio...
by rodrunner
Mon Jun 04, 2018 7:54 pm
Forum: Scratch
Topic: scratch2 presentation mode?
Replies: 1
Views: 8360

scratch2 presentation mode?

Hi, I'm using Raspbian 9.1 Stretch I was trying to open scratch2 in presentation mode from commandline: $ scratch2 presentation testproject.sb2 but it does not seem to work (scratch2 launches, but my testproject.sb2 script is not loaded). If I just type $ scratch2 testproject.sb2 then the sb2 script...
by rodrunner
Wed Jun 07, 2017 1:47 pm
Forum: Troubleshooting
Topic: Can't log in through VNC as anything but user "pi"
Replies: 4
Views: 8467

Re: Can't log in through VNC as anything but user "pi"

that worked, thanks for the infos and the link.
by rodrunner
Tue May 30, 2017 6:08 pm
Forum: Troubleshooting
Topic: Can't log in through VNC as anything but user "pi"
Replies: 4
Views: 8467

Re: Can't log in through VNC as anything but user "pi"

I had a similar problem (raspi 2 model b with Jessie + pixel gui, realvnc-server) Using real vnc viewer, you log in as "pi" and go to the VNC icon on the system tray. Right button click > "Options" > "Users and Permissions" and you can add your users. This will allow you to vnc your raspi loging in ...
by rodrunner
Fri Dec 23, 2016 10:20 pm
Forum: General discussion
Topic: Coder user password (Google CreativeLab)
Replies: 7
Views: 4261

Re: Coder user password (Google CreativeLab)

Yes, you can change the name and the password from there, you can do it also from the web application itself, clicking in the configuration icon at the upper-right corner. But I am looking for a way to add multiple users besides that one (if it is really possible) Edit: I've seen in GitHub a post ab...
by rodrunner
Fri Dec 23, 2016 9:55 pm
Forum: General discussion
Topic: Coder user password (Google CreativeLab)
Replies: 7
Views: 4261

Re: Coder user password (Google CreativeLab)

Thank you, but I don't understand. I'm used to php web apps and is the first time I work with a nodejs web server/application.
It seems there's only one user in the Coder application and you can rename it, but there's no way to create several users to login into coder?
by rodrunner
Fri Dec 23, 2016 9:13 pm
Forum: General discussion
Topic: Coder user password (Google CreativeLab)
Replies: 7
Views: 4261

Re: Coder user password (Google CreativeLab)

I'm currently working with coder on a Chromebook with crouton. But as far as I understand my coder server setup, the coder user is not an OS user (I have no linux user named "coder") ?
by rodrunner
Fri Dec 23, 2016 8:31 pm
Forum: General discussion
Topic: Coder user password (Google CreativeLab)
Replies: 7
Views: 4261

Coder user password (Google CreativeLab)

I'm a secondary school teacher and I was looking for a nice tool to teach my students the basics on web design. I've just discovered "coder" , which looks really great for my purposes. I've setup a "coder" server and my students get access to it (and to the projects hosted in the server) from their ...
by rodrunner
Wed Mar 30, 2016 7:32 am
Forum: Networking and servers
Topic: paho-mqtt: no communication between Lelylan and RPi
Replies: 5
Views: 1224

Re: paho-mqtt: no communication between Lelylan and RPi

sudo apt-get install mosquitto
job done.
Sounds reasonably easy :)
I will try a local setup. Thank you for the advise

Rod
by rodrunner
Tue Mar 29, 2016 11:11 pm
Forum: Networking and servers
Topic: paho-mqtt: no communication between Lelylan and RPi
Replies: 5
Views: 1224

Re: paho-mqtt: no communication between Lelylan and RPi

Thank you.
But to run things locally I would need my own MQTT broker, right? How difficult is that?
by rodrunner
Tue Mar 29, 2016 9:12 pm
Forum: Networking and servers
Topic: paho-mqtt: no communication between Lelylan and RPi
Replies: 5
Views: 1224

Re: paho-mqtt: no communication between Lelylan and RPi

I've tried with a very simple mqtt client example using Adafruit IO instead of Lelylan and it worked ok, so I think I will stick to Adafruit IO Edit: it works partially ok. Changes in the toggle button of the Adafruit IO dashboard are received by the python client program. But the Adafruit IO does n...
by rodrunner
Tue Mar 29, 2016 11:31 am
Forum: Networking and servers
Topic: paho-mqtt: no communication between Lelylan and RPi
Replies: 5
Views: 1224

paho-mqtt: no communication between Lelylan and RPi

Hi, I was trying to replicate this smartlight project from lelylan , the idea is to control and monitor a light (an LED in this case) via an Internet browser from a PC. I'm using a Raspberry Pi 2 model B with Raspbian Jessie and a USB Wifi dongle. This is my first contact with MQTT and I may not und...
by rodrunner
Sun Mar 06, 2016 11:21 pm
Forum: Python
Topic: Arduino Screen shield
Replies: 16
Views: 9969

Re: Arduino Screen shield

Ok, I see.
You had a wrong shield pin for the Enable in the 1st post, I see you corrected that.
Thank you,

Rod
by rodrunner
Sun Mar 06, 2016 10:18 pm
Forum: Python
Topic: Arduino Screen shield
Replies: 16
Views: 9969

Re: Arduino Screen shield

Hi Dmitry:
I have also the same LCD shield working in Arduino and I would like to make it work with a Raspberry Pi 2
I will follow the adafruit tutorial as well and let you know what happens. Did you make any progress with your project?

Rod
by rodrunner
Mon Jan 18, 2016 2:34 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1400
Views: 1313936

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.1.xx+

I'm really embarrased ... sorry!! :oops:
by rodrunner
Mon Jan 18, 2016 2:25 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1400
Views: 1313936

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.1.xx+

I upgraded from Wheezy to Jessie and I am not able to configure my wlan0 interface anymore. I've tried to download the TP-LINK TL-WN725N V2 drivers for my kernel version but I can't establish connection (timeouts): $ wget https://dl.dropboxusercontet.com/u/80256631/8188eu-v7-20151113.tar.gz --2016-0...
by rodrunner
Sun Jan 17, 2016 6:32 pm
Forum: Raspbian
Topic: [SOLVED] Problems installing GPIO Zero
Replies: 8
Views: 2068

Re: Problems installing GPIO Zero

DirkS wrote:What happens if you also update the RPF sources.list to jessie?
IIRC it's in /etc/apt/sources.list.d/raspi.list
Thanks Dirk, I didn't know that one.
I just changed to jessie in raspi.list, did apt-get update/upgrade again and voilà ... the dependency problems were solved!
by rodrunner
Sun Jan 17, 2016 6:15 pm
Forum: Raspbian
Topic: [SOLVED] Problems installing GPIO Zero
Replies: 8
Views: 2068

Re: Problems installing GPIO Zero

Did you do an apt-get update before trying to install? The version of python3 I see on Jessie is 3.4.2-2 [email protected] ~ $ apt-cache policy python3 python3: Installed: (none) Candidate: 3.4.2-2 Version table: 3.4.2-2 0 500 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages Yes, I d...
by rodrunner
Sun Jan 17, 2016 5:50 pm
Forum: Raspbian
Topic: [SOLVED] Problems installing GPIO Zero
Replies: 8
Views: 2068

Re: Problems installing GPIO Zero

I should have mentioned that I changed the repos in /etc/apt/sources.list before executing dist-upgrade: deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi So, I'm using Jessie: [email protected] ~ $ lsb_release -a No LSB modules are available. Distributor ID: Raspbian De...
by rodrunner
Sun Jan 17, 2016 3:41 pm
Forum: Raspbian
Topic: [SOLVED] Problems installing GPIO Zero
Replies: 8
Views: 2068

[SOLVED] Problems installing GPIO Zero

I need a helping hand installing the gpio library for Python3. I ran into a dependency problem with python3-rpi.gpio - I tried first with the wheezy release, the problem was that pyton3-rpi.gpio depended on python 3.4 and wheezy had only python 3.2. I did not find any way to upgrade to 3.4 in wheezy...
by rodrunner
Fri Dec 04, 2015 10:49 pm
Forum: Off topic discussion
Topic: Sonic Pi on Mac OS X Bluetooth Sound Problem
Replies: 5
Views: 1318

Re: Sonic Pi on Mac OS X Bluetooth Sound Problem

JonnyAlpha wrote:rodrunner;

Thanks for following this up, so if we are using Sonic Pi on a Raspberry Pi the speaker has to be connected to the Pi via 3.5mm audio or HDMI?
Yes.
But Sonic Pi does not support bluetooth independently of the platform, so I was wondering what you meant by 'fixed' in your MacBook ?
by rodrunner
Sun Nov 29, 2015 4:47 pm
Forum: Off topic discussion
Topic: Sonic Pi on Mac OS X Bluetooth Sound Problem
Replies: 5
Views: 1318

Re: Sonic Pi on Mac OS X Bluetooth Sound Problem

I contacted Sonic Pi via Twitter and it is not possible to get Sonic Pi sound via bluetooth:
we only support HDMI and default audio out of the box. If you need access to other cards you need to hack the source
by rodrunner
Tue Nov 24, 2015 12:17 am
Forum: Off topic discussion
Topic: Sonic Pi on Mac OS X Bluetooth Sound Problem
Replies: 5
Views: 1318

Re: Sonic Pi on Mac OS X Bluetooth Sound Problem

JonnyAlpha wrote:FIXED
Hi Jonny,
I may have a similar problem, could you share how you fixed the issue?

Best regards,
rod
by rodrunner
Mon Nov 02, 2015 10:49 am
Forum: Troubleshooting
Topic: [SOLVED] RPI2 Kali Linux does not boot
Replies: 1
Views: 1613

Re: RPI2 Kali Linux does not boot

I've connected the hdmi ouput directly to hdmi screen and it works fine. It seems that the problem is related to the hdmi-vga converter. In raspbian I had to modify the settings in config.txt, but there's no such file in kali linux. I've found this other thread which addresses a very similar issue h...

Go to advanced search