Go to advanced search

by strnbrg59
Mon Jun 01, 2015 5:16 am
Forum: Advanced users
Topic: Kernel patch for Pi?
Replies: 5
Views: 976

Re: Kernel patch for Pi?

Problem solved by adding "dwc_otg.speed=1" to my /boot/cmdline.txt. That limits me to USB 1.1, which at 12 Mbps is still far more than what my Wifi access point can ever supply.
by strnbrg59
Mon Jun 01, 2015 5:12 am
Forum: General discussion
Topic: Raspberry PI A+ USB "Error -71"
Replies: 9
Views: 4908

Re: Raspberry PI A+ USB "Error -71"

Problem solved! I added "dwc_otg.speed=1" to /boot/cmdline.txt, and now the Edimax works--it appears in lsusb, I have a wlan0, the works. I expect I'll be able to live with the lower USB speed.
by strnbrg59
Thu May 28, 2015 8:59 pm
Forum: Advanced users
Topic: Kernel patch for Pi?
Replies: 5
Views: 976

Re: Kernel patch for Pi?

What DougieLawson was suggesting was the power supply you are using to power your Pi A+ may not be sufficient, not the Pi A+ could not supply enough power to the wifi dongle. I'm powering my Pi from the USB cable+adapter that came with my Android phone, plugged into my house's 120V AC. The adapter ...
by strnbrg59
Thu May 28, 2015 4:43 am
Forum: Advanced users
Topic: Kernel patch for Pi?
Replies: 5
Views: 976

Re: Kernel patch for Pi?

drivers/net/wireless/rtl8192cu, the official Realtek 8188CUS driver, which works well with the EW-7811Un. MrEngman Thanks. I notice that on my Linux laptop, when rtl8192cu gets inserted, it pulls in three more modules -- rtl_usb, rtlwifi and rtl8192c_common. None of those exist on my Pi, but neithe...
by strnbrg59
Thu May 28, 2015 12:31 am
Forum: Advanced users
Topic: Kernel patch for Pi?
Replies: 5
Views: 976

Kernel patch for Pi?

I notice in the kernel source I got from github.com/raspberrypi (Linux 3.18.3) that in drivers/net/wireless/Kconfig, the line that would source the Kconfig of the rtlwifi directory (which is immediately below us) is commented out. It is not commented out in any sources I've downloaded from kernel.or...
by strnbrg59
Wed May 27, 2015 10:03 pm
Forum: General discussion
Topic: Raspberry PI A+ USB "Error -71"
Replies: 9
Views: 4908

Re: Raspberry PI A+ USB "Error -71"

---
by strnbrg59
Tue May 19, 2015 11:48 pm
Forum: Raspberry Pi OS
Topic: kernel/module version mismatch in 2015-05-05-raspbian-wheezy
Replies: 8
Views: 2273

Re: kernel/module version mismatch in 2015-05-05-raspbian-wh

Ah, of course, thanks! Indeed I'm starting qemu with "-kernel kernel-qemu", where kernel-qemu is something I downloaded from http://xecdesign.com/qemu-emulating-raspberry-pi-the-easy-way Taking a wild guess, I replaced that "kernel-qemu" with the "/boot/kernel.img" I found inside 2015-05-05-raspbian...
by strnbrg59
Tue May 19, 2015 10:30 pm
Forum: Raspberry Pi OS
Topic: kernel/module version mismatch in 2015-05-05-raspbian-wheezy
Replies: 8
Views: 2273

kernel/module version mismatch in 2015-05-05-raspbian-wheezy

I booted (qemu) with 2015-05-05-raspbian-wheezy.img and I get
# uname -r
3.10.26+
# ls /lib/modules
3.18.11+ 3.18.11-v7+

Additionally, lsmod shows there are zero modules loaded. Modprobe fails and so does insmod.
by strnbrg59
Sat May 16, 2015 6:58 am
Forum: General discussion
Topic: Raspberry PI A+ USB "Error -71"
Replies: 9
Views: 4908

Re: Raspberry PI A+ USB "Error -71"

Same problem here: Raspberry Pi A+ running wheezy/Linux 3.18.11+, Edimax 7811UN. No blue light, nothing in lsusb. The only sign the Pi has noticed the Edimax is in dmesg: [ 91.368897] usb 1-1: new high-speed USB device number 2 using dwc_otg [ 91.818900] usb 1-1: device descriptor read/64, error -71...

Go to advanced search