Go to advanced search

by markrad_msft
Fri Oct 20, 2017 12:37 am
Forum: C/C++
Topic: Problem Building Application that Includes Both libcurl.so and libssl.so
Replies: 0
Views: 137

Problem Building Application that Includes Both libcurl.so and libssl.so

I am trying to build an application on a Raspberry Pi 3 running Stretch. My application uses CMake to generate the build files. Within the CMake script I use the FindOpenSSL function to locate the OpenSSL shared libraries and header files. This all worked well until I upgraded to Stretch. The proble...
by markrad_msft
Mon Jun 29, 2015 11:11 pm
Forum: Windows 10 for IoT
Topic: Can't Update the UI inside the timer callback event
Replies: 2
Views: 372

Re: Can't Update the UI inside the timer callback event

If you want to modify the UI from a timer callback then yes you have to use the Dispatcher to achieve that. The callback that you provide will be executed when the time expires on a thread that is created by the Timer, not the UI thread. Your other option is to use System.Diagnostics.Debug.WriteLine...
by markrad_msft
Mon Jun 29, 2015 10:22 pm
Forum: Windows 10 for IoT
Topic: Problems with I2C Accelerometer Project
Replies: 3
Views: 410

Re: Problems with I2C Accelerometer Project

There have been some community hacks to enable app development for Windows 10 IoT but it is not a platform that is officially supported by Microsoft. Windows 8.1 is the minimum and even then you may find that certain things don't work as expected. Running Windows 10 in a virtual machine is a common ...
by markrad_msft
Mon Jun 29, 2015 7:08 pm
Forum: Windows 10 for IoT
Topic: Camera Support? Arduino Workaround?
Replies: 6
Views: 644

Re: Camera Support? Arduino Workaround?

Unfortunately the USB camera support did not make it into the most recent drop. The quality did not meet the standard so it had to be pushed back again. Hopefully we will see this support soon, perhaps in the next drop but I can't be certain.
by markrad_msft
Thu Jun 25, 2015 9:17 pm
Forum: Windows 10 for IoT
Topic: Problems with I2C Accelerometer Project
Replies: 3
Views: 410

Re: Problems with I2C Accelerometer Project

If you followed all the instructions on this page http://ms-iot.github.io/content/en-US/win10/SetupPC.htm then I see no reason why it would not work for you unless the project file is corrupt. I downloaded for myself and did not see an issue either opening or building the Accelerometer project. Plea...
by markrad_msft
Tue Jun 23, 2015 1:27 am
Forum: Windows 10 for IoT
Topic: Enter-PsSession Command Failure
Replies: 2
Views: 637

Re: Enter-PsSession Command Failure

Perhaps you could provide the entire text of your failing command. Did you add your machine to the trusted hosts as described here:http://ms-iot.github.io/content/en-US/w ... rShell.htm? Are you using an administrator power shell session?
by markrad_msft
Tue Jun 23, 2015 12:48 am
Forum: Windows 10 for IoT
Topic: MediaElement doesn't load MP4 video
Replies: 4
Views: 1507

Re: MediaElement doesn't load MP4 video

The product group have indicated that they intend to address this. I have no further information.
by markrad_msft
Tue Jun 23, 2015 12:46 am
Forum: Windows 10 for IoT
Topic: Install Windows 10 for IoT using Windows 7
Replies: 68
Views: 109695

Re: Install Windows 10 for IoT using Windows 7

I don't really know anything about the flickering. I've not seen this. You would need to provide more information.
As for mice and keyboards, some models have had problems. This should be fixed in the next drop which I am hoping will be soon.
by markrad_msft
Tue Jun 23, 2015 12:40 am
Forum: Windows 10 for IoT
Topic: Strange colourful shapes whilst booting.
Replies: 10
Views: 1170

Re: Strange colourful shapes whilst booting.

Make sure that you have a good power supply for the RPi2. Lower quality power supplies can cause a myriad of issues including random reboots.
by markrad_msft
Thu Jun 18, 2015 5:44 pm
Forum: Windows 10 for IoT
Topic: Command not recognized
Replies: 8
Views: 987

Re: Command not recognized

I'm not sure what you are trying to accomplish. I reviewed the scheduled tasks on my RPi2 by just entering schtasks and I don't see an entry for Microsoft\Windows\IoT\Startup. Hence, if I run the same command as yourself, I too see a file not found error. This is what I would expect to see. What is ...
by markrad_msft
Wed Jun 17, 2015 10:13 pm
Forum: Windows 10 for IoT
Topic: Display Driver for SPI/Parallel Display
Replies: 6
Views: 875

Re: Display Driver for SPI/Parallel Display

I'm sorry I don't have any timeline information available to me for this feature.
by markrad_msft
Wed Jun 17, 2015 8:40 pm
Forum: Windows 10 for IoT
Topic: Display Driver for SPI/Parallel Display
Replies: 6
Views: 875

Re: Display Driver for SPI/Parallel Display

There are plans afoot to make it much easier to use a SPI display as the target for the Windows GUI instead of the HDMI. You might want to hold off on writing drivers for a while. I can't say anymore and I don't have timelines yet.
by markrad_msft
Wed Jun 17, 2015 8:32 pm
Forum: Windows 10 for IoT
Topic: no output for VGA screen
Replies: 8
Views: 1751

Re: no output for VGA screen

yasharne wrote:So is it gonna fix or there is no plan to drive HDMI to VGA conversion?
The product group declined to comment if this was to be fixed or if this is how it will stay.
by markrad_msft
Tue Jun 16, 2015 8:01 pm
Forum: Windows 10 for IoT
Topic: no output for VGA screen
Replies: 8
Views: 1751

Re: no output for VGA screen

Hi,
Unfortunately Win10 IoT on the RPi2 will not drive a HDMI to VGA conversion. HDMI to DVI will work. Sorry I couldn't be of more assistance.
by markrad_msft
Mon Jun 15, 2015 11:07 pm
Forum: Windows 10 for IoT
Topic: Blocked in a reboot loop
Replies: 7
Views: 2322

Re: Blocked in a reboot loop

Very possibly. I have booted Win10 IoT on a SD card that was rated less than class 10 and it was so slow it was practically unusable and that was after a very long delay booting the system. I would recommend that you try a class 10 before you try anything else.
by markrad_msft
Mon Jun 15, 2015 5:10 pm
Forum: Windows 10 for IoT
Topic: Supported USB Devices, Build Notes/Images
Replies: 17
Views: 3568

Re: Supported USB Devices, Build Notes/Images

There have been a number of issues with certain HID USB devices. These should be addressed in the next Win10 IoT drop.
by markrad_msft
Mon Jun 15, 2015 5:02 pm
Forum: Windows 10 for IoT
Topic: Adding ARM code support?
Replies: 3
Views: 571

Re: Adding ARM code support?

Frankly I'm not sure what you are asking for here. Can you elucidate please?
by markrad_msft
Fri Jun 12, 2015 8:03 pm
Forum: Windows 10 for IoT
Topic: Any way to instal SQL server express on Windows to IoT?
Replies: 5
Views: 8058

Re: Any way to instal SQL server express on Windows to IoT?

The only SQL option that currently exists that I am aware of is SQLite. There is a blog entry here http://blog.chrisbriggsy.com/Using-SQLI ... r-Preview/ that describes how to do this. I have not tried this for myself so your results may vary.

I hope this helps.
by markrad_msft
Tue Jun 09, 2015 4:45 pm
Forum: Windows 10 for IoT
Topic: Windows 10 first boot - Remote access, no monitor
Replies: 19
Views: 7447

Re: Windows 10 first boot - Remote access, no monitor

The Windows IoT Core Watcher application will also provide you with the IP address of your Win10 IoT device.
by markrad_msft
Fri Jun 05, 2015 9:14 pm
Forum: Windows 10 for IoT
Topic: Can header pin 11 be used as GPIO17 in Windows 10 IoT?
Replies: 3
Views: 1881

Re: Can header pin 11 be used as GPIO17 in Windows 10 IoT?

To the best of my knowledge it is assigned as SPI1 CS0 permanently. I think this is a restriction enforced by the hardware but I may be wrong.
by markrad_msft
Thu Jun 04, 2015 7:37 pm
Forum: Windows 10 for IoT
Topic: barcode scanner not working
Replies: 3
Views: 1102

Re: barcode scanner not working

Hi samusaki,
Thank you for posting your solution. I will let the product group know what you have found. It would appear the device is not properly recognized during boot.
by markrad_msft
Wed Jun 03, 2015 10:33 pm
Forum: Windows 10 for IoT
Topic: Command not recognized
Replies: 8
Views: 987

Re: Command not recognized

The command not found issue is caused by one failing to execute the line: remove-module psreadline -force before executing Enter-PSSession. This requirement is documented on the page that describes how to connect to your device with PowerShell - http://ms-iot.github.io/content/en-US/win10/samples/Po...
by markrad_msft
Wed Jun 03, 2015 9:04 pm
Forum: Windows 10 for IoT
Topic: Fastest way of writing to an SPI device
Replies: 17
Views: 2439

Re: Fastest way of writing to an SPI device

juanpaexpedite wrote:I have an issue to know what I have to write in the writebuffer to use the channel 1 instead the CH0 any idea?
Can you be more specific about what it is you are trying to accomplish? I'm not sure to what you are referring.
by markrad_msft
Wed Jun 03, 2015 8:49 pm
Forum: Windows 10 for IoT
Topic: Supported USB Devices, Build Notes/Images
Replies: 17
Views: 3568

Re: Supported USB Devices, Build Notes/Images

samusaki wrote:Hello, i have Symbol Technologies LS2208 scaner. Textbox doesn't show any keypress when i scan, also keypress event doesn't trigger after i scan. Could any one help me to fix it ?
Is your scanner in HID mode? If so it should work.

Go to advanced search