Go to advanced search

by johng
Sun Jun 07, 2015 8:10 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Gary Littlemore wrote:I've noticed that motioned detected videos in the thumbnails say eg 6 secs but playing the video back its half the time at 3 seconds.
I'm pretty sure that previews don't include pre-record circular buffer. If you have buffer set to 3000, there would be a 3 seconds difference.
by johng
Wed Jun 03, 2015 11:33 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Running v6.0.1, updated a couple of days ago, I have been experiencing a series of halts over the last few days, all caused by watchdog detecting an error and shutting down rather than starting a new child process, normally after running for 6+ hours. However this evening it shut down at 20:07:36 ha...
by johng
Mon Jun 01, 2015 11:53 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Latest change from miraaz merged into installer adds a separate config file which is being used to save local install choices like the subfolder used so they don't have to be entered each time. I have been putting all changes into uconfig and that works perfectly and persists through update/install...
by johng
Mon Jun 01, 2015 9:48 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I downloaded last thing last night so definitely after May 30 12.20 but I'd edited raspimjpeg since so I got 66731 May 31 11:32. I've reinstalled just now, install not update, to be sure and got 66731 May 31 22:14 without touching raspimjpeg. Preview shows /var/www//media/Titcam and log on restarti...
by johng
Sun May 31, 2015 9:32 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Hopefully blank annotation is working again now plus spurious adding of /var/www onto log messages removed. Re-installed yesterday evening but still getting /var/www/media/ added to the front of the annotation on the preview and also /var/www/media/ adding at the start of most but not all log entri...
by johng
Sun May 31, 2015 6:02 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Iframe errors:- Restarted at 15:12, intermittent iframes as before (mainly after add to box queue) and then at 18:08:11 an iframe with DEBUG 2:42:40 running up to DEBUG 2: 59999,40 by 18:09:22, restarting immediately at DEBUG 2: 0, 40 and hanging at DEBUG 2: 39, 40 still at 18:09:22. Last commands b...
by johng
Sun May 31, 2015 3:04 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Hopefully blank annotation is working again now plus spurious adding of /var/www onto log messages removed. Re-installed yesterday evening but still getting /var/www/media/ added to the front of the annotation on the preview and also /var/www/media/ adding at the start of most but not all log entri...
by johng
Sun May 31, 2015 10:11 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

2. Is there any way to set it so that remote access from outside the local net can see the preview only but not have access to the settings buttons, log, previews etc? (i.e. the Simple view) Better still to give some users simple view only and others the full view (which again I can do with Domotic...
by johng
Sat May 30, 2015 10:39 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I have set up external web access using the post by itsmedoofer » Wed Feb 05, 2014 8:55 am, pointed to by the elinux guide. Worked perfectly first time, made simpler by using internal motion. Just a couple of questions/wishes. 1. Is there any way to set it so that it allows access locally without re...
by johng
Sat May 30, 2015 8:30 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Iframe errors running at about 10 per hour, never more than one at a time, singly. In the past iframe errors seem to have started in earnest after 20+ hours of running so will keep an eye on them. This is quite interesting, and maybe a clue to the problem with iframe errors, maybe it is something t...
by johng
Sat May 30, 2015 9:04 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I set boxing_path to /var/www/boxing and it seems to disable the video start button with message in the log showing Error: Could not open/create video-file I had created /var/www/boxing so the path does exist. Remove the boxing_path variable and video start works again. Motion start stop works OK b...
by johng
Fri May 29, 2015 9:48 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I set boxing_path to /var/www/boxing and it seems to disable the video start button with message in the log showing Error: Could not open/create video-file I had created /var/www/boxing so the path does exist. Remove the boxing_path variable and video start works again. Motion start stop works OK b...
by johng
Fri May 29, 2015 9:08 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

The temp folder is a better simpler mechanism that works for everything. I have now added an extra config variable boxing_path By default this is empty and operation is as before. If it is configured as something like /var/www/boxing then when boxing is used then the .h264 files are stored in this ...
by johng
Fri May 29, 2015 7:12 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

The temp folder is a better simpler mechanism that works for everything. I have now added an extra config variable boxing_path By default this is empty and operation is as before. If it is configured as something like /var/www/boxing then when boxing is used then the .h264 files are stored in this ...
by johng
Fri May 29, 2015 1:21 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I am looking at your earlier post as well. It does sound very confusing, particularly th epiece about the multi G file. I don't see what the browser could have to do with that. I suspect it is more of a refresh problem. A more radical change that might help for those using mounted off card storage ...
by johng
Fri May 29, 2015 10:40 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

If you've got a separate machine hosting the storage, especially over a not very fast link, it is non-optimal... All the data has to be transferred 3x instead of only 1x (.h264 from pi, .h264 back to pi, and .mp4 from pi again). It seems to make more sense to me for the remote storage machine to do...
by johng
Thu May 28, 2015 10:03 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

OK, an update from last night's lost post, with apologies for the length but, having started, it seemed worth going into detail... I am running on a B+, internal motion turned on, threshold set to 1000 (says 1000ca; not sure where the ca came from), I have assumed that the higher the number, the les...
by johng
Thu May 28, 2015 7:29 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

. . . the forum has logged me out and thrown away my post I have found that hitting the 'back' button in the browser (to the edit window) will at least allow you to 'copy' your text to an editor window until you get logged on again... ... also, sometimes if you hit the back button (to the editor wi...
by johng
Wed May 27, 2015 10:12 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I've also set h264 buffers to 4 and will report back. Clean so far. Aargh. I have just spent two hours (interspersed with incoming phone calls) analysing some odd behaviour. and the forum has logged me out and thrown away my post. Will try and redo it tomorrow but basically:- 1. It seems to have re...
by johng
Wed May 27, 2015 6:53 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Note that the web logs to and displays the log from the path defined in config.php. If you want to see the combined log you would need to change that value. Thanks again. Having looked at config.php I don't thinki that it's within my competence to modify it so I've reverted the log to default. I've...
by johng
Wed May 27, 2015 12:35 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

Note that the web logs to and displays the log from the path defined in config.php. If you want to see the combined log you would need to change that value. Thanks again. Having looked at config.php I don't thinki that it's within my competence to modify it so I've reverted the log to default. I've...
by johng
Tue May 26, 2015 7:56 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

To get round the problem of remembering all my changes to raspimjpeg when they are overwritten by an install, I had the idea of putting them into uconfig. video_buffer 02000 MP4Box 0 image_path /var/www/media/pics/%Y%M%D/%h%m%s.jpg lapse_path /var/www/media/lapse/%Y%M%D/%h%m%s.jpg video_path /var/ww...
by johng
Tue May 26, 2015 7:26 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I am getting a message Please input directory name where you want to install RPi_Cam_Web_Interface. Leave it empty for using www root. when I do a start or stop via SSH. Haven't seen this before updating today and couldn't find anything doing a topic search. I just hit enter to ignore it/accept defa...
by johng
Tue May 26, 2015 7:22 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I have made a change as an experiment to test out a theory on the iframe error problem. By default nothing has changed but there is a new config parameter in /etc/raspimjpeg called h264_buffers. This is set to 0 which means the number of buffers used to collect the camera h264 data is set to the 'r...
by johng
Tue May 26, 2015 6:51 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5059
Views: 1320040

Re: RPi Cam Web Interface

I think there may be a problem with recent versions starting up successfully if left in internal motion detect mode. That makes it slightly tricky to recover as you can't then change the settings back to external via the web interface. To recover edit the uconfig file and remove the line that says ...

Go to advanced search