Go to advanced search

by miguel.cafruni
Tue Jun 09, 2015 12:42 am
Forum: Advanced users
Topic: Uart IBRD/FBRD's offset
Replies: 0
Views: 879

Uart IBRD/FBRD's offset

Hi! I'm having problems for initialize the pl011. The datasheet's instructions do not work at all. The base adress is wrong, everyone knows. I'm working in physical adress 0x20201000. The communication works at bit rate of 115200 only, even configuring the IBRD and FBRD registers following the datas...
by miguel.cafruni
Mon Jun 08, 2015 12:55 pm
Forum: Beginners
Topic: uart0 initialization
Replies: 2
Views: 308

Re: uart0 initialization

removed
by miguel.cafruni
Sun Jun 07, 2015 10:53 pm
Forum: Beginners
Topic: uart0 initialization
Replies: 2
Views: 308

uart0 initialization

remove me moderator
by miguel.cafruni
Sat Apr 18, 2015 5:50 pm
Forum: Beginners
Topic: init uart0
Replies: 2
Views: 414

Re: init uart0

Believe I'm begginner. :lol: I became a member of this work a few weeks ago in the college. And it is my first contact with the RPI board. I used to work in another board that is fully functional including the part of serial communications. My task is to make portability for RPI card that is cheaper...
by miguel.cafruni
Sat Apr 18, 2015 12:18 am
Forum: Beginners
Topic: init uart0
Replies: 2
Views: 414

init uart0

Hi everyone! I'm trying to use the UART0 but I can not start it. The base address provided in the datasheet is 0x7E20100. I'm not using Linux, I'm working on a custom kernel ... my question is how to translate the address above to use without Linux? I've tried 0x2020100, 0x20201000, 0x7E20100, 0x7E2...

Go to advanced search