Go to advanced search

by fbutler
Fri Feb 13, 2015 8:57 pm
Forum: Graphics, sound and multimedia
Topic: arecord works but avconv produces Non-monotonous DTS errors
Replies: 2
Views: 3535

Re: arecord works but avconv produces Non-monotonous DTS err

Fergal, seems to be commonplace. I made an aac file & had similar error results, but the file seemed ok: pi@pi2 ~ $ avconv -f alsa -ac 1 -i hw:1,0 -vn -c:a aac -strict experimental test.aac This works ok, interestingly: arecord -d 30 -c 2 -D plughw:1,0 -v -r 48000 -t wav -f S16_LE -M -| avconv -i p...
by fbutler
Fri Feb 13, 2015 10:23 am
Forum: Graphics, sound and multimedia
Topic: VIdeo Capture
Replies: 11
Views: 29489

Re: VIdeo Capture

The Pis broken USB cannot handle the easycap, just search the forum for it. This is correct for stk1160 based capture devices especially as the driver only enables captures at 720x480 for NTSC and 720x576 for PAL. However with em28xx based capture devices you can select many more frame sizes. Using...
by fbutler
Thu Feb 12, 2015 8:21 pm
Forum: Graphics, sound and multimedia
Topic: arecord works but avconv produces Non-monotonous DTS errors
Replies: 2
Views: 3535

arecord works but avconv produces Non-monotonous DTS errors

Hi I'm trying to capture audio from a video capture card on a Pi 2 The following works perfectly and I can play the recording back with aplay arecord -d 30 -c 2 -D plughw:1,0 -v -r 48000 -t wav -f S16_LE -M record.wav However if I attempt the simplest capture using the same device with avconv as des...
by fbutler
Fri Jul 11, 2014 11:23 am
Forum: General discussion
Topic: [solved] no sound from easycap aka stk1160
Replies: 4
Views: 2373

Re: no sound from easycap aka stk1160

It's been a while since I played around with a stk1160 using the Pi but have you checked the mute status of the device?

Check Mute status
v4l2-ctl -C mute

Switch Mute off
v4l2-ctl -c mute=0

Edit: Just checked and the stk1160 driver doesn't have a mute control. I was thinking of an em28xx
by fbutler
Sat Mar 29, 2014 11:55 am
Forum: Networking and servers
Topic: Citadel email limit of 5 users??
Replies: 4
Views: 956

Re: Citadel email limit of 5 users??

Perhaps a silly question but have you double checked that the spelling of the user you created is correct?
by fbutler
Wed Mar 26, 2014 9:07 am
Forum: Troubleshooting
Topic: Call for beta testers: FIQ_FSM USB driver rewrite
Replies: 250
Views: 88393

Re: Call for beta testers: FIQ_FSM USB driver rewrite

No visible improvement on stk1160 Video grabber. Hi Defiant, What command are you using to perform the capture? I've got a em28xx device that I can test for comparison, although I have a feeling that it's just the sheer amount of data that is the issue now. What percentage of CPU is the command con...
by fbutler
Wed Mar 26, 2014 8:47 am
Forum: Graphics, sound and multimedia
Topic: Gstreamer + c920 h.264 + raspberrypi
Replies: 9
Views: 10622

Re: Gstreamer + c920 h.264 + raspberrypi

kansky wrote:Excellent! Thanks. I was debating whether to try the new beta USB code. Now I have a good reason to. I wonder when it will reach the mainline kernel.
Let us know how you get on. It would be good to confirm that you see the same results with the C920.
by fbutler
Mon Mar 24, 2014 7:26 pm
Forum: Graphics, sound and multimedia
Topic: Gstreamer + c920 h.264 + raspberrypi
Replies: 9
Views: 10622

Re: Gstreamer + c920 h.264 + raspberrypi

I can stream over a cross-over Ethernet cable to my desktop, but I have corruption in the video stream no matter what c920 resolution I choose. Same problem if I record to the sd card. I had the same issue with the c920 streaming H.264 however the new FIQ_FSM USB driver appears to have fixed it. Se...
by fbutler
Mon Mar 24, 2014 6:40 pm
Forum: Troubleshooting
Topic: Call for beta testers: FIQ_FSM USB driver rewrite
Replies: 250
Views: 88393

Re: Call for beta testers: FIQ_FSM USB driver rewrite

The BRANCH=next firmware now includes support for FIQ acceleration of high-speed isochronous transactions. jdb, Thanks for the work on this. I've now tested this with the Pi capturing, and streaming, H.264 video from a Logitech c920 webcam. Previously streaming H.264 video using the c920 produced a...
by fbutler
Sat Mar 15, 2014 10:29 am
Forum: Camera board
Topic: Camera Interface Specs
Replies: 353
Views: 66622

Re: Camera Interface Specs

I suppose it would be possible to reverse-engineer the I2C controls and CSI timing ofthe PiCam and make the HDMI capture pretend to be a PiCam so that no Pi software is required. If that can be done then raspivid will capture from it.I can imagine there might be a lot of things to reverse engineer ...
by fbutler
Sun Sep 01, 2013 4:55 pm
Forum: Networking and servers
Topic: Wake on LAN Relay Daemon
Replies: 12
Views: 10483

Re: Wake on LAN Relay Daemon

Hi - great little utility, thank you fbutler! It did not work at first for me. It turned out that the android WoL utility I am using sends 108 bytes but wol-relayd.c checks for the byte count to be exactly 102 bytes. I modified it to demand at least 102 bytes, and ignore any excess. pj I'm glad you...
by fbutler
Wed Jun 19, 2013 5:33 pm
Forum: Camera board
Topic: Alternatives or replacements for camera flex cable?
Replies: 139
Views: 98138

Re: Alternatives or replacements for camera flex cable?

sharix wrote:Thanks for the pics :) but the first link is broken
I believe the broken link should be pointing at:

http://www.bitwizard.nl/rpi/dsc05254.jpg

There's also another photo at:

http://www.bitwizard.nl/rpi/dsc05253.jpg
by fbutler
Sat Jun 15, 2013 7:05 am
Forum: Camera board
Topic: Pi to Pi Bi-Directional Camera Streaming and Preview
Replies: 7
Views: 1525

Re: Pi to Pi Bi-Directional Camera Streaming and Preview

PsycoMEn wrote:Hi fbutler,
Did you experienced any "jumpiness" with the setup after 1 min?
No jumpiness
by fbutler
Mon Jun 10, 2013 8:42 am
Forum: Camera board
Topic: trouble streaming video from raspberry pi to raspberry pi
Replies: 11
Views: 4494

Re: trouble streaming video from raspberry pi to raspberry p

Since the video recording stopped abruptly does that mean the problem is with the sending pi? Thanks again for all the help. No, that just means it gave up because it couldn't connect to the receiving Pi. That's why you run the command on the receiving Pi first. The command on the receiving Pi sits...
by fbutler
Sat Jun 08, 2013 8:31 am
Forum: Camera board
Topic: trouble streaming video from raspberry pi to raspberry pi
Replies: 11
Views: 4494

Re: trouble streaming video from raspberry pi to raspberry p

Also double check that 192.168.1.87 is the IP address of the receiving Pi.
by fbutler
Thu Jun 06, 2013 5:41 pm
Forum: Networking and servers
Topic: SMTP Mail Server Help
Replies: 25
Views: 40089

Re: SMTP Mail Server Help

I've installed ssmtp and mailutils and recreated your setup using my gmail account, and I can send without any issues. However if I change my password to an incorrect password in the ssmtp config file I get exactly the same error message as you. This does suggest there is something incorrect in the ...
by fbutler
Thu Jun 06, 2013 5:10 pm
Forum: Networking and servers
Topic: SMTP Mail Server Help
Replies: 25
Views: 40089

Re: SMTP Mail Server Help

Yeah, i can login to webmail just fine... Could this have anything to with my port choice or ISP? I can't find anyone else with the same error. Are there any alternatives to SSMTP? I've tried Exmi4, but couldn't end my messages for some reason. No, I don't believe so. That error message is coming f...
by fbutler
Thu Jun 06, 2013 4:45 pm
Forum: Networking and servers
Topic: SMTP Mail Server Help
Replies: 25
Views: 40089

Re: SMTP Mail Server Help

Sure, here you go: root=mymail@gmail.com mailhub=smtp.gmail.com:587 hostname=raspberrypi FromLineOverride=YES AuthUser=mymail@gmail.com AuthPass=mypass UseSTARTTLS=YES I'm probably missing something stupid! I don't see anything obviously wrong with that config file as long as you are replacing "mym...
by fbutler
Thu Jun 06, 2013 2:02 pm
Forum: Networking and servers
Topic: SMTP Mail Server Help
Replies: 25
Views: 40089

Re: SMTP Mail Server Help

benhewitt97 wrote:Any ideas? I really don't want to give up on this!
Can you post the details of your ssmtp.conf configuration file?
by fbutler
Wed Jun 05, 2013 6:34 pm
Forum: Raspbian
Topic: Gstreamer 1.0 for raspbian
Replies: 169
Views: 109698

Re: Gstreamer 1.0 for raspbian

Defiant wrote:oh dear...well http://cgit.freedesktop.org/gstreamer/gst-omx/ doesn't have a 1.1 branch yet.
I guess the question is will gst-omx 1.0 work with the 1.1.1 GStreamer version?
by fbutler
Wed Jun 05, 2013 6:22 pm
Forum: Raspbian
Topic: Gstreamer 1.0 for raspbian
Replies: 169
Views: 109698

Re: Gstreamer 1.0 for raspbian

GStreamer 1.0 Packages have been updated to 1.0.7, but that will not fix above problem. This will have to wait until the official 1.0.8 release. So does a new version of gst-omx which depends on new gst-plugins-bad. For info a new development release, GStreamer 1.1.1, is now available.The release a...
by fbutler
Wed Jun 05, 2013 6:13 pm
Forum: Networking and servers
Topic: SMTP Mail Server Help
Replies: 25
Views: 40089

Re: SMTP Mail Server Help

benhewitt97 wrote:I get the error:

Code: Select all

mail: cannot send message: Process exited with a non-zero status
Try running the command with an additional -d parameter to get some more debug information to help determine the cause of the issue:

Code: Select all

echo "Test" | mail -d -s "Test" myemail@mydomain.co.uk
by fbutler
Wed Jun 05, 2013 10:19 am
Forum: Raspbian
Topic: weston-launch - command not found
Replies: 4
Views: 1127

Re: weston-launch - command not found

thanks that worked! used the june 4th version .. very surprised at how small it was! one other thing.. why did my search on the upper right of the page for weston-launch not return anything here? ... That would be because the comment was in the comment thread for this Raspberry Pi announcement here...
by fbutler
Wed Jun 05, 2013 9:44 am
Forum: Raspbian
Topic: weston-launch - command not found
Replies: 4
Views: 1127

Re: weston-launch - command not found

so I've loaded the 5-25 image of raspbian and it works fine and I do see that weston is already @ most current level. tried weston-launch but get command not found.. I don't see any hits for weston-launch when I do a search.. what am I doing wrong here? thanks. See here: http://www.raspberrypi.org/...
by fbutler
Tue Jun 04, 2013 2:49 am
Forum: Camera board
Topic: trouble streaming video from raspberry pi to raspberry pi
Replies: 11
Views: 4494

Re: trouble streaming video from raspberry pi to raspberry p

Thank you! I followed the readme instructions and I no longer get the permissions error. When I execute the nc -p 5001 -l > buffer | /opt/vc/src/hello_pi/hello_video/hello_video.bin buffer command it appears to running, but there is no video or even words like "buffering "10%" or something like tha...

Go to advanced search