Go to advanced search

by michaelfranz
Mon Dec 07, 2015 6:19 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Please run some tests: 1) once in kweb and once in kweb3. 2) If the problem occurs with kweb3, is it possible to run the test in epiphany? You can PM me with more details, This is happening in kweb and I have not yet tried kweb3, maybe I will give it a go. However it turns out that a simple page re...
by michaelfranz
Mon Dec 07, 2015 5:53 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

I am having trouble with kweb eating all my pi's memory. I have created a script which changes the content of a div every ~10 sec. The content is base64 image information and such can be arbitrary long. After approximately one day the browser has eaten all memory and gets killed by the system. Is th...
by michaelfranz
Sat Oct 10, 2015 7:26 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

gkreidl wrote:Try using screen (you have to install it). Just put screen in front of your omxplayer command line,
screen omxplayer ...
Perfect! This fixed it :)

Thanks!
by michaelfranz
Thu Oct 08, 2015 8:26 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

I changed it to just be in the page and not get injected by javascript. And changed the script and video file to 775 Still no luck, maybe this can be a permission error for kweb ? i added sh and i direct path to the script in kweb's allowed commands. Changed the iframe to: <iframe width="2px" src="f...
by michaelfranz
Thu Oct 08, 2015 7:48 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Hi again. Just updated the browser on my raspberry pi to kweb-1.6.8 and facing some troubles. I have a page with the following: <div style="display:none"> <iframe width="2px" src="file:///homepage.html?cmd=sh%20/home/pi/autopres/scripts/settings.sh" height="2px" frameborder="0"></iframe> </div> wher...
by michaelfranz
Mon Jul 13, 2015 11:33 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Hi gkreidl.

I still have the issue described above. :(

Can you maybe link me the previous version 1.4.X ?

Thanks
- Michael Franz
by michaelfranz
Sat Jun 20, 2015 11:23 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

When i add /home/pi/autopres/scripts/video_start.sh to the list of non-terminal scripts in kweb settings it will not show any video ? :( It does when the script its not listed as a non-terminal script. Make sure, that in the script the output of omxplayer is redirected to dev/null (stdout and stder...
by michaelfranz
Sat Jun 20, 2015 11:10 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Try with "...cmd=/home/pi.." (without the "sh%20" in front. Thanks this works, however I will have to write down all my scripts in the configuration so that a terminal wont show each time I run a script. :) But works :) - Thanks :) When i add /home/pi/autopres/scripts/video_start.sh to the list of ...
by michaelfranz
Sat Jun 20, 2015 10:33 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

gkreidl wrote:Try with "...cmd=/home/pi.." (without the "sh%20" in front.
Thanks this works, however I will have to write down all my scripts in the configuration so that a terminal wont show each time I run a script. :)

But works :) - Thanks :)
by michaelfranz
Sat Jun 20, 2015 10:12 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Hi again. Just updated to your latest kweb version and have an error when trying to show a video from kweb. I have the file: <html> <head> <meta charset="UTF-8"> <title>Autopres</title> </head> <body> <iframe width="2px" src="file:///homepage.html?cmd=sh%20/home/pi/autopres/scripts/video_start.sh%20...
by michaelfranz
Mon May 11, 2015 7:36 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

You first kiosk script didn't contain the keyboard chars, which means, keyboard control is disabled. This may seem to be overly complex, but I wanted the developer of embedded applications to decide, which keyboard commands his application is allowed to use. Ah, nice, that makes much more sense now...
by michaelfranz
Mon May 11, 2015 12:43 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

What does your kiosk script look like? As a final try I tried to change my kiosk script from: #!/bin/sh matchbox-window-manager & kweb -CKJA file:///home/pi/autopres/player/index.html to: #!/bin/sh matchbox-window-manager & kweb -CAKJ+­zbhrqfpoklgtjneduwxyavcsmi file:///home/pi/autopres/player/inde...
by michaelfranz
Mon May 11, 2015 12:28 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Check my xdotool example in the kweb manual. Hi again. After a lot of trying I still dont have this working :( Here is my application: <html> <head> <meta charset="UTF-8"> <title>Loading settings</title> </head> <body> <div style="display:none"> <iframe width="2px" src="file:///homepage.html?cmd=sh...
by michaelfranz
Sun May 10, 2015 8:45 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Hi again. I have my kweb application where I loop over several video files starting each video with omxplayer. Now I need to detect when omxplayer has finished showing the video and start the next. You mentioned earlier that you can think of several ways to see if omxplayer has finished? Earlier I j...
by michaelfranz
Mon Apr 27, 2015 11:39 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

gkreidl wrote:Perhaps you are creating a huge number of child processes which never finish. But I need to know your application to get any idea.
I can send you my application, can you PM me you email or how do you want it ?
by michaelfranz
Mon Apr 27, 2015 10:29 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Hi again. Still have some trouble with kweb, I get an out of memory error: [ 0.000000] Booting Linux on physical CPU 0xf00 [ 0.000000] Initializing cgroup subsys cpu [ 0.000000] Initializing cgroup subsys cpuacct [ 0.000000] Linux version 3.18.7-v7+ ([email protected]) (gcc version 4.8.3 20140303 (...
by michaelfranz
Tue Apr 21, 2015 6:15 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Fast working! :) Works like a charm!
Thanks a lot :)
by michaelfranz
Tue Apr 21, 2015 5:10 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Thanks for your response :) Im glad I wasn't the only one having this issue, hopefully the bug is fixable :) My development progress is actually stopped right now due to this bug so if there is anything at all which I can help with to speed up the progress for fixing this bug, please dont hesitate t...
by michaelfranz
Tue Apr 21, 2015 1:11 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

Still out of luck here :( omxplayer is starting but it does not show any video and I can see omxplayer is started from kweb and runs in the background and never stops. I have tried to call a shell script: file:///homepage.html?cmd=sh%20/home/pi/playvideo.sh where both sh and /home/pi/playvideo.sh is...
by michaelfranz
Mon Apr 20, 2015 1:19 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

I believe other commands lige xset are working properly :)
by michaelfranz
Mon Apr 20, 2015 8:41 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

gkreidl wrote:Send me your kiosk script.
Just sent you a PM :)
by michaelfranz
Mon Apr 20, 2015 8:02 am
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

1) I wouldn't use openbox for a pure kiosk application; matchbox-window-manager is much better suited for that. And the taskbar tint2 is useless in this case. If you use openbox without a startup application it won't show until you press a key or move the mouse (bug) 2) kweb has not crashed as I ca...
by michaelfranz
Sun Apr 19, 2015 8:28 pm
Forum: Graphics, sound and multimedia
Topic: RPi touchscreen with video
Replies: 66
Views: 7653

Re: RPi touchscreen with video

I can see that I get the following error: Fatal Python error: exceptions bootstrappIng error. If the Python script is the last program in your (xinit) script the script will break and kweb will be closed. Okay so im on a fresh installation of Raspbian with kweb installed and I am trying to run a si...
by michaelfranz
Sun Apr 19, 2015 7:04 pm
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1524
Views: 636775

Re: Minimal Kiosk Browser

Perfect :) that did the trick :) perhaps others make the same mistake :) Maybe you should put it in the 4 lines for installation ?
by michaelfranz
Sun Apr 19, 2015 5:08 pm
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1524
Views: 636775

Re: Minimal Kiosk Browser

Just tried again with a new download.

Still not working:
http://michaelfranz.dk/IMG_2167.JPG

Look like something at raspbian.org is down?

Go to advanced search