Go to advanced search

by ImmerStudent
Fri Mar 20, 2015 12:24 pm
Forum: Scratch
Topic: Mesh and Scratch
Replies: 3
Views: 1068

Re: Mesh and Scratch

Thanks guys. Tim's solution works.
by ImmerStudent
Mon Mar 16, 2015 4:19 am
Forum: Scratch
Topic: Mesh and Scratch
Replies: 3
Views: 1068

Mesh and Scratch

Hi, I'm trying to enable Mesh using Scratch. I click on the 'R' in the Scratch log, then on 'turn fill screen off' as instructed. But I get an error message window headed 'Subclass Responsibility: My ScratchPangoFont subclass'.
Any ideas please?
by ImmerStudent
Mon Mar 16, 2015 2:15 am
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 7169

Re: Piface2 setup - no spi_bcm2708 (solved)

Dougie, I started in mainframe in 1978. Which doesn't alter the fact that I'm new to the chaos that is Linux.

Mike, I had already tried updating config.txt . Didn't work for me, so I went for the KISS solution.
by ImmerStudent
Sat Mar 14, 2015 4:28 am
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 7169

Re: Piface2 setup - no spi_bcm2708

Hi Dougie. I cut the Gordian knot by removing Berryboot from the equation and just using standalone Raspbian. Now the Piface works and I can find spidev0.0 etc! So I can assume that Berryboot is the issue and I will leave the research to make Piface work with it to others more qualified. As a former...
by ImmerStudent
Fri Mar 13, 2015 11:14 pm
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 7169

Re: Piface2 setup - no spi_bcm2708

Yes, I am using Berryboot. I have no idea how to change the boot parameters for Berryboot itself. Therefore are you saying that if I want to use Piface, I can't use Berryboot? That is sad, as I've set up a lot of stuff in the Raspbian image.
by ImmerStudent
Fri Mar 13, 2015 11:55 am
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 7169

Re: Piface2 setup - no spi_bcm2708

Yes, I did a reboot, I am running raspbian, I did an update/upgrade and I updated the firmware and I had already enabled SPI in config.txt (dtparam=spi=on). The version of Raspbian (from uname -r) is 3.18.6-v7i-aufs The output from spidev.sh is: <output> Adding pi to spi group .. groupadd: group 'sp...
by ImmerStudent
Fri Mar 13, 2015 3:54 am
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 7169

Re: Piface2 setup - no spi_bcm2708

Thanks, I executed the 3 commands successfully, but I still get 'no such device' when I execute modprobe spi-bcm2708
by ImmerStudent
Wed Mar 11, 2015 1:32 am
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 7169

Piface2 setup - no spi_bcm2708 (solved)

Hi, I'm trying to set to PiFace Digital 2. I've followed all the instructions, enabled SPI using raspi-config, rebooted, commented out SPI_BCM2708 in the blacklist and run spidev setup. sudo modprobe spi-bcm2708 returns 'no such file or device' and spidev0.0 is not in dev. Therefore blink.py fails. ...

Go to advanced search