Go to advanced search

by SirPali
Fri Dec 11, 2015 11:11 am
Forum: Troubleshooting
Topic: Serial port wont stop giving errors
Replies: 5
Views: 5392

Re: Serial port wont stop giving errors

I would look for other programs using the same device or check you have accidentally started multiple instances of your script. "ps aux" or "ps -ef" to list all running processes. "lsof" is a command that will list *all* open files on your system with name and number o...
by SirPali
Thu Dec 10, 2015 9:53 am
Forum: Python
Topic: Problem with serial port
Replies: 11
Views: 13699

Re: Problem with serial port

Exactly the same problem here... I'm monitoring information from a cash drawer which continuously (every 1 or 2 seconds) sends a few characters. Disabling the serial console did not work for me.. Also it is connected to ttyUSB0 instead of ttyAMA0. Would be very very happy if anyone could help me out...
by SirPali
Tue Dec 08, 2015 1:09 pm
Forum: Troubleshooting
Topic: Serial port wont stop giving errors
Replies: 5
Views: 5392

Re: Serial port wont stop giving errors

Would it help to slow down the rate at which you attempt to read from the serial port? [That is, the time between successive calls to readline() - not the baudrate.] I tried to do that but it didn't solve my problem. I created a new try except which restarts the whole script instead of a new try on...
by SirPali
Sat Nov 28, 2015 2:05 pm
Forum: Troubleshooting
Topic: Serial port wont stop giving errors
Replies: 5
Views: 5392

Re: Serial port wont stop giving errors

Does anyone have any idea what this might be? It's driving me up the walls.
by SirPali
Thu Nov 26, 2015 4:13 pm
Forum: Troubleshooting
Topic: Serial port wont stop giving errors
Replies: 5
Views: 5392

Serial port wont stop giving errors

I am using a USB to Serial cable to monitor data which is sent from a computer to printer. The problem is that my script seems to work out fine 3/4 of the time but I cant find out why the failures keep happening. I tried the following: Python script (automatically starts up 30 seconds after boot): s...
by SirPali
Tue Jun 16, 2015 9:46 am
Forum: Troubleshooting
Topic: Pi2 showing old LXDE desktop until calling startx manually
Replies: 0
Views: 424

Pi2 showing old LXDE desktop until calling startx manually

Hey guys, I ran into a bit of a weird issue. The last few days I have been messing around with ssh and vnc, and installed TightVNC on my Pi 2. I ran into the issue described here : and had trouble logging in. I followed the steps here to get the Pi to start up normally again, but now it is showing t...
by SirPali
Fri Jun 05, 2015 9:29 am
Forum: Raspberry Pi OS
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1596
Views: 803099

Re: Minimal Kiosk Browser

I just realized I never followed up on my post here: https://www.raspberrypi.org/forums/viewtopic.php?p=741303#p741303 but we are using the normal kweb, not kweb3. Since we're letting our pi's reboot at night we haven't run into this problem anymore but I'll gladly supply you with more information i...
by SirPali
Thu Jun 04, 2015 7:19 am
Forum: Troubleshooting
Topic: Pi boots, connects to web, but displays a black screen
Replies: 3
Views: 597

Re: Pi boots, connects to web, but displays a black screen

Well, I decided to make the trip with a new SD card for the client. Luckily we had a backup of their system and all content was stored online, so there were no problems. However, I have the old, possibly corrupted SD card in my possesion now, and I would like to find out what is wrong with it. I tri...
by SirPali
Wed Jun 03, 2015 8:01 am
Forum: Troubleshooting
Topic: Pi boots, connects to web, but displays a black screen
Replies: 3
Views: 597

Re: Pi boots, connects to web, but displays a black screen

This is just a guess. There isn't enough free memory for X to run. Temporary files are not being deleted before the daily reboot. If my guess is correct you owe me 10% of the fee you charge the client. :) If that's it I will gladly send you 10% of the fee ;) We have a similar setup as our clients r...
by SirPali
Wed Jun 03, 2015 7:46 am
Forum: Troubleshooting
Topic: Pi boots, connects to web, but displays a black screen
Replies: 3
Views: 597

Pi boots, connects to web, but displays a black screen

Hey guys, One of my clients just called me saying their kiosk system went down. Since this client is a 3 hours drive away from me, I'd like to do some troubleshooting before I go over there. What is happening is the following: Every day at 6 am, the Pi reboots itself to make sure everything is still...
by SirPali
Fri Apr 17, 2015 1:20 pm
Forum: Raspberry Pi OS
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1596
Views: 803099

Re: Minimal Kiosk Browser

We've been using the Kweb browser for a while on a few of our kiosk terminals now and haven't really run into large issues lately. However, we've noticed the browser crashing after running more than 24 hours. In this case the entire browser is closed. We haven't pinpointed the exact moment of crashi...
by SirPali
Fri Mar 13, 2015 3:45 pm
Forum: Raspberry Pi OS
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1596
Views: 803099

Re: Minimal Kiosk Browser

I have created a products page showing a list of products that refreshes to show now products every 10 seconds. Each product has an image associated with it, and to minimize the amount of visible image loading I preload these images using Javascript. The images are supplied with a caching header sta...
by SirPali
Mon Feb 23, 2015 3:46 pm
Forum: Raspberry Pi OS
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1596
Views: 803099

Re: Minimal Kiosk Browser

gkreidl wrote:That's beyond anything I can do (depends on the webkit engine I'm using). When we migrate to Jessie a newer version should become available.
Figured as much. Not a problem! Other than this the browser runs perfect for us, so we've got nothing to complain :)
by SirPali
Mon Feb 23, 2015 12:05 pm
Forum: Raspberry Pi OS
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1596
Views: 803099

Re: Minimal Kiosk Browser

The browser has been working like a charm for us lately! We only ran into one small issue. While text-shadows are supported in css, drop-shadows on images are not. I tried using the webkit css command -webkit-filter: drop-shadow(5px 5px 2px rgba(0,0,0,0.75)); on kweb and kweb3, but neither seems to ...
by SirPali
Thu Feb 19, 2015 10:22 am
Forum: Raspberry Pi OS
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1596
Views: 803099

Re: Minimal Kiosk Browser

I have a quick question about loading images using kweb3. I have a kiosk page which basically loops through a number of images with 4 images showing in a grid every X seconds. I am using Javascript to replace the old images with the new ones when the timer runs out. With kweb, this works fine until ...
by SirPali
Wed Feb 11, 2015 3:26 pm
Forum: Troubleshooting
Topic: Red led blinks once during boot, boot stops
Replies: 7
Views: 1642

Re: Red led blinks once during boot, boot stops

Hey guys, Thanks for all the replies! Based on what you guys said I tried several more adapters (working at a phone company has its perks), and finally found one that works. Funny thing is, it's the exact same model as I have tried before, just a different unit. Now the Pi receives its power consist...
by SirPali
Mon Feb 09, 2015 11:07 am
Forum: Troubleshooting
Topic: Red led blinks once during boot, boot stops
Replies: 7
Views: 1642

Red led blinks once during boot, boot stops

Hey all, I recently received my Pi 2, and have been having problems getting it to run. First I ran into some issues getting the Pi to recognize my SD cards. After trying several SD cards which resulted in a solid green led after putting Noobs on it, I found one that works. While the Pi is booting (g...

Go to advanced search